LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-05-2004, 01:50 AM   #1
Corlinux
LQ Newbie
 
Registered: Apr 2004
Distribution: Red Hat 9
Posts: 15

Rep: Reputation: 0
¿Why RPM installs doesn't work on my red hat 9 linux system?


I cannot install any program with RPM, i make a double click over the file and it says that is checking to install but it never does it.. I tried to install with the command line (terminal) but it doesn't work too..

How can i fix this problem?
 
Old 04-05-2004, 01:53 AM   #2
basse-
LQ Newbie
 
Registered: Mar 2004
Location: Tampere, Finland
Distribution: Gentoo 2004.3, Ubuntu
Posts: 15

Rep: Reputation: 0
Does it give you an error message when installing from terminal? And if yes, what?
 
Old 04-05-2004, 02:37 AM   #3
Corlinux
LQ Newbie
 
Registered: Apr 2004
Distribution: Red Hat 9
Posts: 15

Original Poster
Rep: Reputation: 0
It says there are some errors

I tried to install some programs, when i try to install them with the terminal it always says that there is problem with MD5SUM, but i downloaded those programs of the linux.org homepage.

I'm a new linux user so i dont know many things about it, a friend installed some of those programs on his system and he says that it works.

Thanks for your answer and your help.
 
Old 04-05-2004, 08:47 AM   #4
basse-
LQ Newbie
 
Registered: Mar 2004
Location: Tampere, Finland
Distribution: Gentoo 2004.3, Ubuntu
Posts: 15

Rep: Reputation: 0
My machine gives me that warning as well, but the programs is still installed succesfully. Note that it's only a warning, not an error. The difference is that warning doesn't (usually?) stop the process, but error does.

You can verify the package is installed my typing:

$ rpm -q [package name without versions numbers and stuff, eg. perl]

If it's installed, it echoes back the package name and version. If it ain't installed, you get something like "package x is not installed".
 
Old 04-05-2004, 10:23 AM   #5
chem1
Member
 
Registered: Jun 2002
Location: White House, Washignton DC
Distribution: Red Hat 9
Posts: 270

Rep: Reputation: 30
THe Packager Program with Red Hat 9.0 is broken (for some reason). It used to work OK but suddenly stopped working on my machine like 2 months back. I always use the command
rpm -Uvh nameofrpm.rpm

Hope this helps...
 
Old 04-05-2004, 11:16 AM   #6
Corlinux
LQ Newbie
 
Registered: Apr 2004
Distribution: Red Hat 9
Posts: 15

Original Poster
Rep: Reputation: 0
Unhappy It doesn't work....

Thanks for your help... I already tried with rpm -q... but it says that the package is not installed and trying with rpm -Uvh... it gives me the same error: MD5 digest: BAD Expected and compares 2 numbers.

I tried so many ways to do it but it isn't working yet. It always gives the same error, but when i try double clicking the desktop icon to install it, the program says that is checking the package and finishes there.
 
Old 04-05-2004, 11:51 AM   #7
chem1
Member
 
Registered: Jun 2002
Location: White House, Washignton DC
Distribution: Red Hat 9
Posts: 270

Rep: Reputation: 30
Where did you get the RPMS from? I have done a Google search for this problem and most of the time its a bad download: corrupt or incomplete file etc.

Try downloading the file again

Hope this helps...
 
Old 04-05-2004, 05:01 PM   #8
Corlinux
LQ Newbie
 
Registered: Apr 2004
Distribution: Red Hat 9
Posts: 15

Original Poster
Rep: Reputation: 0
I dont know whats going on...

Sorry, i tried downloading the files again but i didn't work.

I read something about an ID of the file that RPMS checks when its going to install a package, something about MD5SUM, but i dont know anything about it, do ya?

I could install a RPM package by double clicking the desktop icon, but only one...
 
Old 04-05-2004, 07:13 PM   #9
kcender
Member
 
Registered: Apr 2004
Posts: 30

Rep: Reputation: 15
i have never had this problem, but since you say you got one to install, then it must mean the others are corrupted, try running a google search for the same rpm's and downloading from a different mirror, then install using rpm -Uvh <file>
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
trying to install Red Hat EL 3 on AMD64, but it installs 32-bit dewaldc Linux - Newbie 1 10-05-2005 06:33 AM
Does Red Hat 7 RPM packages work also for Fedora Core 3? excidy Linux - Software 1 04-03-2005 08:31 PM
How P IV system work fast with Red Hat Linux 8, I recompile the kernel also. benoy4007 Red Hat 2 06-12-2004 04:49 AM
Red Hat 9 Installs to Completeion, but wont boot from Floppy kkathman Linux - Newbie 2 10-05-2003 07:39 PM
rpm --rebuild can't work in Red Hat 8.0 explorer1979 Linux - General 1 10-15-2002 11:26 PM


All times are GMT -5. The time now is 06:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration