LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-07-2009, 12:39 AM   #1
wongdg
Member
 
Registered: May 2006
Location: Kuching, Malaysia
Distribution: Debian 2.4 & 2.6
Posts: 42

Rep: Reputation: 16
Lightbulb [SOLVED] VLC shows no image after upgrade


distro: Debian amd64
upgrade from lenny to testing

VLC is obviously a new version as its interface looks different and by default it opens the image in a separate window.

The newly upgraded VLC shows no image but sound regardless what video files I throw at it. It used to be working perfectly before the upgrade.

Several recommendations did not work for me, including setting the video output to x11 or openGL.

The error message:
Under "Tools" -> "Messages" it gave

main error: no video filter module matched "adjust"
main error: no suitable vout module
main error: failed to create video output

My solution:
delete away "vlc" directory
home$ .local/share/vlc

set your VLC preferences to default

and voila! It worked for me after several days effort of finding the net.
Do remember to share your experience, solutions with us all of the open source community. That is what Linux/GNU community is about.

Regards,
Wilson
 
Old 07-08-2009, 02:58 AM   #2
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,475

Rep: Reputation: 87
Fanx for posting that fix.

Have you tried MPlayer as a general movie player?

I've found it much easier to compile and install than VLC, it seems to play many more formats and comes with a powerful associated encoding utility.

XINE is good for playing DVDs with good DVD menu support as well.
 
Old 09-01-2011, 11:57 PM   #3
tux_addict
Member
 
Registered: Dec 2004
Location: Nairobi, Kenya
Distribution: Vector Linux 7.0, Ubuntu 13.04
Posts: 87

Rep: Reputation: 15
Mplayer

I definitely second the suggestion to use Mplayer! I ended up on this thread while struggling to get VLC to play video. I think I'll just settle with Smplayer/Mplayer.
 
  


Reply

Tags
error, image, vlc


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Totem has no sound after dist-upgrade wongdg Linux - Software 1 06-25-2009 08:17 AM
No keyboard or mouse with full upgrade of Sid - solved propofol Debian 0 06-10-2009 01:46 AM
SOLVED Sax config shows up on non-existent screen jcllings Linux - Desktop 0 02-17-2009 09:18 AM
SOLVED: Intel Wifi not working after Ubuntu 8.10 upgrade? ronaldv Ubuntu 1 12-12-2008 02:08 AM
Recent Upgrade Broke Xscreensaver (solved) kevinbenko Debian 0 11-14-2008 11:37 AM


All times are GMT -5. The time now is 01:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration