LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-20-2003, 01:06 PM   #1
Yttrium
LQ Newbie
 
Registered: Oct 2002
Location: belgium
Distribution: redhat 9.0
Posts: 7

Rep: Reputation: 0
[redhat9.0] XWindows doesn't start anymore?


suddenly from one day up another i got this error and i haven't installed anything new or deleted stuff? with redhat 8.0 i also got that error but the i just installed it again but this time i really want the answer for this error it's driving me crazy especially since i don't see anything about bitmap module in the config file?

if anybody can help, please tell me ... i want my linux back ;-)

XFree86.setup.log:

XFree86 Version 4.3.0 (Red Hat Linux release: 4.3.0-2)
Release Date: 27 February 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.20-3bigmem i686 [ELF]
Build Date: 27 February 2003
Build Host: porky.devel.redhat.com

Before reporting problems, check http://www.XFree86.Org/
to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.4.20-8 (bhcompile@porky.devel.redhat.com) (gcc version 3.2.2 20030222 (Red Hat Linux 3.2.2-5)) #1 Thu Mar 13 17:54:28 EST 2003
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Sat May 17 14:05:02 2003
(==) Using config file: "/etc/X11/XF86Config"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "Videocard0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc102"
(**) XKB: model: "pc102"
(**) Option "XkbLayout" "be"
(**) XKB: layout: "be"
(==) Keyboard: CustomKeycode disabled
(**) |-->Input Device "DevInputMice"
(**) FontPath set to "unix/:7100"
(**) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(++) using VT number 7

(II) Open APM successful
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.2
XFree86 Video Driver: 0.6
XFree86 XInput driver : 0.4
XFree86 Server Extension : 0.2
XFree86 Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(WW) Warning, couldn't open module bitmap
(II) UnloadModule: "bitmap"
(EE) Failed to load module "bitmap" (module does not exist, 0)
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6

Fatal server error:
Unable to load required base modules, Exiting...


When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to xfree86@xfree86.org.
 
Old 07-20-2003, 01:40 PM   #2
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
What video card are you using?

Google hits for your error.

# Configuring X
Linux Hardware Compatibility HOWTO - video cards
The Linux XFree86 HOWTO
Common X configuring tools:
Redhat 7.3 down - the setup utility leads to several config tools
Redhat 7.3 up - redhat-config-xfree86
You may have these tools:
XF86Setup
XFree86 -configure
Xconfigurator
xf86cfg
xf86config
xconf
ATI Linux drivers
If you need the nVidia driver, most likely, you want the Linux IA32 driver

# Redhat links
RedHat Linux Manuals
Get your mp3 support here
Maximum RPM
rpmfind
Easier software management: apt4rpm - Red Carpet
RedHat 8.0 Tips & Tricks

# Redhat 7.3 down configuration commands
setup leads to several configuration tools

# Redhat 7.3 up configuration commands
Configure soundcard:
redhat-config-soundcard
Configure X server:
redhat-config-xfree86
Configure network:
redhat-config-network
Manage software:
redhat-config-packages

# Handling NTFS
New Technology FileSystem (NTFS) HOWTOs
Linux NTFS project
 
Old 07-21-2003, 06:37 AM   #3
Yttrium
LQ Newbie
 
Registered: Oct 2002
Location: belgium
Distribution: redhat 9.0
Posts: 7

Original Poster
Rep: Reputation: 0
in that machine i'm running a 3d prophet 4500! the configuration commands you've giving me i already tried (they were the first things i tried, even changed the videocard) and i don't see what NTFS has to do with this problem? i also looked at google (the second thing i tried) and look at the other bugs but nothing seems to work! tried to update (with the same version but didn't want to because it said it was installed and when i wanted to uninstall it it said it wasn't there)... so you see i already tried lots of stuff!!!

today i just thought of changing the rpmpkgs-file and reinstalling XFree86 4.3.0! maybe that will help! because it seems some modules aren't there so maybe by reinstalling the X it places the libs again! we'll see
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome won't start anymore... DJ_Cyberdance Linux - Software 3 08-19-2006 08:51 AM
Gimp 2 doesn't start anymore? toyotadesigner Linux - Software 1 10-21-2005 09:42 PM
X does not start anymore foxy123 SUSE / openSUSE 10 03-09-2005 05:09 PM
Upgrade Redhat9 to FC2, cannot enter Xwindows: mouse0 core point error???? GingoTree Red Hat 0 09-15-2004 01:19 AM
X doesn't start anymore big_gie Linux - Software 12 07-11-2004 12:10 AM


All times are GMT -5. The time now is 09:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration