LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-22-2002, 04:30 PM   #1
MrGreg
Member
 
Registered: Apr 2001
Location: Hamilton
Distribution: RedHat 7.2, 9.0
Posts: 52

Rep: Reputation: 15
[aviplay, mplayer, ASX, ASF]


Greetings All,

I have a problem where a specific asx file pointing to an asf stream is not working for aviplay. I believe I have all the latest packages neccessary.

The best way for me to demonstrate this problem is by throwing two sample streams at you for evaluation.

This audio stream is from the Jeff Rense program broadcast live 7-10pm Pacific or 10pm-1am EDT. It will not play at all claiming audio/video stream not detected--cannot play this--(operation now in progress).

http://crncast.com/Rense3.asx

However, this clip of Billy Gates own speech from 2002's International Consumer Electronics Show, with both audio and video plays perfectly.

High speed 256kbps:

http://www.microsoft.com/winme/0201/17112/ces256.asx

Low speed 56kbps

http://www.microsoft.com/winme/0201/17112/ces56.asx

I sure would appreciate someone more knowlegeable than myself (mostly everyone here) give these streams a try using aviplay and offer some constructive feedback. I am all but convinced that CRMedia is just totally inept at formatting and redirecting a proper asf stream.

Your thoughts_____________?
 
Old 11-22-2002, 07:24 PM   #2
Hitokiri_X
Member
 
Registered: Mar 2002
Distribution: Slackware Current
Posts: 99

Rep: Reputation: 15
The first link doesn't work at all and I don't think it will.I get a 400:Bad Request trying to connect with mplayer.The second ones work fine for me too with mplayer.
 
Old 11-22-2002, 11:11 PM   #3
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 55
Well, they all work with mplayer, first I guess is an internet radio stream, the other is a video of CES presentation with bg performing all blah-blah-blah, note you need directShow codecs to see it. Well they are available at
ftp://mplayerhq.hu/MPlayer/releases as w32codecs just untar+ungzip tarball and move it to $MPLAYER_LIBS/win32 directory
 
Old 11-23-2002, 08:15 AM   #4
MrGreg
Member
 
Registered: Apr 2001
Location: Hamilton
Distribution: RedHat 7.2, 9.0
Posts: 52

Original Poster
Rep: Reputation: 15
same

Thanks for the replies,

But I'm confused with the dissenting results:

Quote:
The first link doesn't work at all and I don't think it will.I get a 400:Bad Request trying to connect with mplayer.
Quote:
Well, they all work with mplayer, first I guess is an internet radio stream
I haven't tried mplayer having read somewhere that it didn't support asf. Something is just not right with the http://crncast.com/Rense.asx file and subsequent stream it points to. I will try to install mplayer and see if that works instead of using aviplay for this particular stream...

Thanks again,
 
Old 11-23-2002, 08:18 AM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,384

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
mplayer can play *most* asf streams now, been up for a couple of months
 
Old 11-23-2002, 09:48 AM   #6
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 55
And Mplayer does play the stream from http://crncast.com/Rense3.asx

Last edited by neo77777; 11-23-2002 at 09:51 AM.
 
Old 11-23-2002, 11:45 AM   #7
MrGreg
Member
 
Registered: Apr 2001
Location: Hamilton
Distribution: RedHat 7.2, 9.0
Posts: 52

Original Poster
Rep: Reputation: 15
Thanks neo77777,

I was looking for an alternative to avifile and mplayer fit the Bill (pun) perfectly.

FWIW Hitokiri_X, I also recieved a "server return 404:Object Not Found" but the stream does play. I am currently testing it with an archived (WMA) show and it is playing perfectly.

mplayer -v http://crncast.com/Archives/10-31-02.asx -cache 256

I don't know why aviplay fails. I used all the packages for mplayer from the link I found elsewhere in this HANDY forum.

http://www.mplayerhq.hu/homepage/

Thanks Ya'll for taking time to help a fellow Linux user in distress,
 
Old 11-25-2002, 08:41 AM   #8
MrGreg
Member
 
Registered: Apr 2001
Location: Hamilton
Distribution: RedHat 7.2, 9.0
Posts: 52

Original Poster
Rep: Reputation: 15
I spoke too soon....the stream will not play! http://crncast.com/Rense3.asx 7-10 EDT weekdays.

[mr6re9@mr6re9 mr6re9]$ mplayer -v http://crncast.com/Rense3.asx -cache 128
Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/share/locale

MPlayer 0.90pre10-RPM-3.1 (C) 2000-2002 Arpad Gereoffy (see DOCS)

CPU: Advanced Micro Devices Duron SF Spitfire (Family: 6, Stepping: 1)
CPUflags: MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 0 SSE2: 0
Compiled with RUNTIME CPU Detection - warning, it's not optimal! To get best performance, recompile MPlayer with --disable-runtime-cpudetection
Reading /home/mr6re9/.mplayer/codecs.conf: can't open '/home/mr6re9/.mplayer/codecs.conf': No such file or directory
Reading /etc/mplayer/codecs.conf: 44 audio & 110 video codecs
CommandLine: '-v' 'http://crncast.com/Rense3.asx' '-cache' '128'
get_path('font/font.desc') -> '/home/mr6re9/.mplayer/font/font.desc'
font: can't open file: /home/mr6re9/.mplayer/font/font.desc
font: can't open file: /usr/share/mplayer/font/font.desc
Using MMX (with tiny bit MMX2) Optimized OnScreenDisplay
Linux RTC init error in ioctl (rtc_irqp_set 1024): Permission denied
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup
scripts.
Using usleep() timing
get_path('input.conf') -> '/home/mr6re9/.mplayer/input.conf'
Can't open input config file /home/mr6re9/.mplayer/input.conf : No such file or
directory
Parsing input config file /etc/mplayer/input.conf
Input config file /etc/mplayer/input.conf parsed : 50 binds

Playing http://crncast.com/Rense3.asx
Resolving crncast.com ...
Connecting to server crncast.com[66.250.26.163]:80 ...
--- HTTP DEBUG HEADER --- START ---
protocol: [HTTP/1.1]
http minor version: [1]
uri: [(null)]
method: [(null)]
status code: [200]
reason phrase: [OK]
body size: [901]
Fields:
0 - Server: Microsoft-IIS/5.0
1 - Date: Mon, 25 Nov 2002 04:43:35 GMT
2 - Content-Type: video/x-ms-asf
3 - Accept-Ranges: bytes
4 - Last-Modified: Mon, 25 Nov 2002 03:43:35 GMT
5 - ETag: "c6d0fcd43494c21:b6c"
6 - Content-Length: 901
--- HTTP DEBUG HEADER --- END ---
Content-Type: [video/x-ms-asf]
Content-Length: [901]
Trying ASF/HTTP...
Resolving crncast.com ...
Connecting to server crncast.com[66.250.26.163]:80 ...
=====> ASF Redirector
Connected to server: crncast.com
Parsing playlist http://crncast.com/Rense3.asx...
Trying asx...
Detected asx format
Adding file mms://66.250.26.164/Jrense2 to element entry
Playlist succefully parsed

Playing mms://66.250.26.164/Jrense2
Trying ASF/HTTP...
Connecting to server 66.250.26.164:80 ...
=====> ASF Live stream
=====> ASF header chunk follows
=====> ASF header chunk follows
=====> ASF header chunk follows
=====> ASF header chunk follows
=====> ASF header chunk follows
=====> ASF header chunk follows
=====> ASF header chunk follows
=====> ASF header chunk follows
=====> ASF header chunk follows
Stream bitrate properties object
Max bandwidth set to 0
Connecting to server 66.250.26.164:80 ...
=====> ASF Live stream
Cache size set to 128 KBytes
Connected to server: 66.250.26.164
CACHE_PRE_INIT: 0 [0] 0 pre:0 eof:0
Cache fill: 0.00% (0 bytes) =====> ASF header chunk follows
Cache fill: 0.00% (0 bytes) =====> ASF header chunk follows
Cache fill: 0.00% (0 bytes) =====> ASF header chunk follows
Cache fill: 0.00% (0 bytes) =====> ASF header chunk follows
Cache fill: 0.00% (0 bytes) =====> ASF header chunk follows
Cache fill: 0.00% (0 bytes) =====> ASF header chunk follows
Cache fill: 0.00% (0 bytes) =====> ASF header chunk follows
Cache fill: 0.00% (0 bytes) =====> ASF header chunk follows
Cache fill: 0.00% (0 bytes) =====> ASF header chunk follows
Cache fill: 18.75% (24576 bytes) Detected ASF file format!

Title: The Jeff Rense Program
Author: CRN Media
Copyright: ? 2002 - Jeff Rense & CRN Media
Comment:
Rating:

============ ASF Stream group == START ===
object size = 32
stream count=[0x1][1]
stream id=[0x1][1]
max bitrate=[0x2231][8753]
============ ASF Stream group == END ===
ASF: packets: -1 flags: 9 max_packet_size: 331 min_packet_size: 331 max_bitrate: 8753 preroll: 3000
stream type: guid_audio_stream
stream concealment: guid_audio_conceal_interleave
type: 64 bytes, stream: 8 bytes ID: 1
unk1: 0 unk2: 6CCE6200
FILEPOS=0xA1B
==> Found audio stream: 1
======= WAVE Format =======
Format Tag: 10 (0xA)
Channels: 1
Samplerate: 8000
avg byte/sec: 1000
Block align: 300
bits/sample: 16
cbSize: 46
Unknown extra header dump: [10] [0] [4] [0] [0] [0] [0] [0] [0] [0] [0] [0] [0]
[0] [0] [0] [0] [0] [cf] [88] [1a] [0] [5] [c9] [2d] [49] [90] [19] [40] [0] [0] [0] [0] [0] [0] [0] [0] [0] [0] [0] [0] [0] [0] [0] [0] [0]
ASF: audio scrambling: 1 x 1 x 300
Found movie at 0xA95 - 0xA95
ASF: 1 audio and 0 video streams found
ASF: Searching for audio stream (id:-1)
Auto-selected ASF audio ID = 1
Clip info:
name: The Jeff Rense Program
author: CRN Media
copyright: ? 2002 - Jeff Rense & CRN Media
comments:
==========================================================================
get_path('codecs.conf') -> '/home/mr6re9/.mplayer/codecs.conf'
*** Try to upgrade /home/mr6re9/.mplayer/codecs.conf from etc/codecs.conf
*** If it still does not work, read DOCS/codecs.html!
Can't find codec for audio format 0xA!
==========================================================================
Audio: no sound!!!
Freeing 0 unused audio chunks
Video: no video!!!
Freeing 0 unused video chunks

DEMUXER: freeing demuxer at 0x8336190
DEMUXER: freeing sh_audio at 0x8336b48
vo: x11 uninit called but X11 not inited..

Exiting... (End of file)

I have tried many options with basically the same results including:

-ao alsa9

So many options to choose from, I wish I knew the combo that works.
 
Old 11-25-2002, 09:19 AM   #9
neo77777
LQ Addict
 
Registered: Dec 2001
Location: Brooklyn, NY
Distribution: *NIX
Posts: 3,704

Rep: Reputation: 55
Do you have Mplayer compiled with win32 codecs enabled and w32codecs installed? If not get the codecs at
ftp://mplayerhq.hu/MPlayer/releases
Compile mplayer with win32 codecs support, place w32codecs into $MPLAYER_LIBS/win32 and you should be set. $MPLAYER_LIBS is usually prefix/lib/mplayer where prefix by default is /usr/local unless you change it during configure step.
 
Old 11-25-2002, 09:46 AM   #10
MrGreg
Member
 
Registered: Apr 2001
Location: Hamilton
Distribution: RedHat 7.2, 9.0
Posts: 52

Original Poster
Rep: Reputation: 15
There was nothing to config, I used the RPM's and yes I have the Win32 codecs installed in /usr/local/lib/win32

Pertinent output from previous post:
Reading /etc/mplayer/codecs.conf: 44 audio & 110 video codecs

I can play other streams, JUST NOT THIS ONE! I don't have enough experience to even get a clue why. Could it be an unsupported codec? I have asked CRN Media for a test stream in the exact same format, broadcast at normal hours so I can figure this out. They've been pretty cooperative so far.

More info forthcoming...
 
Old 11-25-2002, 02:03 PM   #11
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
You might actually wanna try compiling it rather than installing the RPM, it might be your -vo device that is giving you problems.

What does 'mplayer -vo help' give you? Try each of those with that stream.

Cool
 
Old 11-25-2002, 03:03 PM   #12
MrGreg
Member
 
Registered: Apr 2001
Location: Hamilton
Distribution: RedHat 7.2, 9.0
Posts: 52

Original Poster
Rep: Reputation: 15
I appreciate the help

The more I look into it, the more discouraged I become. I found this in the Mplayer archives from late October:
> >
> > am I correct in the assumption that WMV3 (Windows Media 9) is not
> > working in the current CVS version of MPlayer?
> yes
> and don't even expect it in the near future, they dropped directshow and use
> a brand new codec API (DMO) not yet reverse engineered.
> it also does crypto authentication between their demuxer and codec, to avoid
> the divx3 case (they protect their codec by fourcc checking, so ppl couldn't
> use msmpeg4v3 codec in avi, so a bad guy changed its fourcc to div3...).
> now even if you "steal" their codec, you cannot use it without their asf
> demuxer, which does copyright checking etc...
>
> > What's that ? a file format ?
> no, a new video (WMV3) and audio (0x162) codec in the good old ASF container
> supported by wmp9/wms9 apps
>
I don't know if it's relevent to this, but when I booted up a Win box last night and tried the stream (WMP9) it required a new codec from M$. Why does a simple 8000Hz 16 bit wav have to be so damn complicated? Why is the wheel constantly being re-invented and patented by these guys?

Thanks for the tip though, CRN Media is supposed to fire up a test stream later this afternoon that I can play around with. Normally they only broadcast 10pm - 1 amEDT. I wonder also if it's because the rpm's were compiled with alsa driver option disabled. I use alsa on the machine in question.

Thanks,
 
Old 06-08-2004, 08:53 PM   #13
sst
LQ Newbie
 
Registered: Jun 2004
Posts: 1

Rep: Reputation: 0
.nsc files in linux

Hi there,


from the bellow discuss I believe Mplayer can receive some asf streams.
Here I have a question. Can Mplayer receiver asf stream that indicate by .nsc file?

In my case the MS Media server broadcast .asf files through DVB-S. And in MS window platform I just point .nsc file and Media server can aotumaticly play the live stream. I try to receive such stream on Linux platform but I am not sure if Mplayer or VLC can work.

The video in .asf is MWV1 and audio is mwa2.

Could I get suggestions from you?


thanks

Bin

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mplayer from ASF to MP3 foomanchew Linux - Software 4 12-05-2005 12:51 PM
using mplayer with .asx without -playlist? Would be useful for mplayer plug-in pierrethibault Linux - Software 1 02-18-2005 08:12 AM
Asx files do not play in Mplayer vavoem Linux - Software 2 08-18-2004 04:16 AM
mplayer asf streaming Incanus Linux - Software 0 10-01-2003 03:12 PM
I can't get .asf files to play in mplayer..... garymansell Linux - Software 0 07-10-2003 08:21 AM


All times are GMT -5. The time now is 05:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration