LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 05-15-2007, 02:04 AM   #1
abhishek03
Newbie
 
Registered: Jan 2007
Posts: 0

Rep: Reputation: 0
'lt_dlopen' symbol error in Asterisk 64 bit, compiled using UnxiODBC and freeTDS.


Hi everyone,

I've compiled Asterisk 64 bit version on my machine using UnixODBC and freeTDS.

Although it compiled correctly but on running asterisk, i get the following message:

---------------------------------------
[cdr_odbc.so]May 15 10:55:27 WARNING[3165]: loader.c:325 __load_resource: ld.so.1: asterisk: fatal: relocation error: file /export/home/tulika/utilities/unixODBC-2.2.9-64bit/unixODBC-2.2.9/DriverManager/.libs//libodbc.so.1: symbol lt_dlopen: referenced symbol not found
May 15 10:55:27 WARNING[3165]: loader.c:554 load_modules: Loading module cdr_odbc.so failed!
---------------------------------------

I checked 'libodbc.so.1' using 'nm' and the symbol 'lt_dlopen' in UNDEF there.

I also checked the 32 bit version but that is working absolutely fine!

Where is the issue, in Asterisk or UnixODBC, or in compilation or configuration, and what should be the course of action?

Thanks in advance.

Regards,
Ab.
 
Old 05-15-2007, 10:34 PM   #2
studioj
Member
 
Registered: Oct 2006
Posts: 460

Rep: Reputation: 31
thats a pre-install path to the library which is kind of a funky thing to do
you have end up with a bad path i think...."/.libs//libodbc.so.1" two slashes.. thats no good.

anyway why did you not install libodbc ?
 
  


Reply

Tags
asterisk, bit


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
symbol lookup error: /usr/lib/libgtk-x11.2.0.so.0: undefined symbol:... IamI Slackware 17 02-29-2008 12:10 PM
./firefox-bin: symbol lookup error: /usr/lib/libpango-1.0.so.0: undefined symbol: g_s cb8100 Slackware 3 10-05-2006 11:55 AM
Successfully Compiled Program has Symbol Lookup Errors Kenji Miyamoto Programming 2 02-07-2006 03:32 PM
asterisk compiled error johnrage Suse/Novell 1 12-01-2005 08:11 AM
snort failed: snort: symbol lookup error: undefined symbol: usmAES192PrivProtocol Emmanuel_uk Linux - Security 1 07-10-2005 11:29 AM


All times are GMT -5. The time now is 09:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration