LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices


Reply
 
Search this Thread
Old 03-06-2013, 09:49 AM   #1
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Costa Rica
Distribution: Kubuntu, Debian, Knoppix
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 83
zabbix_agent: unknown parameter [LogFile] in config file


Hi!

I have this ubuntu 12.10 server (on a qemu virtual machine). I'm testing zabbix (from packages) on it and have been having no major problems till now with it. Up until yesterday, zabbix_agent was working normally but today I boot the VM and agent won't come online.

When I run it manually. it was complaining about PidFile:

Code:
cps@zabbix:~$ zabbix_agent -c /etc/zabbix/zabbix_agentd.conf
zabbix_agent [1631]: unknown parameter [PidFile] in config file [/etc/zabbix/zabbix_agentd.conf], line 13
I comment out that option and now it's LogFile:

Code:
cps@zabbix:~$ zabbix_agent -c /etc/zabbix/zabbix_agentd.conf
zabbix_agent [1704]: unknown parameter [LogFile] in config file [/etc/zabbix/zabbix_agentd.conf], line 23
I think it doesn't make much sense. Who can tell me what's going on? Thanks in advance.

Code:
cps@zabbix:~$ zabbix_agent --version
Zabbix agent v2.0.2 (revision 29214) (31 July 2012)
Compilation time: Aug 13 2012 14:27:37
 
Old 03-06-2013, 10:11 AM   #2
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Costa Rica
Distribution: Kubuntu, Debian, Knoppix
Posts: 1,993
Blog Entries: 1

Original Poster
Rep: Reputation: 83
Ok.... problem was that I had a not-directly-related-to-zabbix file in /etc/zabbix/zabbix_agentd.conf.d/. Moved it out and it's working now.
 
Old 03-03-2015, 07:00 PM   #3
virussx
LQ Newbie
 
Registered: Sep 2002
Location: Venezuela
Distribution: Debian etch
Posts: 26

Rep: Reputation: 15
Quote:
Originally Posted by eantoranz View Post
Ok.... problem was that I had a not-directly-related-to-zabbix file in /etc/zabbix/zabbix_agentd.conf.d/. Moved it out and it's working now.
Sorry i kindda have the same problem now, im trying out zabbix and the same error pop out.. do u mind telling me waht did u do to solve this problem???
 
Old 03-03-2015, 08:12 PM   #4
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Costa Rica
Distribution: Kubuntu, Debian, Knoppix
Posts: 1,993
Blog Entries: 1

Original Poster
Rep: Reputation: 83
You have a file that's not relatad to Zabbix in the configuration directory? Move it out of that directory.
 
Old 03-04-2015, 09:46 AM   #5
virussx
LQ Newbie
 
Registered: Sep 2002
Location: Venezuela
Distribution: Debian etch
Posts: 26

Rep: Reputation: 15
Quote:
Originally Posted by eantoranz View Post
You have a file that's not relatad to Zabbix in the configuration directory? Move it out of that directory.
so far i had these files in the directory /etc/zabbix

sdi:/etc/zabbix$ ls -l
total 36
-rw-r--r-- 1 root root 1152 Feb 25 11:30 apache.conf
drwxr-xr-x 2 www-data root 4096 Feb 25 11:46 web
-rw-r--r-- 1 root root 8187 Mar 3 16:28 zabbix_agentd.conf
drwxr-xr-x 2 root root 4096 Feb 25 10:56 zabbix_agentd.d
-rw-r----- 1 root root 13588 Feb 27 10:00 zabbix_server.conf

i checked the Pidfile in /var/run/zabbix and the pid file was created sucessfully, so i dont understand whats going on?? u mean theres a wrong file??
 
Old 03-04-2015, 04:08 PM   #6
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Costa Rica
Distribution: Kubuntu, Debian, Knoppix
Posts: 1,993
Blog Entries: 1

Original Poster
Rep: Reputation: 83
The problem for me was that I had a file not related to zabbix configuration inside /etc/zabbix/zabbix_agentd.conf.d/. My guess is that zabbix goes through all the files in that directory assuming they are all related to zabbix. Chevere? ;-) (yo soy venezolano)
 
  


Reply

Tags
12.10, agent, ubuntu, zabbix


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why we should give "core" parameter in yum config file ram_rajavarapu Linux - Enterprise 2 08-16-2010 12:49 PM
Postfix postconf unknown parameter data_directory annekaelber Linux - Software 2 08-13-2009 11:50 PM
Hello. I am getting 'e1000 unknown parameter 'irq' and my adapter wont come up. Linuxwho? Linux - Hardware 2 06-15-2009 12:22 PM
read config file parameter values sharathkv25 Programming 2 02-15-2007 01:55 AM
Unknown parameter barbanero Linux - Networking 2 01-27-2002 09:29 AM


All times are GMT -5. The time now is 11:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration