LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 02-27-2013, 10:33 AM   #16
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Colombia
Distribution: Kubuntu, Debian, Knoppix
Posts: 1,982
Blog Entries: 1

Original Poster
Rep: Reputation: 83

Uploaded to pastebin http://www.pastebin.ca/2317475
 
Old 02-27-2013, 10:34 AM   #17
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Colombia
Distribution: Kubuntu, Debian, Knoppix
Posts: 1,982
Blog Entries: 1

Original Poster
Rep: Reputation: 83
Could it be that I'm working with zabbix 2.x instead of 1.x?
 
Old 02-27-2013, 10:36 AM   #18
Habitual
Senior Member
 
Registered: Jan 2011
Distribution: Undecided
Posts: 3,493
Blog Entries: 6

Rep: Reputation: Disabled
Quote:
Originally Posted by eantoranz View Post
Could it be that I'm working with zabbix 2.x instead of 1.x?
depends on the template properties (contents of the .xml file). It may have been written for 1.x may not play nice with 2.0...
 
Old 02-27-2013, 10:37 AM   #19
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Colombia
Distribution: Kubuntu, Debian, Knoppix
Posts: 1,982
Blog Entries: 1

Original Poster
Rep: Reputation: 83
Ok... let me know what you get/infer from the template.
 
Old 02-27-2013, 10:39 AM   #20
Habitual
Senior Member
 
Registered: Jan 2011
Distribution: Undecided
Posts: 3,493
Blog Entries: 6

Rep: Reputation: Disabled
<zabbix_export version="1.0" date="06.12.10" time="15.11">
2nd line at pastebin.ca post.

But don't despair, there's some further things we can check yet...
 
Old 02-27-2013, 10:57 AM   #21
Habitual
Senior Member
 
Registered: Jan 2011
Distribution: Undecided
Posts: 3,493
Blog Entries: 6

Rep: Reputation: Disabled
Quote:
Originally Posted by eantoranz View Post
Could it be that I'm working with zabbix 2.x instead of 1.x?
It "may".

there's some further things we can check yet...
inconclusive on the export_version as this file shows the same and description here..says
"Finally this template and perl file was tested for Zabbix 1.8.10, postgreSQL 8.4+ and RHEL 5.5,"

if you haven't said, I'll re-ask:
What is the OS of the zbx_server, and what is the OS of the PG host? What PG version?

"tested for" may not mean anything but it could mean a world of difference.

But https://www.zabbix.com/wiki/howto/mo...l#requirements says 1.8.10.

What site (forum, wiki, etc...) did this template come from originally?

You have any special requirement for the 2.0?
 
Old 02-27-2013, 11:02 AM   #22
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Colombia
Distribution: Kubuntu, Debian, Knoppix
Posts: 1,982
Blog Entries: 1

Original Poster
Rep: Reputation: 83
zabbix server is on ubuntu server 12.04 (running on qemu, just in case).

host I'm playing with trying to monitor is running kubuntu 12.10 (installed zabbix-agent from packages). PG is 9.1 (9.1.8-0ubuntu12.10, from packages).

No special requirement for zabbix, just wanted to give the latest stable a try. Perhaps there's some glue missing between postbix (apparently it hasn't been actively developed lately.... RC is already like one year old) and zabbix 2.x?
 
Old 02-27-2013, 11:41 AM   #23
Habitual
Senior Member
 
Registered: Jan 2011
Distribution: Undecided
Posts: 3,493
Blog Entries: 6

Rep: Reputation: Disabled
ha! thread topic says "postfix".

I think I need a break, you must be reinstalling 1.8.10 as up until now, you been leaning on the reply button as fast as I can post.

and as a "note", have you associated the Template_PostgreSQL with the host?
Attached Images
File Type: png 1.png (15.3 KB, 9 views)
 
Old 02-27-2013, 01:16 PM   #24
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Colombia
Distribution: Kubuntu, Debian, Knoppix
Posts: 1,982
Blog Entries: 1

Original Poster
Rep: Reputation: 83
Yep, template is linked
Attached Images
File Type: png zabbix templates gateway.png (11.5 KB, 9 views)
 
Old 02-27-2013, 01:53 PM   #25
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Colombia
Distribution: Kubuntu, Debian, Knoppix
Posts: 1,982
Blog Entries: 1

Original Poster
Rep: Reputation: 83
I'm setting up a VM with 12.04 to install zabbix from packages (uses 1.8.x). Will let you know how it goes there.
 
Old 02-27-2013, 01:56 PM   #26
fl0
Member
 
Registered: May 2010
Location: Germany
Distribution: Slackware
Posts: 105

Rep: Reputation: 34
@eantoranz

your screenshot says you are using zabbix 2, the theme and tabbed interface is new in version 2...


regards fl0
 
Old 02-27-2013, 02:00 PM   #27
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Colombia
Distribution: Kubuntu, Debian, Knoppix
Posts: 1,982
Blog Entries: 1

Original Poster
Rep: Reputation: 83
So.... where should I look? Or what should I do?
 
Old 02-27-2013, 02:12 PM   #28
fl0
Member
 
Registered: May 2010
Location: Germany
Distribution: Slackware
Posts: 105

Rep: Reputation: 34
if you need postbix, you need to install zabbix 1.8
https://www.zabbix.com/documentation...l/installation

are you sure you need postbix? maybe check_postgres is an alternative for you
http://bucardo.org/wiki/Check_postgres
 
Old 02-27-2013, 02:21 PM   #29
eantoranz
Senior Member
 
Registered: Apr 2003
Location: Colombia
Distribution: Kubuntu, Debian, Knoppix
Posts: 1,982
Blog Entries: 1

Original Poster
Rep: Reputation: 83
Is it easy to use nagios stuff in zabbix? I mean, perhaps zabbix can handle stuff that's built for nagios.
 
Old 02-27-2013, 02:31 PM   #30
fl0
Member
 
Registered: May 2010
Location: Germany
Distribution: Slackware
Posts: 105

Rep: Reputation: 34
sure, you need to write the template yourself, and use UserParameters

https://www.zabbix.com/documentation...userparameters
 
  


Reply

Tags
postbix, ubuntu, zabbix


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Updated Postfix not running after transferring over users from older postfix fedora_user Linux - Server 2 03-01-2011 04:17 AM
SUSE SLE Linux running Zabbix Network monitoing in Amazon Cloud - Blocked port 10051 xaviercardoza Linux - Security 2 11-19-2010 03:20 AM
zabbix problem saran_redhat Linux - Newbie 2 09-30-2009 02:49 AM
Zabbix mahmoud Linux - Software 3 03-17-2008 05:37 PM
Zabbix.... any experiences? alek66 Solaris / OpenSolaris 0 02-20-2008 07:24 AM


All times are GMT -5. The time now is 06:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration