LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 02-21-2008, 09:16 PM   #1
mikelbeck
LQ Newbie
 
Registered: Sep 2007
Location: Lawn Guyland, Noo Yawk
Distribution: CentOS 5.1
Posts: 12

Rep: Reputation: 0
yum update failure!


I've got a CentOS 5 box that I recently installed Tomcat 5.5 on, using yum.

I ran yum update on this machine for the first time since I've installed Tomcat, now I'm getting this message:

Quote:
Error: Missing Dependency: xml-commons = 0:1.3.02-0.b2.7jpp.10 is needed by package xml-commons-apis
Yum shows that there's a lot of Tomcat related items that need to be updated (jakarta, tomcat5-common-lib, etc).

I've searched around but can't find out what I need to do to correct this. Has anybody seen this, or does anybody have an idea of how to fix it?
 
Old 02-21-2008, 09:57 PM   #2
rcx11
Member
 
Registered: Oct 2006
Distribution: Fedora 7 x86_64, SLAX
Posts: 58

Rep: Reputation: 15
I'm not a CentOS person, but I have an idea from my Fedora experience. Try running "yum install xml*" (without quotes). Look for any packages named xml-commons. If so, you can probably say no to that transfer then do "yum install whatever" (replace whatever with the package) or you could say yes and install all that it comes up with. Might possibly work. It's worth a shot.
 
Old 02-21-2008, 10:02 PM   #3
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
hard to say withou more messages, the problenm is probably either that something is trying to update xml-commons, but xml-commons-apis thinks it needs this particular version, or xml-commons-apis is trying to update buy there isn't a more recent xml-commons.

Work out what updte is causing the problem, then use the --exclude=offending_package option to update other packages
 
Old 02-22-2008, 09:37 AM   #4
mikelbeck
LQ Newbie
 
Registered: Sep 2007
Location: Lawn Guyland, Noo Yawk
Distribution: CentOS 5.1
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by billymayday View Post
hard to say withou more messages
What sort of additional messages would be helpful?

Quote:
, the problenm is probably either that something is trying to update xml-commons, but xml-commons-apis thinks it needs this particular version, or xml-commons-apis is trying to update buy there isn't a more recent xml-commons.

Work out what updte is causing the problem, then use the --exclude=offending_package option to update other packages
How would I go about figuring out what's causing the problem?
 
Old 02-22-2008, 02:06 PM   #5
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
Just try posting the whole output from yum
 
Old 02-22-2008, 04:47 PM   #6
mikelbeck
LQ Newbie
 
Registered: Sep 2007
Location: Lawn Guyland, Noo Yawk
Distribution: CentOS 5.1
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by billymayday View Post
Just try posting the whole output from yum
Here it is:

Loading "installonlyn" plugin
Loading "priorities" plugin
Setting up Update Process
Setting up repositories
virtualmin 100% |=========================| 951 B 00:00
rpmforge 100% |=========================| 1.1 kB 00:03
jpackage-generic 100% |=========================| 951 B 00:00
base 100% |=========================| 1.1 kB 00:00
updates 100% |=========================| 951 B 00:00
virtualmin-universal 100% |=========================| 951 B 00:00
addons 100% |=========================| 951 B 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
0 packages excluded due to repository priority protections
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package tomcat5-jsp-2.0-api.noarch 0:5.5.25-1jpp set to be updated
---> Package jakarta-commons-collections.noarch 0:3.2-2jpp set to be updated
---> Package tomcat5-jasper.noarch 0:5.5.25-1jpp set to be updated
---> Package struts.noarch 0:1.2.9-5jpp set to be updated
---> Package kernel-devel.i686 0:2.6.18-53.1.13.el5 set to be installed
---> Package jakarta-commons-beanutils.noarch 0:1.7.0-6jpp set to be updated
---> Package clamd.i386 0:0.92.1-1.el5.rf set to be updated
---> Package lftp.i386 0:3.6.3-1.el5.rf set to be updated
---> Package tomcat5.noarch 0:5.5.25-1jpp set to be updated
---> Package jakarta-commons-launcher.noarch 0:1.1-3jpp set to be updated
---> Package jakarta-taglibs-standard.noarch 0:1.1.1-8jpp set to be updated
---> Package antlr.noarch 0:2.7.7-1jpp set to be updated
---> Package ant.noarch 0:1.6.5-4jpp set to be updated
---> Package autofs.i386 1:5.0.1-0.rc2.55.el5.3 set to be updated
---> Package jakarta-commons-httpclient.noarch 1:3.0.1-1jpp set to be updated
---> Package kernel.i686 0:2.6.18-53.1.13.el5 set to be installed
---> Package jakarta-commons-dbcp.noarch 0:1.2.2-1jpp set to be updated
---> Package xml-commons-resolver10.noarch 0:1.3.03-11jpp set to be updated
---> Package clamav.i386 0:0.92.1-1.el5.rf set to be updated
---> Package tomcat5-webapps.noarch 0:5.5.25-1jpp set to be updated
---> Package tomcat5-admin-webapps.noarch 0:5.5.25-1jpp set to be updated
---> Package xml-commons-resolver12.noarch 0:1.3.03-11jpp set to be updated
---> Package xml-commons.noarch 0:1.3.03-11jpp set to be updated
---> Package perl-BSD-Resource.i386 0:1.2901-1.el5.rf set to be updated
---> Package tomcat5-server-lib.noarch 0:5.5.25-1jpp set to be updated
---> Package jakarta-commons-digester.noarch 0:1.7-6jpp set to be updated
---> Package bcel.noarch 0:5.2-3jpp set to be updated
---> Package xerces-j2.noarch 0:2.9.0-2jpp set to be updated
---> Package virtualmin-base.noarch 0:1.0-53.rh set to be updated
---> Package perl-Net-DNS.i386 0:0.63-1.el5.rf set to be updated
---> Package perl-IO-Socket-INET6.noarch 0:2.52-1.el5.rf set to be updated
---> Package perl-IO-Socket-SSL.noarch 0:1.13-1.el5.rf set to be updated
---> Package wsdl4j.noarch 0:1.6.2-2jpp set to be updated
---> Package kpartx.i386 0:0.4.7-12.el5_1.2 set to be updated
---> Package gdb.i386 0:6.5-25.el5_1.1 set to be updated
---> Package regexp.noarch 0:1.4-3jpp set to be updated
---> Package jakarta-commons-modeler.noarch 0:2.0-4jpp set to be updated
---> Package log4j.noarch 0:1.2.14-3jpp set to be updated
---> Package syslinux.i386 0:3.61-1.el5.rf set to be updated
---> Package jakarta-commons-fileupload.noarch 1:1.1.1-3jpp set to be updated
---> Package net-snmp.i386 1:5.3.1-19.el5_1.4 set to be updated
---> Package jakarta-commons-discovery.noarch 1:0.4-2jpp set to be updated
---> Package kernel-headers.i386 0:2.6.18-53.1.13.el5 set to be updated
---> Package jakarta-commons-pool.noarch 0:1.3-10jpp set to be updated
---> Package axis.noarch 0:1.4-2jpp set to be updated
---> Package dkms-fuse.noarch 0:2.7.2-1.nodist.rf set to be updated
---> Package xml-commons-resolver11.noarch 0:1.3.03-11jpp set to be updated
---> Package perl-DBI.i386 0:1.602-1.el5.rf set to be updated
---> Package xalan-j2.noarch 0:2.7.0-7jpp set to be updated
---> Package clamav-db.i386 0:0.92.1-1.el5.rf set to be updated
---> Package tomcat5-common-lib.noarch 0:5.5.25-1jpp set to be updated
---> Package perl-Socket6.i386 0:0.20-1.el5.rf set to be updated
---> Package fuse.i386 0:2.7.3-1.el5.rf set to be updated
---> Package net-snmp-libs.i386 1:5.3.1-19.el5_1.4 set to be updated
---> Package wbm-virtual-server.noarch 0:3.52.gpl-2 set to be updated
---> Package device-mapper-multipath.i386 0:0.4.7-12.el5_1.2 set to be updated
---> Package jakarta-commons-logging.noarch 0:1.1-4jpp set to be updated
---> Package tomcat5-servlet-2.4-api.noarch 0:5.5.25-1jpp set to be updated
--> Running transaction check
--> Processing Dependency: jakarta-commons-dbcp-tomcat5 >= 0:1.2.1 for package: tomcat5-common-lib
--> Processing Conflict: clamav-filesystem conflicts clamav > 0.92-1.vm.el5
--> Processing Dependency: xml-commons = 0:1.3.02-0.b2.7jpp.10 for package: xml-commons-apis
--> Processing Dependency: jakarta-commons-pool-tomcat5 >= 0:1.2 for package: tomcat5-common-lib
--> Processing Dependency: jakarta-commons-collections-tomcat5 >= 0:3.1 for package: tomcat5-common-lib
--> Processing Dependency: jakarta-commons-io for package: tomcat5-admin-webapps
--> Processing Dependency: wbm-virtualmin-registrar for package: virtualmin-base
--> Processing Dependency: clamav-server = 0.92-1.vm.el5 for package: clamav-server-sysv
--> Processing Dependency: xml-commons-jaxp-1.3-apis >= 0:1.3 for package: xerces-j2
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package xml-commons-jaxp-1.3-apis.noarch 0:1.3.03-11jpp set to be updated
---> Package jakarta-commons-collections-tomcat5.noarch 0:3.2-2jpp set to be updated
---> Package jakarta-commons-dbcp-tomcat5.noarch 0:1.2.2-1jpp set to be updated
---> Package jakarta-commons-io.noarch 0:1.3.2-1jpp set to be updated
---> Package wbm-virtualmin-registrar.noarch 2:1.3-1 set to be updated
---> Package jakarta-commons-pool-tomcat5.noarch 0:1.3-10jpp set to be updated
--> Running transaction check
--> Processing Dependency: clamav-server = 0.92-1.vm.el5 for package: clamav-server-sysv
--> Processing Conflict: clamav-filesystem conflicts clamav > 0.92-1.vm.el5
--> Processing Dependency: xml-commons = 0:1.3.02-0.b2.7jpp.10 for package: xml-commons-apis
--> Finished Dependency Resolution
Error: clamav-filesystem conflicts with clamav > 0.92-1.vm.el5
Error: Missing Dependency: xml-commons = 0:1.3.02-0.b2.7jpp.10 is needed by package xml-commons-apis
 
Old 02-27-2008, 08:57 PM   #7
mikelbeck
LQ Newbie
 
Registered: Sep 2007
Location: Lawn Guyland, Noo Yawk
Distribution: CentOS 5.1
Posts: 12

Original Poster
Rep: Reputation: 0
Nobody has any ideas?
 
Old 02-27-2008, 09:04 PM   #8
waddy
LQ Newbie
 
Registered: Jun 2007
Posts: 9

Rep: Reputation: 0
I had this issue on a RH Server in regards to xen. RH didnt have the package in the repos or something.

i ran

yum update --exclude filename

That should allow everything to update. I dont have a total solution.

Hope that helps
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Yum update failure?? tommy12 Linux - Software 3 03-24-2007 01:44 AM
fc5: yum update causes failure pcandpc Fedora 3 05-07-2006 12:01 AM
yum update failure on broadband gchandler Fedora 7 11-25-2005 06:32 AM
yum update failure! hueofwind Linux - General 3 11-02-2005 10:41 PM
yum update failure?? winchester169 Linux - Software 0 09-17-2004 01:41 AM


All times are GMT -5. The time now is 04:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration