LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   Wrote 0 leases to leases file - DHCP server (http://www.linuxquestions.org/questions/linux-server-73/wrote-0-leases-to-leases-file-dhcp-server-741250/)

lionel.rpm 07-19-2009 05:25 PM

Wrote 0 leases to leases file - DHCP server
 
Hi all!

I'm attempting to set up a DCHP server on my Debian Lenny (first time), but something is going wrong with the leases file. Here's my syslog after the start up ( Don't fail ):

/var/log/syslog

localhost dhcpd: Wrote 0 leases to leases file.



As a matter of fact, I set the interface eth0 in /etc/default/dhcp3-server:

INTERFACES="eth0"



DHCP configuration:

/etc/dhcp3/dhcpd.conf

dns-update-style none;

option domain-name-servers 192.168.1.100, 208.67.222.222, 208.67.220.220;

# I installed bing9 dns server ( It's working )

default-lease-time 600;
max-lease-time 7200;

authoritative;

subnet 192.168.1.0 netmask 255.255.255.0 {
range 192.168.1.200 192.168.1.229;
option subnet-mask 255.255.255.0;
option broadcast-address 192.168.1.255;
option routers 192.168.1.1;
}


Network configuration:

/etc/network/interfaces

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.1.100
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1



Thanks in advance!


PS: I was following this HowTo.

suhas! 07-20-2009 03:42 AM

Lease file contains the information about the IPs leased to client machines. Since you have just installed the DHCP server, there must be no IP leased.

Apart from this warning, check if client machines are getting IP from DHCP server. And then you can just cat the lease file to see whether lease records are written in there or not.

lionel.rpm 07-21-2009 01:54 PM

Is The Server Working?
 
Thanks for the reply! I tried to connect a client through a Hub but It didn't recive any DHCPOFFER... How can I find out that the server is working?

Thanks again!

suhas! 07-22-2009 06:05 PM

Quote:

Originally Posted by lionel.rpm (Post 3615547)
Thanks for the reply! I tried to connect a client through a Hub but It didn't recive any DHCPOFFER... How can I find out that the server is working?

Thanks again!

Can you provide us DHCP relevant logs ?


All times are GMT -5. The time now is 06:03 PM.