Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Server
User Name
Linux - Server This forum is for the discussion of Linux Software used in a server related context.


  Search this Thread
Old 04-10-2008, 11:41 PM   #1
LQ Newbie
Registered: Oct 2007
Location: Vxj / Sweden
Distribution: Debian
Posts: 4

Rep: Reputation: 0
Unhappy WinXP pro don't run "logon script = logon.bat"

Hi, thanks for reading!

I run Debian Linux with samba and it work just fine, but
WinXP Profesional don't run the logon.bat script.
Windows98 in the same box do?
If I run it manualy evrything works just fine.
I have a feeling I forgot somthing?

Here is my smb.conf
#  smb.conf
# Samba config file created using kate
# Global parameters continiue
# Basic server settings
netbios name = HUGO
workgroup = BENGT7JQB
security = user
server string = Debian Samba %a %v %L

# We shuld act as the domain and local master browser
os level = 64
preferred master = yes
domain master = yes
domain logons = yes
time server = yes

# security settings 
smb ports = 139
hosts allow = ***.***.***.***/**
hosts deny = ALL
interfaces = eth1 lo
bind interfaces only = Yes

# encrypt passworsd are a requirement for a PDC
encrypt passwords = yes

# were to store user profiles
# logon path tells Samba where to put \
Windows NT/2000/XP roaming profiles
logon drive = V:
logon path = \\HUGO\profiles\
logon script = logon.bat

# were is a users home directory and\
 where shuld it be mounted at?
;logon home = \\%N\profiles
logon home = \\HUGO\profiles

passwd program = /usr/bin/passwd %u
# Enable the windows support
wins support = yes

hide unreadable = yes
browseable = yes
hide dot files = no
dos filetime resolution = yes

# Logfile options here
debug timestamp = yes
log file = /var/log/samba/%m_%U.log
log level = 2
max smbd processes = 20

socket options = SO_KEEPALIVE \
dns proxy = no
printcap name = cups

# preload = program

printcap = CUPS
printcap name = cups
load printers = yes
restrict anonymous = no
show add printer wizard = no
max protocol = NT
ldap ssl = No
; server signing = Auto

# necessary share for domain controller
comment = LogOn for U-%U u-%u at m-%m N-%N
path = /home/samba/netlogon/%m/%U
browseable = No
writable = No
guest ok = Yes
locking = No

# share for storing user profiles
comment = Profiles for u-%u
path = /home/samba/profile/%u
browseable = No
writable = yes
create mask = 0600
directory mask = 0700
profile acls = Yes

comment = home for U-%U S-%S m-%m a-%a
path = /home/%S/.%m
valid users = %S
read only = No
browseable = No
map archive = Yes
hide dot files = No
dos filemode = yes
dos filetime resolution = yes
case sensitive = no

comment = Extra %U at %m on %L %a
path = /home/samba/user/.%m
force group = users
read only = No
writable = Yes
create mask = 0664
directory mask = 0775
hide dot files = no
dos filemode = yes
dos filetime resolution = yes
case sensitive = no

comment = Programm for %m with %a
path = /pub/disk1/%a/Program
; - path = /pub/disk1/Program
browseable = yes
read only = no
writable = yes
create mask = 0660
directory mask = 0770
force group = users
dos filemode = yes
dos filetime resolution = yes

browseable = no
writable = no
path = /home/samba/tmp
include = /home/%U/smb.conf.www

comment = All Printers
path = /var/spool/samba
browseable = no
guest ok = yes
printable = yes
use client driver = Yes
And some intresting output
sm7jqb:/# smbtree
\\HUGO Debian Samba UNKNOWN 3.0.24 hugo
\\BENGTSHPXP Arbets daror
cli_rpc_pipe_open: cli_nt_create failed on pipe \srvsvc to machine BENGTSHPXP. Error was NT_STATUS_ACCESS_DENIED
I don't understan that error msg, cant find any useful information, yet.

I wanted to put a picture here but
Here is a link to it
How that looks in my WinXP box.

Last edited by Bengt7jqb; 04-11-2008 at 12:02 AM.
Old 04-12-2008, 03:05 PM   #2
Registered: May 2006
Location: England
Distribution: CentOS, Ubuntu Server, Untangle, pfSense
Posts: 78

Rep: Reputation: 15
possibly asking the obvious here but is the xp workstation actually joined to the samba server?

Old 04-13-2008, 01:11 PM   #3
LQ Newbie
Registered: Oct 2007
Location: Vxj / Sweden
Distribution: Debian
Posts: 4

Original Poster
Rep: Reputation: 0

Yes, evrything works exept that he never run the \\hugo\netlogon\login.bat script.
I have to do it manually.

Windows 98 in the same box do it OK all the time.


samba, winxp

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
run script at logon sunlinux Linux - General 4 12-30-2006 12:01 AM
logon.bat for Windows XP ERB Linux - Newbie 3 09-12-2005 09:14 AM
logon.bat and Windows XP ERB Linux - Networking 6 05-31-2005 02:25 AM
WinXp Pro slow to logon to samba PDC seanfitz *BSD 2 03-10-2003 08:15 AM
I can't logon with the "user" and "pass"! bseven Linux - Newbie 5 11-08-2002 02:45 PM

All times are GMT -5. The time now is 08:33 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration