LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 08-25-2012, 11:29 AM   #1
Sebi94
Member
 
Registered: Jun 2012
Posts: 34

Rep: Reputation: Disabled
Question Webserver apache: Called website shows the index of all available sites


Hello community!
I want to find the error in my configuration. If I call a website, I will be redirected to it, but I can't see the called website. I can see an index of all available sites on the server.

Can somebody help me to find the error?

Quote:
Originally Posted by Apache Error Log
[Sat Aug 25 17:49:45 2012] [notice] Graceful restart requested, doing restart
apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/ming.ini on line 1 in Unknown on line 0
PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/ps.ini on line 1 in Unknown on line 0
[Sat Aug 25 17:49:46 2012] [notice] Apache/2.2.22 (Debian) PHP/5.3.3-7+squeeze14 with Suhosin-Patch configured -- resuming normal operations
[Sat Aug 25 18:00:55 2012] [notice] caught SIGTERM, shutting down
PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/ming.ini on line 1 in Unknown on line 0
PHP Deprecated: Comments starting with '#' are deprecated in /etc/php5/apache2/conf.d/ps.ini on line 1 in Unknown on line 0
[Sat Aug 25 18:01:10 2012] [notice] Apache/2.2.22 (Debian) PHP/5.3.3-7+squeeze14 with Suhosin-Patch configured -- resuming normal operations
Quote:
Originally Posted by /etc/apache2/httpd.conf (manually created, cause it wasn't available
Listen 80
NameVirtualHost *:80

<VirtualHost *:80>
ServerName http://fascinatinggaming.no-ip.info/
ServerAlias fascinatinggaming.no-ip.info
ServerAdmin Clan%WatL@gmx.de

DocumentRoot /var/www/FG
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/FG>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog ${APACHE_LOG_DIR}/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

<VirtualHost *:80>
ServerAdmin Sebastian-Kraetzig@gmx.de
ServerName http://mk-trockenbau.no-ip.info/
ServerAlias mk-trockenbau.no-ip.info

DocumentRoot /var/www/mktrockenbau
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/mktrockenbau>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog ${APACHE_LOG_DIR}/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

<VirtualHost *:80>
ServerAdmin Sebastian-Kraetzig@gmx.de
ServerName http://kraetzig.no-ip.info/
ServerAlias kraetzig.no-ip.info

DocumentRoot /var/www/wordpress
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>
<Directory /var/www/wordpress>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
allow from all
</Directory>

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
<Directory "/usr/lib/cgi-bin">
AllowOverride None
Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
Order allow,deny
Allow from all
</Directory>

ErrorLog ${APACHE_LOG_DIR}/error.log

# Possible values include: debug, info, notice, warn, error, crit,
# alert, emerg.
LogLevel warn

CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>
Thanks forwarding!
 
Old 08-25-2012, 11:56 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,937

Rep: Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330
Hi,

Well, the ServerName is wrong for both your vhosts. It must be a FQDN and not a URL, so change it to
Code:
<-snip->
ServerName fascinatinggaming.no-ip.info
<-snip->
ServerName mk-trockenbau.no-ip.info
<-snip>
Quote:
Originally Posted by /etc/apache2/httpd.conf (manually created, cause it wasn't available
Please note that in debian, httpd.conf is not used. All relevant configuration is located in apache2.conf instead. Also the vhosts are defined under /etc/apache2/sites-available and are enabled running:
Code:
a2ensite
See this for more details

Regards
 
Old 08-25-2012, 07:01 PM   #3
Sebi94
Member
 
Registered: Jun 2012
Posts: 34

Original Poster
Rep: Reputation: Disabled
Thanks, but I've read, that it's a bug. I use Debian 6.0.5. In my file under sites-available/ is already the ServerName written.

If with or without "http://", I'll get this error.

But... I fixed the error with the index. Thanks a lot!

But now, I've got an other question: My friend told me, that he can't see some or all pictures on the website. He isn't the only one with that mistake. All files have the permissions 644 and all directories the permissions 755. I've tested the pictures with different paths. I saved the path in the files like that:

/var/www/FG/images/banner.png
/images/banner.png
images/banner.png

Just visit the site and watch it self: http://fascinatinggaming.no-ip.info/

Error-Log of apache doesn't say anything. It's just error-free.
 
Old 08-26-2012, 12:20 PM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,937

Rep: Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330Reputation: 1330
Quote:
Just visit the site and watch it self: http://fascinatinggaming.no-ip.info/
It works from here.
Perhaps your friend should clear his/her browser cache.

Regards
 
Old 08-26-2012, 02:28 PM   #5
Sebi94
Member
 
Registered: Jun 2012
Posts: 34

Original Poster
Rep: Reputation: Disabled
Thanks for your informations.
 
  


Reply

Tags
apache2, httpd, httpdconf, index


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] apache webserver does not reload new index.html figure20012 Linux - Newbie 1 04-20-2012 09:42 AM
Stack trace shows a function called itself when there is no recursion. How? Member88 Linux - Kernel 4 09-26-2009 06:41 AM
apache index.html doesn't show up but index.php do zoffmann Linux - Server 5 01-28-2008 03:53 PM
LXer: Password protect your website in Apache webserver LXer Syndicated Linux News 0 02-25-2006 09:16 AM
apache: shows only my index.php and no other file! xpucto Linux - Software 12 02-21-2006 03:37 AM


All times are GMT -5. The time now is 05:48 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration