LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 12-31-2007, 02:08 PM   #1
craig_panama
LQ Newbie
 
Registered: Dec 2007
Posts: 12

Rep: Reputation: 0
Webmin httpd.conf get 403 error


FC8
I used Webmin to created a virtual user to run a blog engine "Serendipity"
The engine is saved in a directory named "earthly"

I'm testing this setup via VNC.
I run up the web browser...the one I used to created the virtual user

I'm getting a 403 error (no permission ) issued by the Apache II server?

Here's my directory and file settings based on the install instructions for Serendipity.

What's causing the 403 error?

[root@cletis earthly]# ls -l ./..
total 16
drwxrwxrwx 14 root root 4096 2007-12-30 18:37 earthly
-rw-r--r-- 1 root root 20 2007-12-28 18:25 testphp.php
[root@cletis earthly]# ls -l
total 276
drwxrwxrwx 2 root root 4096 2007-12-30 18:37 archives
drwxr-xr-x 11 root root 4096 2007-12-08 09:45 bundled-libs
-rw-r--r-- 1 root root 6814 2006-04-06 04:14 comment.php
drwxr-xr-x 5 root root 4096 2007-12-08 09:45 deployment
drwxr-xr-x 2 root root 4096 2007-12-08 09:45 docs
-rw-r--r-- 1 root root 1526 2006-04-06 04:14 exit.php
drwxr-xr-x 7 root root 4096 2007-12-08 09:45 htmlarea
drwxr-xr-x 5 root root 4096 2007-12-08 09:45 include
-rw-r--r-- 1 root root 24199 2007-06-18 06:57 index.php
drwxr-xr-x 3 root root 4096 2007-12-08 09:45 lang
drwxrwxrwx 32 root root 4096 2007-12-08 09:45 plugins
-rw-r--r-- 1 root root 10174 2007-05-16 05:12 rss.php
-rw-r--r-- 1 root root 12640 2006-09-14 03:45 serendipity_admin_image_selector.php
-rw-r--r-- 1 root root 22485 2007-08-09 04:31 serendipity_admin.php
-rw-r--r-- 1 root root 14585 2007-09-04 05:12 serendipity_config.inc.php
-rw-r--r-- 1 root root 2229 2007-04-12 04:22 serendipity.css.php
-rw-r--r-- 1 root root 526 2006-04-06 04:14 serendipity_define.js.php
-rw-r--r-- 1 root root 10726 2007-04-16 05:14 serendipity_editor.js
-rw-r--r-- 1 root root 448 2006-04-06 04:14 serendipity_xmlrpc.php
drwxr-xr-x 2 root root 4096 2007-12-08 09:45 sql
drwxrwxrwx 27 root root 4096 2007-12-08 09:45 templates
drwxrwxrwx 2 root root 4096 2007-12-08 09:45 templates_c
drwxrwxrwx 2 root root 4096 2007-12-08 09:45 uploads
-rw-r--r-- 1 root root 1469 2006-04-06 04:14 wfwcomment.php

thank you
 
Old 12-31-2007, 02:32 PM   #2
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 74
What are the permissions of the earthly directory. You posted the contents of the directory and not those of the directory itself.
 
Old 12-31-2007, 03:40 PM   #3
craig_panama
LQ Newbie
 
Registered: Dec 2007
Posts: 12

Original Poster
Rep: Reputation: 0
[root@cletis earthly]# ls -l ./..
total 16
drwxrwxrwx 14 root root 4096 2007-12-30 18:37 earthly
-rw-r--r-- 1 root root 20 2007-12-28 18:25 testphp.php


I'm looking over Serendipity docs and found this:

http://s9y.org/36.html#A5... down the page..

Quote:
For full operation, Serendipity relies on .htaccess files that your Virtual Host? must allow. For Apache, this requires the "Allow Override? File Info? Indexes Limit" (or "Allow Override? All") option set to the directory of your Serendipity installation.
is this referring to the directives in the httpd.conf file?
 
Old 02-16-2008, 07:23 PM   #4
traene
Member
 
Registered: Jan 2005
Distribution: Archlinux, Debian, grml
Posts: 210

Rep: Reputation: 33
Sorry -- is this solved? I tried to get s9y on my archlinux installed and i get a 500 Internal server error, when i try to access http://127.0.0.1/serenpidity.

However, when i put a php test file, something like:

Code:
<html> ...
<body><?php
   phpinfo();
?>
</body></html>
It shows the php info page with lots of information.
 
Old 02-23-2008, 05:57 AM   #5
traene
Member
 
Registered: Jan 2005
Distribution: Archlinux, Debian, grml
Posts: 210

Rep: Reputation: 33
Basically i forgot to include the session extension:
/etc/php/php.ini:
extension=session.so

Restarted httpd and now it works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting httpd: httpd: Syntax error on line 209 of /etc/httpd/conf/httpd.conf: Syntax sethukpathi Linux - Networking 6 04-12-2008 12:26 PM
Failed to start apache :Starting httpd: Syntax error on line 1027 of /etc/httpd/conf/ payjoe Linux - Newbie 3 09-21-2007 08:24 AM
httpd ,error num:403 hrajabi Linux - Networking 1 10-17-2005 02:37 PM
Vqadmin.cgi, 403 Forbidden Erros, and httpd.conf woe opioid Linux - Software 3 05-11-2004 09:08 AM
httpd.conf error hrc Linux - Software 4 07-07-2003 07:30 PM


All times are GMT -5. The time now is 07:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration