LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 01-08-2013, 12:56 AM   #1
XXLRay
Member
 
Registered: May 2010
Posts: 117

Rep: Reputation: 16
Webmail interface could not log on to timsieved


I ported a mail server from RHEL4 to RHEL6 (Red Hat Enterprise Linux Server release 6.3). It has a cyrusd running and email via IMAP works in principle fine.
My problem is with a Squirrelmail webmail interface on another RHEL6 server. It connects fine to the mailserver and can send and receive emails. The problem is with the avelsieve plugin. As soon as I enable it the interface reports to any logged in user:

"Could not log on to timsieved daemon on your IMAP server imap.my.domain.top:2000.
Please contact your administrator."

The plugin worked with the old server and the new one has - to the best of my knowledge - the same IP, hostname and firewall settings (port 2000/tcp is open).
Currently I am trying to get version 1.9.9 (alpha) running where as far as I remember 1.9.8 (alpha) was the version that worked before on the old server (but not on the new one either).

I can ping the server and the telnet connection looks fine:
Code:
 # telnet imap.my.domain.top 2000
 Trying 192.164.0.1...
 Connected to imap.my.domain.top.
 Escape character is '^]'.
 "IMPLEMENTATION" "Cyrus timsieved v2.3.16-Fedora-RPM-2.3.16-6.el6_2.5"
 "SASL" "DIGEST-MD5 CRAM-MD5 GSSAPI"
 "SIEVE" "comparator-i;ascii-numeric fileinto reject vacation imapflags notify envelope relational regex subaddress copy"
 "STARTTLS"
 OK
The settings in /etc/imapd.conf are:
Code:
...
sievedir: /var/lib/imap/sieve
...
sieve_maxscriptsize: 512
...
Where these are the permissions for the sieve directory:
Code:
# getfacl /var/lib/imap/sieve
getfacl: Removing leading '/' from absolute path names
# file: var/lib/imap/sieve
# owner: cyrus
# group: mail
user::rwx
group::---
other::---
The user running the imap daemon is indeed cyrus:
Code:
# ps aux | grep imap
cyrus      461  0.0  0.1 119000  3460 ?        S    Jan07   0:10 imapd -s
...
My settings in /etc/cyrus.conf are:
Code:
...
SERVICES {
  # add or remove based on preferences
...
  sieve         cmd="timsieved" listen="sieve-filter" prefork=0
...
}
...
I tried also "sieve" and "192.164.0.1:sieve" instead of "sieve-filter".

I disabled TLS in my /usr/share/squirrelmail/plugins/avelsieve/config/config.php
Code:
...
$sieveport = 2000;
...
$avelsieve_disabletls = true;
...
I even disabled the firewall completely but this did not help. Do you have any ideas which settings I could try or how to debug the problem? It is urging me quite a lot (although you need not to be urged of course) because lots of users need to disable their vacation responders after the holidays.
 
Old 01-08-2013, 06:59 AM   #2
vishesh
Member
 
Registered: Feb 2008
Distribution: Fedora,RHEL,Ubuntu
Posts: 649

Rep: Reputation: 66
Did you cross checked SeLinux related settings . I mean to say SeLinux is in enabled state or its in disabled state .

root# sestatus

Thanks
 
Old 01-08-2013, 07:50 AM   #3
XXLRay
Member
 
Registered: May 2010
Posts: 117

Original Poster
Rep: Reputation: 16
Code:
# sestatus 
SELinux status:                 enabled
SELinuxfs mount:                /selinux
Current mode:                   permissive
Mode from config file:          enforcing
Policy version:                 24
Policy from config file:        targeted
The debug mode of the avelsieve plugin is not very helpful for me by the way:
Code:
(Debug Mode). Login failed. Capabilities:ERROR:
Could not log on to timsieved daemon on your IMAP server imap.my.domain.top:2000.
Please contact your administrator.

Last edited by XXLRay; 01-08-2013 at 08:03 AM. Reason: Addition
 
Old 01-08-2013, 08:44 AM   #4
XXLRay
Member
 
Registered: May 2010
Posts: 117

Original Poster
Rep: Reputation: 16
Got it back running. The utilized sieve port has changed from 2000 to 4190 between RHEL4 and RHEL6 furthermore I had to explicitely allow plaintext for saslauth in my imapd.conf.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
450 errors sending mail on centos+ostfix+dovecot+amavisd via webmail interface sneakyimp Linux - Software 2 06-03-2008 02:29 PM
sendmail webmail interface kafnir Linux - Networking 2 03-29-2007 10:25 AM
Users can't log into Webmail - Error 500 Twistedlizzard Linux - Software 17 06-14-2005 04:37 AM
Webmail interface for POP3 mail.. Has it been done? sedulous Linux - Software 18 05-17-2004 09:40 PM
Webmail Interface johnlee Linux - General 1 01-21-2002 12:31 AM


All times are GMT -5. The time now is 05:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration