LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 04-17-2012, 08:21 PM   #1
hectorharvey
LQ Newbie
 
Registered: Apr 2012
Posts: 7

Rep: Reputation: Disabled
VSFTPD - Passive mode refused


I have burnt a lot of time trying to figure this out. I have installed VSFTPD on Fedora 13.

I issue "ftp localhost". I enter user and password. All is good. If I enter "ls", the system waits for x minutes and then reports:
421 Timeout.
Passive mode refused.

In VSFTPD.CONF, among the defaults I have:
anonymous_enabled=NO
pasv_enabled=YES
log_ftp_protocol=YES
and have experimented with
pasv_address=(real ip), 127.0.0.1, localhost
pasv_min_port=11000
pasv_max_port=11010

Even though I specify log_ftp_protocol=YES, I am not seeing the log data... which may be hurting me.

I am only interested in local host access, so I don't think the firewall is an issue. I get the same behavior if I temporarily completely disable the firewall (IPTABLES -F). I know this works because it allows me to test from my PC to this cloud server's IP.

Here is the entire .conf

Code:
# Example config file /etc/vsftpd/vsftpd.conf
#
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
#
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
#
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
anonymous_enable=NO

pasv_enable=YES
pasv_address=127.0.0.1
pasv_min_port=11000
pasv_max_port=11010

log_ftp_protocol=YES

#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# Activate logging of uploads/downloads.
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# You may override where the log file goes if you like. The default is shown
# below.
#xferlog_file=/var/log/vsftpd.log
#
# If you want, you can have your log file in standard ftpd xferlog format.
# Note that the default log file location is /var/log/xferlog in this case.
xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
#idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
#data_connection_timeout=120
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that on some FTP servers, ASCII support allows a denial of service
# attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
# predicted this attack and has always been safe, reporting the size of the
# raw file.
# ASCII mangling is a horrible feature of the protocol.
#ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
#ftpd_banner=Welcome to blah FTP service.
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd/banned_emails
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
#chroot_local_user=YES
#chroot_list_enable=YES
# (default follows)
#chroot_list_file=/etc/vsftpd/chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#ls_recurse_enable=YES
#
# When "listen" directive is enabled, vsftpd runs in standalone mode and
# listens on IPv4 sockets. This directive cannot be used in conjunction
# with the listen_ipv6 directive.
listen=YES
#
# This directive enables listening on IPv6 sockets. To listen on IPv4 and IPv6
# sockets, you must run two copies of vsftpd with two configuration files.
# Make sure, that one of the listen options is commented !!
#listen_ipv6=YES

pam_service_name=vsftpd
userlist_enable=YES
tcp_wrappers=YES
Thank for any help
 
Old 04-18-2012, 12:40 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,900

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
Quote:
I issue "ftp localhost". I enter user and password. All is good. If I enter "ls", the system waits for x minutes and then reports:
421 Timeout.
Passive mode refused.
What happens if you issue
Code:
pas
after logging in?
Quote:
I am only interested in local host access, so I don't think the firewall is an issue. I get the same behavior if I temporarily completely disable the firewall (IPTABLES -F). I know this works because it allows me to test from my PC to this cloud server's IP.
I don't see a reason to use ftp for localhost, but anyway you should open the passive ports in you firewall (even though firewall rules do not apply on localhost)

Regards
 
Old 04-18-2012, 07:29 AM   #3
hectorharvey
LQ Newbie
 
Registered: Apr 2012
Posts: 7

Original Poster
Rep: Reputation: Disabled
>>What happens if you issue: pas<<

Good call.

Code:
[root@catavoltsat ~]# ftp localhost
Connected to localhost (127.0.0.1).
220 (vsFTPd 2.3.4)
Name (localhost:root): username
331 Please specify the password.
Password:
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> pas
Passive mode off.
ftp> ls
421 Timeout.
While the timeout is the same, it no longer states that "Passive mode is refused". So it would appear the passive mode message is a red herring.

I tried enabling the anonymous ftp, and can successfully login and issue the ls command if I do it as anonymous.

So I realize now the problem is more specifically that I can't logon with a user other than anonymous. You would think this would be an authority issue, but the log files are not being populated so I am in the dark.

Any help appreciated.

FYI
I am setting up FTP for an interface into 3rd party software. It just so happens all my access will be local, and FTP is their interface.
 
Old 04-18-2012, 12:04 PM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,900

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
Quote:
While the timeout is the same, it no longer states that "Passive mode is refused". So it would appear the passive mode message is a red herring.
This happens because using "pas" you toggled passive mode off. Also set "connect_from_port_20" to NO and see if it helps.
BTW why don't you setup vsftpd for active connections?

Quote:
So I realize now the problem is more specifically that I can't logon with a user other than anonymous. You would think this would be an authority issue, but the log files are not being populated so I am in the dark.
It couldn't be an authentication problem, as your user can login into the ftp server. About that user, is this a real or a virtual user?
Regarding logs, check the system logs under /var/log
 
Old 04-18-2012, 12:37 PM   #5
hectorharvey
LQ Newbie
 
Registered: Apr 2012
Posts: 7

Original Poster
Rep: Reputation: Disabled
So when I turn passive mode off, I still get a time out with the ls command. That is why I am thinking the "Passive mode refused" is not relavant. It's the timeout that is the root issue.

As far as the user, it's a real user. I created the user, and gave it a password. I can logon with that user.

Because anonymous works and my specific user does not, I am thinking under the covers there is a failure that is not being reported. Not authorized to a directory or something. Also the anonymous is working in passive mode (I think).

I checked the var/log/messages & var/log/secure. There is also a var/log/(vsftpd.log & xferlog) that don't seem to get populated.

Thanks for your help by the way. It is much appreciated. Should I start a new thread reguardign getting the log to log?
 
Old 04-18-2012, 01:17 PM   #6
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,900

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
The timeout after the successful login means that there is a firewall or something blocking the data port, but it doesn't make sense as you are connecting to localhost.
Quote:
I checked the var/log/messages & var/log/secure. There is also a var/log/(vsftpd.log & xferlog) that don't seem to get populated.

Thanks for your help by the way. It is much appreciated. Should I start a new thread reguardign getting the log to log?
If you want to debug login, you should disable xferlog, or use dual logging:
Code:
dual_log_enable=YES
xferlog_enable=YES
xferlog_std_format=NO
vsftpd_log_file=/var/log/vsftpd.log
log_ftp_protocol=YES
 
Old 04-18-2012, 04:15 PM   #7
hectorharvey
LQ Newbie
 
Registered: Apr 2012
Posts: 7

Original Poster
Rep: Reputation: Disabled
Interestingly enough, if I add the statements you suggest about logging, the system hangs up when I am entering the password. I had noticed that before... and it happened again.

I am dissappointed that I can't a non-anonymous login to work, but I now have the anonymous working and that serves my purpose. Maybe there is some deep grime on my system that just can't be explained.

Thanks so much for your help. Let me know if you think I should mark this as resolved or leave it alone.

Thanks again.
 
Old 04-19-2012, 02:28 AM   #8
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,900

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
Quote:
Interestingly enough, if I add the statements you suggest about logging, the system hangs up when I am entering the password. I had noticed that before... and it happened again.
Was anything written to vsftpd.log?
Check if you have selinux enabled and disable it temporarily to see if this is your problem.

And no, don't mark the thread "Solved", as it mau mislead other people with a similar problem

Regards
 
Old 04-19-2012, 06:24 AM   #9
hectorharvey
LQ Newbie
 
Registered: Apr 2012
Posts: 7

Original Poster
Rep: Reputation: Disabled
The log is empty and selinux is not enabled.
 
Old 04-19-2012, 08:54 AM   #10
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,900

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
Quote:
Originally Posted by hectorharvey View Post
The log is empty and selinux is not enabled.
Huh, there should be logged at least the client IP and the username, since you said it hangs at password.
Try the following config and see what happens. Create the directory /var/run/vsftpd/empty if it doesn't already exist
Code:
anonymous_enable=NO
local_enable=YES
write_enable=YES
local_umask=022
xferlog_enable=YES
listen=YES
pam_service_name=vsftpd
secure_chroot_dir=/var/run/vsftpd/empty
userlist_enable=NO
dual_log_enable=YES
xferlog_enable=YES
xferlog_std_format=NO
vsftpd_log_file=/var/log/vsftpd.log
log_ftp_protocol=YES
 
Old 04-20-2012, 04:31 PM   #11
hectorharvey
LQ Newbie
 
Registered: Apr 2012
Posts: 7

Original Poster
Rep: Reputation: Disabled
I saved my vsftpd.conf and replaced it's contents with yours. Restarted vsftpd. Started "ftp localhost". Entered a user name and was prompted for the password, where it would sit indefinitely (I think). The log was working from anonymous logins, so I deleted it. Here is the contents of the log while the system was stuck on password prompt:

Code:
Fri Apr 20 21:19:50 2012 [pid 13137] CONNECT: Client "127.0.0.1"
Fri Apr 20 21:19:50 2012 [pid 13137] FTP response: Client "127.0.0.1", "220 (vsFTPd 2.3.4)"
Fri Apr 20 21:19:55 2012 [pid 13137] FTP command: Client "127.0.0.1", "USER userftp"
Fri Apr 20 21:19:55 2012 [pid 13137] [userftp] FTP response: Client "127.0.0.1", "331 Please specify the password."
Fri Apr 20 21:20:00 2012 [pid 13137] [userftp] FTP command: Client "127.0.0.1", "PASS <password>"
I really think at this point we should just bale on this issue. Anonymous works for me, for now.

Thanks so much for your help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
vsftpd with port 2021 not going to passive mode jjjj12212 Linux - Software 6 02-13-2012 01:14 PM
vsftpd - Passive mode not working correctly. Zaraphrax Linux - Software 1 02-17-2011 04:23 AM
How can I configure vsftpd to accept passive mode? daihard Linux - Server 1 09-04-2009 05:30 PM
Vsftpd Entering passive mode pramka Suse/Novell 1 07-18-2008 07:20 PM
Problem with vsftpd and passive mode 0001001 Linux - Server 1 09-12-2006 07:18 AM


All times are GMT -5. The time now is 02:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration