LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 06-04-2012, 07:50 AM   #1
psoni
LQ Newbie
 
Registered: Feb 2012
Posts: 14

Rep: Reputation: Disabled
VSFTP Issue: 500 OOPS: cannot change directory


Hi Guys,
My apologies, there is lot of thread running on the same topic but i am not be able to resolve my issue. So I am starting a new thread, Please help.

whenever I am ftp my machine with any user it give me below error
500 OOPS: cannot change directory:/home/APTuser/ftp, however if i do su - APTuser, it work fine. I have below configuration on my system, please help

Directory Permission
---------------------

drwx------ 4 APTuser APTuser 4096 Feb 23 03:25 APTuser



-bash-3.2$ cat /etc/passwd
--------------------------

APTuser:x:507:507:APT FTP USER:/home/APTuser/ftp:/bin/bash
I Have below configuration on my machine

[root@localhost ~]# [nsn@localhost home]$ cat /etc/redhat-release
[root@localhost ~]# Red Hat Enterprise Linux Server release 5.4 (Tikanga)
[root@localhost ~]# [nsn@localhost home]$ rpm -qa | grep ftpd
[root@localhost ~]# vsftpd-2.0.5-16.el5


[root@localhost ~]# cat /etc/passwd
psoni:x:500:500:Pardeep Soni:/home/psoni:/bin/bash

[root@localhost ~]# cat vsftpd.conf
# Example config file /etc/vsftpd/vsftpd.conf
#
# The default compiled in settings are fairly paranoid. This sample file
# loosens things up a bit, to make the ftp daemon more usable.
# Please see vsftpd.conf.5 for all compiled in defaults.
#
# READ THIS: This example file is NOT an exhaustive list of vsftpd options.
# Please read the vsftpd.conf.5 manual page to get a full idea of vsftpd's
# capabilities.
#
# Allow anonymous FTP? (Beware - allowed by default if you comment this out).
anonymous_enable=NO
#
# Uncomment this to allow local users to log in.
local_enable=YES
#
# Uncomment this to enable any form of FTP write command.
write_enable=YES
#
# Default umask for local users is 077. You may wish to change this to 022,
# if your users expect that (022 is used by most other ftpd's)
local_umask=022
#
# Uncomment this to allow the anonymous FTP user to upload files. This only
# has an effect if the above global write enable is activated. Also, you will
# obviously need to create a directory writable by the FTP user.
#anon_upload_enable=YES
#
# Uncomment this if you want the anonymous FTP user to be able to create
# new directories.
#anon_mkdir_write_enable=YES
#
# Activate directory messages - messages given to remote users when they
# go into a certain directory.
dirmessage_enable=YES
#
# The target log file can be vsftpd_log_file or xferlog_file.
# This depends on setting xferlog_std_format parameter
xferlog_enable=YES
#
# Make sure PORT transfer connections originate from port 20 (ftp-data).
connect_from_port_20=YES
#
# If you want, you can arrange for uploaded anonymous files to be owned by
# a different user. Note! Using "root" for uploaded files is not
# recommended!
#chown_uploads=YES
#chown_username=whoever
#
# The name of log file when xferlog_enable=YES and xferlog_std_format=YES
# WARNING - changing this filename affects /etc/logrotate.d/vsftpd.log
#xferlog_file=/var/log/xferlog
#
# Switches between logging into vsftpd_log_file and xferlog_file files.
# NO writes to vsftpd_log_file, YES to xferlog_file
xferlog_std_format=YES
#
# You may change the default value for timing out an idle session.
#idle_session_timeout=600
#
# You may change the default value for timing out a data connection.
#data_connection_timeout=120
#
# It is recommended that you define on your system a unique user which the
# ftp server can use as a totally isolated and unprivileged user.
#nopriv_user=ftpsecure
#
# Enable this and the server will recognise asynchronous ABOR requests. Not
# recommended for security (the code is non-trivial). Not enabling it,
# however, may confuse older FTP clients.
#async_abor_enable=YES
#
# By default the server will pretend to allow ASCII mode but in fact ignore
# the request. Turn on the below options to have the server actually do ASCII
# mangling on files when in ASCII mode.
# Beware that on some FTP servers, ASCII support allows a denial of service
# attack (DoS) via the command "SIZE /big/file" in ASCII mode. vsftpd
# predicted this attack and has always been safe, reporting the size of the
# raw file.
# ASCII mangling is a horrible feature of the protocol.
ascii_upload_enable=YES
#ascii_download_enable=YES
#
# You may fully customise the login banner string:
#ftpd_banner=Welcome to blah FTP service.
#
# You may specify a file of disallowed anonymous e-mail addresses. Apparently
# useful for combatting certain DoS attacks.
#deny_email_enable=YES
# (default follows)
#banned_email_file=/etc/vsftpd/banned_emails
#
# You may specify an explicit list of local users to chroot() to their home
# directory. If chroot_local_user is YES, then this list becomes a list of
# users to NOT chroot().
chroot_local_user=YES
chroot_list_enable=NO
# (default follows)
#chroot_list_file=/etc/vsftpd/chroot_list
#
# You may activate the "-R" option to the builtin ls. This is disabled by
# default to avoid remote users being able to cause excessive I/O on large
# sites. However, some broken FTP clients such as "ncftp" and "mirror" assume
# the presence of the "-R" option, so there is a strong case for enabling it.
#ls_recurse_enable=YES
#
# When "listen" directive is enabled, vsftpd runs in standalone mode and
# listens on IPv4 sockets. This directive cannot be used in conjunction
# with the listen_ipv6 directive.
listen=YES
#
# This directive enables listening on IPv6 sockets. To listen on IPv4 and IPv6
# sockets, you must run two copies of vsftpd whith two configuration files.
# Make sure, that one of the listen options is commented !!
#listen_ipv6=YES

pam_service_name=vsftpd
userlist_enable=YES
tcp_wrappers=YES

==============================
[root@localhost ~]# cat /etc/vsftpd/chroot_list
psoni
APTuser
--------------------------
Please help, How to sort this issue.
 
Old 06-04-2012, 08:41 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,875

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
Quote:
Directory Permission
---------------------
drwx------ 4 APTuser APTuser 4096 Feb 23 03:25 APTuser

-bash-3.2$ cat /etc/passwd
--------------------------
APTuser:x:507:507:APT FTP USER:/home/APTuser/ftp:/bin/bash
Make sure that /home/APTuser/ftp has the execute bit on.
Code:
chmod 755 /home/APTuser/ftp
Regards
 
Old 06-04-2012, 11:19 PM   #3
psoni
LQ Newbie
 
Registered: Feb 2012
Posts: 14

Original Poster
Rep: Reputation: Disabled
Hi,
I made the changes, but still not worked

[root@localhost home]# chmod -R 755 APTuser
[root@localhost home]# ls -lrt
drwxr-xr-x 4 APTuser APTuser 4096 Feb 23 03:25 APTuser

[root@localhost home]# ftp localhost
Connected to localhost.localdomain.
220 (vsFTPd 2.0.5)
530 Please login with USER and PASS.
530 Please login with USER and PASS.
KERBEROS_V4 rejected as an authentication type
Name (localhost:root): APTuser
331 Please specify the password.
Password:
500 OOPS: cannot change directory:/home/APTuser/ftp
Login failed.
 
Old 06-05-2012, 12:09 AM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,875

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
Does the directory /home/APTuser/ftp exist?
What gives:
Code:
ls -l /home/APTuser
 
Old 06-05-2012, 12:15 AM   #5
psoni
LQ Newbie
 
Registered: Feb 2012
Posts: 14

Original Poster
Rep: Reputation: Disabled
Yes It is available

[root@localhost APTuser]# ls -l /home/APTuser/
total 8
drwxr-xr-x 6 APTuser APTuser 4096 Jun 4 08:47 ftp
[root@localhost APTuser]#
 
Old 06-05-2012, 12:35 AM   #6
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,875

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
Huh. Could be SELinux as you're running rhel.
Try to disable it temporarily
Code:
sudo setenforce 0
and see if it works.
 
Old 06-05-2012, 01:13 AM   #7
psoni
LQ Newbie
 
Registered: Feb 2012
Posts: 14

Original Poster
Rep: Reputation: Disabled
It's works Now,
Thanks a lot mate. Many Many Thanks

Whats that command do?


Padreep Soni
 
Old 06-05-2012, 01:14 AM   #8
psoni
LQ Newbie
 
Registered: Feb 2012
Posts: 14

Original Poster
Rep: Reputation: Disabled
How to disable permanently
 
Old 06-05-2012, 01:22 AM   #9
lonelyman
Member
 
Registered: May 2012
Location: Shanghai
Distribution: redhat,centos,fedora
Posts: 63
Blog Entries: 4

Rep: Reputation: Disabled
eh,it's used for shutting down the Selinux firewall,do the following is same: alter the /etc/sysconfig/Selinux,change "selinux=enforcing" to "selinux=disabled",but this needs a reboot,then you permanently disabled your Selinux

Last edited by lonelyman; 06-05-2012 at 01:24 AM.
 
Old 06-05-2012, 01:25 AM   #10
psoni
LQ Newbie
 
Registered: Feb 2012
Posts: 14

Original Poster
Rep: Reputation: Disabled
Thanks Mate....


Pardeep
 
Old 06-05-2012, 01:57 AM   #11
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,875

Rep: Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322Reputation: 1322
Quote:
Originally Posted by psoni View Post
How to disable permanently
IMHO it's better not disable it for security reasons
You can run:
Code:
setsebool -P ftp_home_dir 1
so user can change into his homedir

Regards
 
Old 03-24-2013, 09:44 PM   #12
Bird2010
LQ Newbie
 
Registered: Nov 2012
Posts: 2

Rep: Reputation: Disabled
Latest Version direct from the author

Everyone,

Get the latest version of vsftpd direct from the author: https://security.appspot.com/vsftpd.html

I had lots of problems because the latest version of Linux Mint 14 was using an old version of vsftpd. I read the Software Manager page carefully for vsftpd and I noticed the author's website link. I downloaded it and I am happy now!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ftp 500 OOPS: cannot change directory yhus Linux - Networking 24 03-24-2013 09:41 PM
vsftpd 500 OOPS: cannot change directory ratcateme Linux - Software 4 05-21-2008 05:14 PM
i got a problem with vsftpd in F7, 500 OOPS: cannot change directory:/home/ftp-docs hosanna Fedora 1 05-25-2007 09:17 PM
Vsftpd - 500 OOPS: Cannot change directory amon Linux - Networking 3 05-31-2006 11:17 AM
VSFTP: 500 OOPS: unrecognised variable in config file snapper64 Linux - Software 4 07-01-2005 04:16 PM


All times are GMT -5. The time now is 07:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration