LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 02-19-2009, 10:55 AM   #1
SteveInTallyFL
Member
 
Registered: May 2008
Location: Tallahassee, FL
Distribution: RHEL4, RHEL 5, OEL4, OEL5
Posts: 60

Rep: Reputation: 17
vncserver config problems


I have just rebuilt an RHEL4.7 server, selected gnome for desktop. Configured 2 vncserver sessions with standard ~/.vnc/xstartup language [an 80x24 xterm and startx &].

At end of server config process I did change the /etc/inittab to have the server itself come up in mode 3 instead of mode 5 and rebooted.

I use vnc to remote in to administer. When I come in to my session I get the proverbial empty black screen. I have googled up the issue and I cannot see what may be causing this.

I have checked:
~/.vnc/xstartup
/etc/sysconfig/vncservers <<<< updated>>>>
/etc/rc.d/rc.local
/usr/local/bin/startvnc

I am stumped!

Last edited by SteveInTallyFL; 02-19-2009 at 11:12 AM.
 
Old 02-20-2009, 09:02 AM   #2
SteveInTallyFL
Member
 
Registered: May 2008
Location: Tallahassee, FL
Distribution: RHEL4, RHEL 5, OEL4, OEL5
Posts: 60

Original Poster
Rep: Reputation: 17
Quote:
Originally Posted by SteveInTallyFL View Post
I have just rebuilt an RHEL4.7 server, selected gnome for desktop. Configured 2 vncserver sessions with standard ~/.vnc/xstartup language [an 80x24 xterm and startx &].

At end of server config process I did change the /etc/inittab to have the server itself come up in mode 3 instead of mode 5 and rebooted.

I use vnc to remote in to administer. When I come in to my session I get the proverbial empty black screen. I have googled up the issue and I cannot see what may be causing this.

I have checked:
~/.vnc/xstartup
/etc/sysconfig/vncservers <<<< updated>>>>
/etc/rc.d/rc.local
/usr/local/bin/startvnc

I am stumped!
The configuration may have been fine but if ~/.vnc/xstartup is not made executable then all bets are off. I failed to set the mode to 0755. Once that was done everything was fine.

Kudos to Oracle Linux support for pointing this glaring omission out to me.
 
  


Reply

Tags
vncserver


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DSL vncserver problems. reed026 DamnSmallLinux 5 07-04-2007 03:24 AM
vncserver Problems em00guy Linux - Software 0 04-30-2007 10:50 PM
vncserver and printing problems spoody_goon Linux - Networking 1 01-17-2006 12:13 AM
Robust vncserver startup file (rc.vncserver) arobinson74 Slackware 4 05-14-2005 06:33 AM
vncserver problems starting Xris718 Linux - General 2 10-09-2004 12:53 AM


All times are GMT -5. The time now is 08:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration