LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   !!!!!!!!!!!!!!!virtual users config in dovecot !!!!!!!!!!!!!!!!! (http://www.linuxquestions.org/questions/linux-server-73/virtual-users-config-in-dovecot-587545/)

lasantha 09-26-2007 11:47 AM

!!!!!!!!!!!!!!!virtual users config in dovecot !!!!!!!!!!!!!!!!!
 
I am having CentOS 4.4 server installed sendmail(rpm based) ,dovecot(rpm based) and DNS-namd(rpm based) working fine for test domain in my office. All are default configuratons and working fine for 79 email accounts as system users with no login shell.

I need to remove system user accounts and config virtual users in dovecot for first part and need to set various size of email boxes of each virtual user. So I have removed default dovecot and installed from compiled source code to accomplish my goal.

My dovecot location is /usr/local/ and donfig file is at /usr/local/etc/dovecot.conf shown bellow.

Code:

# Dovecot configuration file
base_dir=/usr/local/var/run/
protocols = imap
listen = *:143
# We can use plain text passwords
disable_plaintext_auth = no
# Logging
log_path = /var/log/dovecot.log
info_log_path = /var/log/dovecot.info.log
log_timestamp = "%b %d %H:%M:%S "
# SSL settings
# Without ssl
ssl_disable = yes
# Login processes
login_user = dovecot
login_greeting = Hi buddy, have an account ?
login_log_format = %$: %s
# Mailbox locations and namespaces
mail_extra_groups = mail
# Mailbox locations and namespaces
# Clients Inbox at /var/mail, Clients Folders at /var/mail/folders/username/
mail_location = mbox:/var/mail/folders/%u/:INBOX=/var/mail/%u
# Mail processes
mail_debug = yes
mail_log_prefix = "%Us(%u): "
verbose_proctitle = yes
first_valid_uid = 1000
last_valid_uid = 5000
max_mail_processes = 2048
# mbox-specific settings
mbox_read_locks = dotlock fcntl
mbox_write_locks = dotlock fcntl
# IMAP specific settings
protocol imap {
}
# LDA specific settings
protocol lda {
postmaster_address = root@mydomain.org
hostname = mydomain.org
# Sieve plugin for local delivery agent
mail_plugins = cmusieve
log_path = /var/log/dovecot-local-deliver.log
auth_socket_path = /usr/local/var/run/dovecot-auth-master
}
# Authentication processes
auth_verbose = yes
auth_debug = yes
auth_debug_passwords = yes
auth default {
mechanisms = plain
passdb passwd-file {
# Virtual Users from file
args = /usr/local/etc/dovecot.passdb
}
userdb passwd-file {
# Virtual Users from file
args = /usr/local/etc/dovecot.passdb
}
user = root
# It's possible to export the authentication interface to other programs:
# For example getmail with MDA external
socket listen {
master {
path = /usr/local/var/run/dovecot-auth-master
mode = 0660
user = dovecot
group = mail
}
}
}

Mail authentication is done by file at same directory dovecot.passdb
Code:

user1:{PLAIN}pass1:1001:1001:User 1 Name:/var/mail/folders/user1
user2:{PLAIN}pass2:1002:1002:User 2 Name:/var/mail/folders/user2
user3:{PLAIN}pass3:1003:1003:User 3 Name:/var/mail/folders/user3
user4:{PLAIN}pass4:1004:1004:User 4 Name:/var/mail/folders/user4

Finally I can telnet to both dovecot IMAP and sendmail smtp servers and log r using outlook express to CentOS server. When I trying to send email to server using out look it gives error
Code:

The message could not be sent because one of the recipients was rejected by the server.
The rejected e-mail address was 'user1@elephent.lk'. Subject 'test',
Account: '192.168.1.1', Server: '192.168.1.1', Protocol: SMTP, Server Response:
 '550 5.1.1 <user1@elephent.lk>... User unknown', Port: 25, Secure(SSL):
No, Server Error: 550, Error Number: 0x800CCC79

What was the error ?

Or

Pls give me any good guide(url) to configure virtual users using dovecot ?
_____________________
LASANTA

digitalnerds 10-03-2007 02:31 PM

Hi

Am i wrong here .. but you are trying to send mails which is sendmail's task. For what i can see sendmail doesnt know how to lookup the virtual users or doesnt know where to look up them for.

Regards
andy

thefreak 01-15-2008 04:47 PM

its too hard to tell where to make the change... dont waste your time next time and dont reply !!!!!

XavierP 01-16-2008 05:52 AM

Why did you dredge up an old thread and not give a useful reply?


All times are GMT -5. The time now is 09:08 AM.