LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   Very Slow FTP Connection to VSFTPD on Fedora Core 6 (http://www.linuxquestions.org/questions/linux-server-73/very-slow-ftp-connection-to-vsftpd-on-fedora-core-6-a-553895/)

silent_j 05-14-2007 06:38 PM

Very Slow FTP Connection to VSFTPD on Fedora Core 6
 
Hi all,
I am acquainted with Linux, but have only been playing around with it and BSD for about seven months now so there is a ton of stuff that I still do not know. My problem is that I have installed Fedora Core 6 a machine on the network, and the FTP server is really, really slow. I am running vsftpd. Is there anything that I can do to speed things up? Is there anything else that I need to provide to help you help me?

TIA.

fur 05-15-2007 09:21 AM

How slow is it?

What kind of network connection is between them?

Use hdparm to test the read speed on your server.

Code:


hdparm -t /dev/whateverdrive


Check the output of ifconfig and see if there are a large amount of collisions, or errors on any of the transferring interfaces of both client, and server.

silent_j 05-15-2007 11:30 AM

It's slow to the tune of less than 1 KB a second. I don't think it's the hard drive. The computers are connected a router that's housed with another company that leases part of a T1 line to us. I noticed that it took forever to log in to SSH as well, but in the past SCP transfers have been fine. I tried to enter "ifconfig" in the terminal, but it gave me an error saying that it could not be found. Sorry - I know just enough to be dangerous in Linux and that's about it :).

TheLateJC 05-17-2007 01:59 AM

check for the link status, "dmesg |grep eth" might show what it is from your lan adapter

You should have the router and your lan adapter forced to full duplex, you might have gone through some lan trouble and the link was renegociated down to a slow speed.

mt83 05-26-2007 08:55 AM

If i am not wrong, your server is beside firewall.
Check your firwall setting. You should open your dns port.


All times are GMT -5. The time now is 09:42 AM.