LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   Using YUM to upgrade Mysql (http://www.linuxquestions.org/questions/linux-server-73/using-yum-to-upgrade-mysql-4175437516/)

Footsie 11-16-2012 10:40 PM

Using YUM to upgrade Mysql
 
Originally, until half an hour ago, I was running mysql (server) version 5.0.45-7.el5.

Want to upgrade to v.5.1.

Never done this before, or anything like it. I backed up all databases, stopped the mysqld service and typed:

# yum install MySQL-server-5.1.60-1.glibc23.i386.rpm

YUM said:

Error: mysql conflicts with MySQL

That seemed fair enough since the two versions are not compatible. So, I typed:

# yum remove mysql

That was fine.

Finally I tried again to install the new mysql version:

# yum install MySQL-server-5.1.60-1.glibc23.i386.rpm

and got the messages:

warning: rpmts_HdrFromFdno: V3 DSA signature: NOKEY, key ID 5072e1f5
Public key for MySQL-server-5.1.60-1.glibc23.i386.rpm is not installed

I can't start the mysql daemon and

# yum list MySQL

shows no trace of the package.

I tried a localinstall from a downloaded rpm file and got exactly the same result.

I hope this is something simple - it's a production server and I have to get it going again!

John VV 11-16-2012 11:05 PM

Quote:

I was running mysql (server) version 5.0.45-7.el5.
el5 means that this is "one" of the redhat 5 ( RHEL 5.0,5.1,5.2,5.3,5.4,5.5,5.6,5.7,5.8 )
or
CentOS 5.8 or Scientificlinux 5.8 ( both cent and sl ONLY support the current version in the major version)

so WHAT operating system are you using ?

RHEL is NOT free and you MUST have the REQUIRED support contract to install software
or
one of the FREE rebuilds ????
cent or SL

--------------

that error is from trying to install an incompatible rpm BYPASSING the distros repo

the "glibc23" on the end of that "Random" rpm file
means you MUST have a operating system BUILT with glibc 2.3
the rpm MUST MATCH your system



there is nothing i can offer untill you inform us as to what you are using

other than USE your operating system's update and base repo
Code:

su -
yum update mysql

or
build and install from source the database and ALL of it's prerequisites
and for a mismatching libc
that is 80% of the operating system

so
1)
exactly what operating system is it ?
2) and what version is it ?



blindly trying to bypass the safeguards in "yum" and installing an incompatible rpm from some " random place on the web"
is NEVER a good idea

Footsie 11-16-2012 11:28 PM

[root@monkey downloads]# cat /etc/*-release
CentOS release 5.2 (Final)

That's the OS. Can't make out whether you were asking anything else.

I want v5.1 of mysql. If you know how I should go about installing it, please let me know. I don't believe it is impossible.

John VV 11-17-2012 12:00 AM

cent STOPPED supporting 5.2 a very long time ago
Cent only supports the CURRENT minor version in the major version
Cent5.8 and Cent 6.3 are the ONLY supported versions

please UPGRADE
You have not installed any security fixes sense "2008-05-21" when 5.2 hit "End Of Life"

but if you must use a OS that is vulnerable to EVERY KNOWN security hole for the last 4 years

then build mysql from source

that is really your only option
and hopefully you will not have to rebuild half of the OS to do so ?
but you might !

Footsie 11-17-2012 12:13 AM

Okay, I'll upgrade.

Please bear in mind that I haven't done this before. If I just type

# yum update

and then re-boot, will that do the trick?

Am I likely to hit problems that will make me wish I'd never done it?

John VV 11-17-2012 01:13 AM

on 5.2 you can not do that, that will NOT work
ALL , every and ALL the rpms were removed a long time ago from the folders that are listed in the repo files
/mnt/SL6/etc/yum.repos.d/cent.repo

EVERY link in that file is dead
you would have to manually point it to the very old and insecure historical vault
and then you can ONLY install rpms that are 4+ years OUT OF DATE
-- NO UPDATES -
http://vault.centos.org/5.2/
mysql-5.0.45-7.el5.i386.rpm

is the very LAST update to 5.2 and that WAS in June of 2008

if you MUST stay wit ha unsupported version of a Operating system ( not recommended )
then you will have to manually build every and ALL prerequisite for that version of MySQL
-- a LOT of work .

Footsie 11-17-2012 03:10 AM

I was asking how to upgrade CentOS 5.2 to something shiny and new, and what the problems were likely to be.

Not sure whether or not you gave an answer???

John VV 11-17-2012 06:56 PM

in that case you will need to do a new CLEAN install of CentOS 6.3
there is no option to upgrade between major versions of the operating system

and the major version of mysql in centos 5.8 will be the SAME as in 5.2


All times are GMT -5. The time now is 02:16 PM.