LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
LinkBack Search this Thread
Old 01-22-2010, 03:31 PM   #1
arashi256
Member
 
Registered: Jan 2008
Location: Brighton, UK
Distribution: Ubuntu 12.04 / CentOS 6.5
Posts: 384

Rep: Reputation: 61
uShare - Directory Recursion and Symbolic Links


Hi all,

I have uShare 1.1a setup to talk to my XBox 360. If I share a directory that has no subdirectories, the video files display on the XBox. However, most of my files are in sub-directories on a different partition - I don't really want to copy them to the share, but uShare doesn't seem to recognise any sub-directories or files contained therein.

I have tried setting up symbolic soft links directly to the video files (although this is a pain, it is better than moving the files)...

Code:
ln -s /home/jonftp/TV-Shows/Buffy/Season-1/Buffy-101.avi /home/share/Buffy-101.avi
...but these don't show up on the XBox either.

How can I get uShare to "drill down" the directory structure to list the files or how can I get uShare to follow symbolic links?
 
Old 01-23-2010, 06:47 AM   #2
arashi256
Member
 
Registered: Jan 2008
Location: Brighton, UK
Distribution: Ubuntu 12.04 / CentOS 6.5
Posts: 384

Original Poster
Rep: Reputation: 61
I suppose I could get round this by sharing the directories, but again, this doesn't display what I'd expect. For example, I would have thought the following would display all AVI files in the /home/share directory, but it actually shows the last directory in the tree. Huh?

Code:
ln -s /home/jonftp/TV-Shows/Buffy/Season-1 /home/share
If I do an "ls" after this, I get the Season-1 directory and not a list of the files contained therein. Help?
 
Old 01-25-2010, 04:53 AM   #3
arashi256
Member
 
Registered: Jan 2008
Location: Brighton, UK
Distribution: Ubuntu 12.04 / CentOS 6.5
Posts: 384

Original Poster
Rep: Reputation: 61
Fixed - this works if you invoke ushare from the command line, but not the /rc.d/init.d/ushare start (for some reason).
 
Old 11-09-2013, 05:43 PM   #4
polrus
Member
 
Registered: Oct 2004
Location: Poland
Distribution: yoper
Posts: 53

Rep: Reputation: 15
i have the same experience - why is it different when you call it from command line?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ushare... 360 symbolic links do not work? naitackin Linux - Software 0 03-03-2009 05:28 PM
Symbolic links Vs Hard links sulekha Linux - General 2 10-02-2008 07:03 AM
Cannot remove symbolic directory links in RHEL3 WS ahelis Red Hat 5 03-24-2007 02:51 AM
Java Directory Recursion Kamikazee Programming 1 09-14-2006 05:42 PM
symbolic links neocontrol Linux - Software 3 05-15-2006 12:08 AM


All times are GMT -5. The time now is 01:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration