LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 06-29-2008, 12:43 AM   #1
farrukhndm
Member
 
Registered: Mar 2008
Location: Pakistan
Distribution: Fedora,Centos,RHEL
Posts: 75

Rep: Reputation: 15
Post Urgent ! our mail server is unable to receive mail from Other domains!


Dear Gurus

i am using postfix(SMTP :25 ) and Dovecot(IMAPS: 993) ports with Squirelmail as a web client on Fedora core 8 ,
from Last 2 days i am getting problem after changing my dsl Router from Aztech to LinksyswAG200G) .our organization mail server is unable to receive mail from other domains like yahoo,gmail etc.but whiten a orgnaiztion we can send or receive mails easily .but we can send mail to these servers. i am tried to telnet 25 its giving connectivinty when i connect to 993 it connected but on command prompt it shows nothing only blank screen.
i have also check mail log.by
#tail -f /var/log/maillog
when i cmd> telnet mailserverxxxx 993 on other machine with Public ip and simultaniously i am watching log it dosn't show me any connectivity of client but when i disconncted its show

Jun 29 09:58:15 mail dovecot: imap-login: Disconnected: rip=::ffff:xxx.xx.63.1x, lip=::ffff:xxx.xx.63.1x, TLS handshake

[root@mail ~]# netstat -antp | grep 993
tcp 0 0 xxx.xx.xx.xx:39932 xxx.xx.xx.xx:80 TIME _WAIT -
tcp 0 0 :::993 :::* LIST EN 1226/dovecot
tcp 0 0 :::22 :::* LIST EN 1993/sshd

i can't find problem is where...... there is no firewall rule disturbing my connectivity as i have flush all iptables rules temporarily .i have also disable DSL Router Firewall.

Last day when i checking all these thing i have also receive one mail from gmail but when i again resend then yet one i can't receive mail.

Please do helpful for me to solve this issue as our whole organization work is pending....
 
Old 06-29-2008, 12:46 AM   #2
chort
Senior Member
 
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 69
What's your domain name? If your machine is supposed to receive mail from the Internet, there's no "security risk" in posting the domain and IP. It's pretty difficult to help you if you leave out all the most important details.
 
Old 06-29-2008, 12:59 AM   #3
chort
Senior Member
 
Registered: Jul 2003
Location: Silicon Valley, USA
Distribution: OpenBSD 4.6, OS X 10.6.2, CentOS 4 & 5
Posts: 3,660

Rep: Reputation: 69
BTW your test results from inside are completely normal. You won't see a normal prompt if you try to connect to an implicit TLS service, which is what you're apparently running on 993 (IMAP4S). The log results are normal for a client terminating the connection before the TLS session was negotiated.

It sounds like your new router is not keeping track of sessions properly (or doesn't have port 25 forwarded, very difficult to tell from you post). Since the change corresponds with replacing the router, and it doesn't appear to be iptables on your server itself, it's almost certainly the router, but there's no way for anyone to tell for sure without testing and we can't do that without the domain name/host name/IP address on the outside.
 
Old 06-29-2008, 01:47 AM   #4
Mr. C.
Senior Member
 
Registered: Jun 2008
Posts: 2,529

Rep: Reputation: 59
Focus on your port 25 connectivity from the WAN. Its not clear to me why you mention or test the IMAPS (993) port, as it has nothing to do with sending mail. MTAs will connect to your port 25, so your firewall needs to allow access to port 25, or port forward as appropriate.

Watch your postfix logs for "connect from hostname[IP]" - if you don't see this line, that means postfix is not getting the connection, so focus on your firewall/router.
 
Old 06-29-2008, 02:27 AM   #5
sumit dash
Member
 
Registered: Jul 2007
Location: Hyderabad
Distribution: Red Hat
Posts: 33

Rep: Reputation: 15
Mail server

Hello dear,
to configure a mail server for receving mail server you have to edit the sendmail.mc file i.e you have to add dnl before
portmap=smtp 127.0.0.1 file after the commeinting this line restart sendamil service and restart
/etc/init.d/sendmail restart.
you can recive incoming mails after it.

Thanking you
sumit dash
 
Old 06-29-2008, 02:38 AM   #6
Mr. C.
Senior Member
 
Registered: Jun 2008
Posts: 2,529

Rep: Reputation: 59
The poster is using "postfix", not "sendmail".
 
Old 07-02-2008, 05:40 AM   #7
farrukhndm
Member
 
Registered: Mar 2008
Location: Pakistan
Distribution: Fedora,Centos,RHEL
Posts: 75

Original Poster
Rep: Reputation: 15
Problem is Solved by Changing DSL Router

My Problem has been solved by changing the DSL router ,As LinkSys WAG 200G. Our DSL Router Firewall was not allowing to Connect 25 port from outside of our LAN.

But still when i connect my Old LINKSYS WAG200G,i have disable its all Securites,Firewall but it makes dosn't effect to access.
by using LINKSYS wag200G DSL Router it disable all INBOUND TCP Traffic by default.

Please tell me is there any way to Allow INBOUND trafic in LINKSYS Wag200G.As i have Disable is Firewall but i dosn't allow me to Even Ping my Public IPS from OutSide.

Thanks for all for supporting .
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix mail server cant receive mail outside LAN shio Linux - Networking 2 10-05-2007 05:01 AM
Mail server, can send out, but cant receive christopher_c Linux - Newbie 7 10-04-2007 05:09 PM
with the linux proxi, backend pop3 mail client can not receive mail and send mail rubin823 Linux - Networking 0 12-21-2006 10:06 PM
setting up a mail server: unable to recieve mail Valkyrie_of_valhalla Linux - Networking 3 09-15-2006 01:29 PM
sendmail server unable to receive external mail goonfui_wong Linux - Networking 7 07-01-2005 02:15 AM


All times are GMT -5. The time now is 01:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration