LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 01-18-2010, 02:42 PM   #1
GDoctor
LQ Newbie
 
Registered: Apr 2009
Posts: 6

Rep: Reputation: 0
"unresolved requires" Error


Hi, im trying to update my Plesk and i get a strange error:
Code:
Warning: unresolved requires '/usr/sbin/sendmail' from uudeview-0.5.20-12.i386
What could be the reason for this ?
10x
 
Old 01-18-2010, 03:58 PM   #2
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 14,134

Rep: Reputation: 2456Reputation: 2456Reputation: 2456Reputation: 2456Reputation: 2456Reputation: 2456Reputation: 2456Reputation: 2456Reputation: 2456Reputation: 2456Reputation: 2456
Quote:
Originally Posted by GDoctor View Post
Hi, im trying to update my Plesk and i get a strange error:
Code:
Warning: unresolved requires '/usr/sbin/sendmail' from uudeview-0.5.20-12.i386
What could be the reason for this ?
10x
Hmm...could be that you don't have sendmail installed, or it's missing the link. It's telling you very plainly that you have an unresolved requirement, and that it's /usr/sbin/sendmail.

Also, it could be you're not installing as root. But you don't give any details, like version/distro of linux, what you're doing to generate this error, if you're installing from binary/source, etc. Hard to give help when yo don't provide details.
 
1 members found this post helpful.
Old 01-18-2010, 07:03 PM   #3
GDoctor
LQ Newbie
 
Registered: Apr 2009
Posts: 6

Original Poster
Rep: Reputation: 0
I use Fedora Core 7

The thing is Plesk update has failed...

The Plesk update started then gave error and now everything is ******

Now even my Horde email doesnt work and i have
Code:
 There was an error sending your message: Failed to open sendmail [/usr/sbin/sendmail] for execution.
Under the above error is this one:
Code:
Warning: unresolved requires 'psa-api-rpc = 9.2.3-fc7.build92091015.22' from psa-backup-manager-9.2.3-fc7.build92091015.22.i586

Last edited by GDoctor; 01-18-2010 at 07:08 PM.
 
Old 01-18-2010, 09:33 PM   #4
John VV
Guru
 
Registered: Aug 2005
Posts: 12,603

Rep: Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677
Quote:
I use Fedora Core 7
this is one of the problems right here .
Fedora 7 is WAY,WAY past it's end of life and has not been updated since June/2008 and WILL never be updated .

if you are trying to use "yum" in fedora 7 -- you can NOT the repos are dead.

Update to the current fedora 12 , then in 4 to 5 months reinstall to fedora 13 , then 6 months after that install fedora 14 .

-- or --
install the very long life CentOS . CentOS 5.4 is the current.
 
0 members found this post helpful.
Old 01-19-2010, 04:43 AM   #5
GDoctor
LQ Newbie
 
Registered: Apr 2009
Posts: 6

Original Poster
Rep: Reputation: 0
Fedora Core 7 is working fine, YUM is working good, the repos are not dead (not all) !

I cant use Fedora 12 because Plesk doesnt work on it yet !

I need to repair this install if i can, rebuilding is the last option...
 
Old 01-19-2010, 05:49 AM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,519

Rep: Reputation: 2495Reputation: 2495Reputation: 2495Reputation: 2495Reputation: 2495Reputation: 2495Reputation: 2495Reputation: 2495Reputation: 2495Reputation: 2495Reputation: 2495
Info from the Fedora 6 based EL5 / SL 5 / CentOS 5 :

# yum provides */sendmail
exim-4.63-3.el5.i386 : The exim mail transfer agent
Matched from:
Filename : /usr/sbin/sendmail


# yum install exim
( provides exim-4.66-3.fc7 on Fedora 7.)



The free versions of Redhat EL 5 = SL 54, CentOS 5
have end of life ' March 31, 2014 '.
.....
 
Old 01-19-2010, 06:32 AM   #7
GDoctor
LQ Newbie
 
Registered: Apr 2009
Posts: 6

Original Poster
Rep: Reputation: 0
It was something in php.ini, i had disable_functions ON ...now its OFF

Quote:
disable_functions =exec,passthru,shell_exec,system,proc_open,popen,curl_exec,curl_multi_exec,parse_ini_file
I hope that will not be a security problem...

This was a Plesk recommendation: http://kb.parallels.com/en/2278

Last edited by GDoctor; 01-19-2010 at 06:54 AM.
 
Old 01-26-2010, 04:59 PM   #8
Drew_Parallels
LQ Newbie
 
Registered: Oct 2009
Posts: 3

Rep: Reputation: 0
Correct me if I'm mistaken, but the error you're referencing is actually just a warning that may come up during the install process that can be ignored. If you have 'unresolved dependencies' errors, then you have a problem (means a package or packages can't be installed for some reason).

So, are you sure this is an error that's preventing you from moving forward?

Drew from Parallels
@ParallelsPanel
 
Old 01-27-2010, 03:46 AM   #9
GDoctor
LQ Newbie
 
Registered: Apr 2009
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Drew_Parallels View Post
Correct me if I'm mistaken, but the error you're referencing is actually just a warning that may come up during the install process that can be ignored. If you have 'unresolved dependencies' errors, then you have a problem (means a package or packages can't be installed for some reason).

So, are you sure this is an error that's preventing you from moving forward?

Drew from Parallels
@ParallelsPanel
You`re right, Igor from Plesk forum said the same thing, just a warning that can be ignored !
I just wanted to know what this error is about, now i know

I managed to work around all the warnings and no the problems are fixed !
 
Old 01-28-2010, 10:54 AM   #10
Drew_Parallels
LQ Newbie
 
Registered: Oct 2009
Posts: 3

Rep: Reputation: 0
Wonderful - I'm glad you got it figured out.
 
  


Reply

Tags
fedora, mail, update


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error:"Requires installation of untrusted packages" Nabeel Ubuntu 6 12-26-2009 10:05 AM
WEP key in place but "this network requires encryption to be enabled" jdtiede Linux - Wireless Networking 6 02-05-2009 07:23 AM
error: Error for wireless request "Set Mode" (8B06) : invalid argument "roaming" penguin chick Linux - Wireless Networking 5 08-22-2008 01:16 PM
CrossOver office 4.2 - "this application requires the windows installer to run." chucker8 Linux - Software 8 07-07-2006 02:35 PM
"unresolved symbol" loading smc91c92_cs NIC drivers Guitxo Linux - Networking 0 03-20-2002 09:52 AM


All times are GMT -5. The time now is 09:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration