LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   Unable to StartX - Please Help! (http://www.linuxquestions.org/questions/linux-server-73/unable-to-startx-please-help-928284/)

jdardis07 02-08-2012 07:37 AM

Unable to StartX - Please Help!
 
I have installed wine and cannot open any DISPLAY. I have figured a work around using VNC but this is not a permanent solution.

This is what gets returned in console:
Code:

startx
xauth:  creating new authority file /root/.serverauth.3236


X.Org X Server 1.10.4
Release Date: 2011-08-19
X Protocol Version 11, Revision 0
Build Operating System: c6b18n2 2.6.32-71.el6.x86_64
Current Operating System: Linux server.davewilsoncountry.com 2.6.18-028stab094.3 #1 SMP Thu Sep 22 12:47:37 MSD 2011 i686
Kernel command line: quiet
Build Date: 17 December 2011  04:48:52PM
Build ID: xorg-x11-server 1.10.4-6.el6_2.1
Current version of pixman: 0.18.4
        Before reporting problems, check https://www.redhat.com/apps/support/
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Feb  8 08:34:39 2012
(==) Using default built-in configuration (21 lines)

Fatal server error:
xf86OpenConsole: Cannot find a free VT: Inappropriate ioctl for device


Please consult the Red Hat, Inc. support
        at https://www.redhat.com/apps/support/
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

Here is my Xorg.0.log


Code:

[2415961.136]
X.Org X Server 1.10.4
Release Date: 2011-08-19
[2415961.136] X Protocol Version 11, Revision 0
[2415961.136] Build Operating System: c6b18n2 2.6.32-71.el6.x86_64
[2415961.136] Current Operating System: Linux server.davewilsoncountry.com 2.6.18-028stab094.3 #1 SMP Thu Sep 22 12:47:37 MSD 2011 i686
[2415961.136] Kernel command line: quiet
[2415961.136] Build Date: 17 December 2011  04:48:52PM
[2415961.136] Build ID: xorg-x11-server 1.10.4-6.el6_2.1
[2415961.136] Current version of pixman: 0.18.4
[2415961.136]        Before reporting problems, check https://www.redhat.com/apps/support/
        to make sure that you have the latest version.
[2415961.136] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[2415961.136] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Feb  8 08:05:36 2012
[2415961.136] (II) Loader magic: 0x822c500
[2415961.136] (II) Module ABI versions:
[2415961.136]        X.Org ANSI C Emulation: 0.4
[2415961.136]        X.Org Video Driver: 10.0
[2415961.136]        X.Org XInput driver : 12.2
[2415961.136]        X.Org Server Extension : 5.0
[2415961.137] List of video drivers:
[2415961.137]        vmwlegacy
[2415961.137]        glint
[2415961.137]        nv
[2415961.137]        nouveau
[2415961.137]        xgi
[2415961.141]        sisusb
[2415961.141]        radeon
[2415961.141]        qxl
[2415961.141]        intel
[2415961.141]        vmware
[2415961.141]        ast
[2415961.141]        voodoo
[2415961.141]        i128
[2415961.141]        mach64
[2415961.141]        apm
[2415961.141]        rendition
[2415961.141]        r128
[2415961.141]        openchrome
[2415961.141]        cirrus
[2415961.141]        neomagic
[2415961.141]        tdfx
[2415961.141]        sis
[2415961.141]        v4l
[2415961.141]        dummy
[2415961.141]        amd
[2415961.141]        siliconmotion
[2415961.141]        mga
[2415961.141]        savage
[2415961.141]        s3virge
[2415961.141]        i740
[2415961.141]        geode
[2415961.141]        trident
[2415961.142]        ati
[2415961.142]        ztv
[2415961.142]        fbdev
[2415961.142]        vesa
[2415961.142] (II) LoadModule: "vmwlegacy"
[2415961.142] (II) Loading /usr/lib/xorg/modules/drivers/vmwlegacy_drv.so
[2415961.142] (II) Module vmwlegacy: vendor="X.Org Foundation"
[2415961.142]        compiled for 1.10.4, module version = 11.0.3
[2415961.142]        Module class: X.Org Video Driver
[2415961.142]        ABI class: X.Org Video Driver, version 10.0
[2415961.142] (II) LoadModule: "glint"
[2415961.143] (II) Loading /usr/lib/xorg/modules/drivers/glint_drv.so
[2415961.143] (II) Module glint: vendor="X.Org Foundation"
[2415961.143]        compiled for 1.10.4, module version = 1.2.5
[2415961.143]        Module class: X.Org Video Driver
[2415961.143]        ABI class: X.Org Video Driver, version 10.0
[2415961.143] (II) LoadModule: "nv"
[2415961.143] (II) Loading /usr/lib/xorg/modules/drivers/nv_drv.so
[2415961.143] (II) Module nv: vendor="X.Org Foundation"
[2415961.143]        compiled for 1.10.4, module version = 2.1.18
[2415961.143]        Module class: X.Org Video Driver
[2415961.143]        ABI class: X.Org Video Driver, version 10.0
[2415961.143] (II) LoadModule: "nouveau"
[2415961.144] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so
[2415961.144] (II) Module nouveau: vendor="X.Org Foundation"
[2415961.144]        compiled for 1.10.4, module version = 0.0.16
[2415961.144]        Module class: X.Org Video Driver
[2415961.144]        ABI class: X.Org Video Driver, version 10.0
[2415961.144] (II) LoadModule: "xgi"
[2415961.144] (II) Loading /usr/lib/xorg/modules/drivers/xgi_drv.so
[2415961.145] (II) Module xgi: vendor="X.Org Foundation"
[2415961.145]        compiled for 1.10.4, module version = 6.1.6803
[2415961.145]        Module class: X.Org Video Driver
[2415961.145]        ABI class: X.Org Video Driver, version 10.0
[2415961.145] (II) LoadModule: "sisusb"
[2415961.145] (II) Loading /usr/lib/xorg/modules/drivers/sisusb_drv.so
[2415961.145] (II) Module sisusb: vendor="X.Org Foundation"
[2415961.145]        compiled for 1.10.4, module version = 0.9.4
[2415961.145]        Module class: X.Org Video Driver
[2415961.145]        ABI class: X.Org Video Driver, version 10.0
[2415961.145] (II) LoadModule: "radeon"
[2415961.145] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
[2415961.164] (II) Module radeon: vendor="X.Org Foundation"
[2415961.164]        compiled for 1.10.4, module version = 6.14.2
[2415961.164]        Module class: X.Org Video Driver
[2415961.164]        ABI class: X.Org Video Driver, version 10.0
[2415961.164] (II) LoadModule: "qxl"
[2415961.164] (II) Loading /usr/lib/xorg/modules/drivers/qxl_drv.so
[2415961.164] (II) Module qxl: vendor="X.Org Foundation"
[2415961.164]        compiled for 1.10.4, module version = 0.0.0
[2415961.164]        Module class: X.Org Video Driver
[2415961.164]        ABI class: X.Org Video Driver, version 10.0
[2415961.164] (II) LoadModule: "intel"
[2415961.165] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[2415961.165] (II) Module intel: vendor="X.Org Foundation"
[2415961.165]        compiled for 1.10.4, module version = 2.16.0
[2415961.165]        Module class: X.Org Video Driver
[2415961.165]        ABI class: X.Org Video Driver, version 10.0
[2415961.165] (II) LoadModule: "vmware"
[2415961.165] (II) Loading /usr/lib/xorg/modules/drivers/vmware_drv.so
[2415961.165] (II) Module vmware: vendor="X.Org Foundation"
[2415961.165]        compiled for 1.10.4, module version = 11.0.3
[2415961.165]        Module class: X.Org Video Driver
[2415961.165]        ABI class: X.Org Video Driver, version 10.0
[2415961.165] (II) LoadModule: "vmwgfx"
[2415961.166] (WW) Warning, couldn't open module vmwgfx
[2415961.166] (II) UnloadModule: "vmwgfx"
[2415961.166] (II) Unloading vmwgfx
[2415961.166] (EE) Failed to load module "vmwgfx" (module does not exist, 0)
[2415961.166] (EE) vmware: Please ignore the above warnings about not being able to to load module/driver vmwgfx
[2415961.166] (II) vmware: Using vmwlegacy driver everything is fine.
[2415961.166] (II) LoadModule: "vmwlegacy"
[2415961.167] (II) Loading /usr/lib/xorg/modules/drivers/vmwlegacy_drv.so
[2415961.167] (II) Module vmwlegacy: vendor="X.Org Foundation"
[2415961.167]        compiled for 1.10.4, module version = 11.0.3
[2415961.167]        Module class: X.Org Video Driver
[2415961.167]        ABI class: X.Org Video Driver, version 10.0
[2415961.167] (II) UnloadModule: "vmwlegacy"
[2415961.167] (II) Unloading vmwlegacy
[2415961.167] (II) Failed to load module "vmwlegacy" (already loaded, 0)
[2415961.167] (EE) vmware: Unexpected failure while loading the "vmwlegacy" driver. Giving up.
[2415961.167] (II) UnloadModule: "vmware"
[2415961.167] (II) Unloading vmware
[2415961.167] (EE) Failed to load module "vmware" (a required submodule could not be loaded, -1077344280)
[2415961.167] (II) LoadModule: "ast"
[2415961.167] (II) Loading /usr/lib/xorg/modules/drivers/ast_drv.so
[2415961.168] (II) Module ast: vendor="X.Org Foundation"
[2415961.168]        compiled for 1.10.4, module version = 0.91.10
[2415961.168]        Module class: X.Org Video Driver
[2415961.168]        ABI class: X.Org Video Driver, version 10.0
[2415961.168] (II) LoadModule: "voodoo"
[2415961.168] (II) Loading /usr/lib/xorg/modules/drivers/voodoo_drv.so
[2415961.168] (II) Module voodoo: vendor="X.Org Foundation"
[2415961.168]        compiled for 1.10.4, module version = 1.1.0
[2415961.168]        Module class: X.Org Video Driver
[2415961.168]        ABI class: X.Org Video Driver, version 10.0
[2415961.168] (II) LoadModule: "i128"
[2415961.169] (II) Loading /usr/lib/xorg/modules/drivers/i128_drv.so
[2415961.169] (II) Module i128: vendor="X.Org Foundation"
[2415961.169]        compiled for 1.10.4, module version = 1.3.4
[2415961.169]        Module class: X.Org Video Driver
[2415961.169]        ABI class: X.Org Video Driver, version 10.0
[2415961.169] (II) LoadModule: "mach64"
[2415961.169] (II) Loading /usr/lib/xorg/modules/drivers/mach64_drv.so
[2415961.169] (II) Module mach64: vendor="X.Org Foundation"
[2415961.169]        compiled for 1.10.4, module version = 6.9.0
[2415961.169]        Module class: X.Org Video Driver
[2415961.169]        ABI class: X.Org Video Driver, version 10.0
[2415961.169] (II) LoadModule: "apm"
[2415961.170] (II) Loading /usr/lib/xorg/modules/drivers/apm_drv.so
[2415961.170] (II) Module apm: vendor="X.Org Foundation"
[2415961.170]        compiled for 1.10.4, module version = 1.2.3
[2415961.170]        Module class: X.Org Video Driver
[2415961.170]        ABI class: X.Org Video Driver, version 10.0
[2415961.170] (II) LoadModule: "rendition"
[2415961.170] (II) Loading /usr/lib/xorg/modules/drivers/rendition_drv.so
[2415961.170] (II) Module rendition: vendor="X.Org Foundation"
[2415961.170]        compiled for 1.10.4, module version = 4.2.4
[2415961.170]        Module class: X.Org Video Driver
[2415961.170]        ABI class: X.Org Video Driver, version 10.0
[2415961.170] (II) LoadModule: "r128"
[2415961.171] (II) Loading /usr/lib/xorg/modules/drivers/r128_drv.so
[2415961.171] (II) Module r128: vendor="X.Org Foundation"
[2415961.171]        compiled for 1.10.4, module version = 6.8.1
[2415961.171]        Module class: X.Org Video Driver
[2415961.171]        ABI class: X.Org Video Driver, version 10.0
[2415961.171] (II) LoadModule: "openchrome"
[2415961.172] (II) Loading /usr/lib/xorg/modules/drivers/openchrome_drv.so
[2415961.172] (II) Module openchrome: vendor="http://openchrome.org/"
[2415961.172]        compiled for 1.10.4, module version = 0.2.904
[2415961.172]        Module class: X.Org Video Driver
[2415961.172]        ABI class: X.Org Video Driver, version 10.0
[2415961.172] (II) LoadModule: "cirrus"
[2415961.172] (II) Loading /usr/lib/xorg/modules/drivers/cirrus_drv.so
[2415961.172] (II) Module cirrus: vendor="X.Org Foundation"
[2415961.172]        compiled for 1.10.4, module version = 1.3.2
[2415961.172]        Module class: X.Org Video Driver
[2415961.172]        ABI class: X.Org Video Driver, version 10.0
[2415961.172] (II) LoadModule: "neomagic"
[2415961.173] (II) Loading /usr/lib/xorg/modules/drivers/neomagic_drv.so
[2415961.173] (II) Module neomagic: vendor="X.Org Foundation"
[2415961.173]        compiled for 1.10.4, module version = 1.2.5
[2415961.173]        Module class: X.Org Video Driver
[2415961.173]        ABI class: X.Org Video Driver, version 10.0
[2415961.173] (II) LoadModule: "tdfx"
[2415961.173] (II) Loading /usr/lib/xorg/modules/drivers/tdfx_drv.so
[2415961.173] (II) Module tdfx: vendor="X.Org Foundation"
[2415961.173]        compiled for 1.10.4, module version = 1.4.3
[2415961.173]        Module class: X.Org Video Driver
[2415961.173]        ABI class: X.Org Video Driver, version 10.0
[2415961.173] (II) LoadModule: "sis"
[2415961.174] (II) Loading /usr/lib/xorg/modules/drivers/sis_drv.so
[2415961.174] (II) Module sis: vendor="X.Org Foundation"
[2415961.174]        compiled for 1.10.4, module version = 0.10.3
[2415961.174]        Module class: X.Org Video Driver
[2415961.174]        ABI class: X.Org Video Driver, version 10.0
[2415961.174] (II) LoadModule: "v4l"
[2415961.175] (II) Loading /usr/lib/xorg/modules/drivers/v4l_drv.so
[2415961.175] (II) Module v4l: vendor="X.Org Foundation"
[2415961.175]        compiled for 1.10.4, module version = 0.1.1
[2415961.175]        ABI class: X.Org Video Driver, version 10.0
[2415961.175] (II) LoadModule: "dummy"
[2415961.175] (II) Loading /usr/lib/xorg/modules/drivers/dummy_drv.so
[2415961.175] (II) Module dummy: vendor="X.Org Foundation"
[2415961.175]        compiled for 1.10.4, module version = 0.3.4
[2415961.175]        Module class: X.Org Video Driver
[2415961.175]        ABI class: X.Org Video Driver, version 10.0
[2415961.175] (II) LoadModule: "amd"
[2415961.176] (II) Loading /usr/lib/xorg/modules/drivers/amd_drv.so
[2415961.176] (II) Module amd: vendor="X.Org Foundation"
[2415961.176]        compiled for 1.10.4, module version = 2.11.12
[2415961.176]        Module class: X.Org Video Driver
[2415961.176]        ABI class: X.Org Video Driver, version 10.0
[2415961.176] (II) LoadModule: "siliconmotion"
[2415961.176] (II) Loading /usr/lib/xorg/modules/drivers/siliconmotion_drv.so
[2415961.176] (II) Module siliconmotion: vendor="X.Org Foundation"
[2415961.176]        compiled for 1.10.4, module version = 1.7.5
[2415961.176]        Module class: X.Org Video Driver
[2415961.177]        ABI class: X.Org Video Driver, version 10.0
[2415961.177] (II) LoadModule: "mga"
[2415961.177] (II) Loading /usr/lib/xorg/modules/drivers/mga_drv.so
[2415961.177] (II) Module mga: vendor="X.Org Foundation"
[2415961.177]        compiled for 1.10.4, module version = 1.4.13
[2415961.177]        Module class: X.Org Video Driver
[2415961.177]        ABI class: X.Org Video Driver, version 10.0
[2415961.177] (II) LoadModule: "savage"
[2415961.178] (II) Loading /usr/lib/xorg/modules/drivers/savage_drv.so
[2415961.178] (II) Module savage: vendor="X.Org Foundation"
[2415961.178]        compiled for 1.10.4, module version = 2.3.2
[2415961.178]        Module class: X.Org Video Driver
[2415961.178]        ABI class: X.Org Video Driver, version 10.0
[2415961.178] (II) LoadModule: "s3virge"
[2415961.178] (II) Loading /usr/lib/xorg/modules/drivers/s3virge_drv.so
[2415961.178] (II) Module s3virge: vendor="X.Org Foundation"
[2415961.178]        compiled for 1.10.4, module version = 1.10.4
[2415961.178]        Module class: X.Org Video Driver
[2415961.178]        ABI class: X.Org Video Driver, version 10.0
[2415961.179] (II) LoadModule: "i740"
[2415961.179] (II) Loading /usr/lib/xorg/modules/drivers/i740_drv.so
[2415961.179] (II) Module i740: vendor="X.Org Foundation"
[2415961.179]        compiled for 1.10.4, module version = 1.3.2
[2415961.179]        Module class: X.Org Video Driver
[2415961.179]        ABI class: X.Org Video Driver, version 10.0
[2415961.179] (II) LoadModule: "geode"
[2415961.180] (II) Loading /usr/lib/xorg/modules/drivers/geode_drv.so
[2415961.180] (II) Module geode: vendor="X.Org Foundation"
[2415961.180]        compiled for 1.10.4, module version = 2.11.12
[2415961.180]        Module class: X.Org Video Driver
[2415961.180]        ABI class: X.Org Video Driver, version 10.0
[2415961.180] (II) LoadModule: "trident"
[2415961.180] (II) Loading /usr/lib/xorg/modules/drivers/trident_drv.so
[2415961.180] (II) Module trident: vendor="X.Org Foundation"
[2415961.180]        compiled for 1.10.4, module version = 1.3.4
[2415961.180]        Module class: X.Org Video Driver
[2415961.180]        ABI class: X.Org Video Driver, version 10.0
[2415961.180] (II) LoadModule: "ati"
[2415961.181] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
[2415961.181] (II) Module ati: vendor="X.Org Foundation"
[2415961.181]        compiled for 1.10.4, module version = 6.14.2
[2415961.181]        Module class: X.Org Video Driver
[2415961.181]        ABI class: X.Org Video Driver, version 10.0
[2415961.181] (II) LoadModule: "ztv"
[2415961.182] (II) Loading /usr/lib/xorg/modules/drivers/ztv_drv.so
[2415961.182] (II) Module ztv: vendor="X.Org Foundation"
[2415961.182]        compiled for 1.10.4, module version = 0.0.1
[2415961.182]        ABI class: X.Org Video Driver, version 10.0
[2415961.182] (II) LoadModule: "fbdev"
[2415961.182] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[2415961.182] (II) Module fbdev: vendor="X.Org Foundation"
[2415961.182]        compiled for 1.10.4, module version = 0.4.2
[2415961.182]        ABI class: X.Org Video Driver, version 10.0
[2415961.182] (II) LoadModule: "vesa"
[2415961.183] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[2415961.183] (II) Module vesa: vendor="X.Org Foundation"
[2415961.183]        compiled for 1.10.4, module version = 2.3.0
[2415961.183]        Module class: X.Org Video Driver
[2415961.183]        ABI class: X.Org Video Driver, version 10.0
[2415961.183]
Fatal server error:
[2415961.183] xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
[2415961.183]
[2415961.183]
Please consult the Red Hat, Inc. support
        at https://www.redhat.com/apps/support/
 for help.
[2415961.183] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[2415961.183]

I have been struggling with this for a long time now, I hope someone can help.

(There is no Xorg.conf in /etc/X11/)

adamk75 02-08-2012 09:49 AM

Do you know what video card you have? What's the output of 'lspci | grep -i vga'?

Adam

jdardis07 02-08-2012 07:21 PM

Quote:

Originally Posted by adamk75 (Post 4597096)
Do you know what video card you have? What's the output of 'lspci | grep -i vga'?

Adam

That command returns nothing.
I don't know what VGA I have but I will ask the host and find out.

adamk75 02-08-2012 07:37 PM

So you're not running this on a local machine? Then what's the point of getting X running?

EDIT: If this a server at a hosting facility, there is a good chance there is no video card. Maybe you should explain what your ultimate goal is here...

jdardis07 02-08-2012 07:45 PM

Okay first let me ask this stupid question... This is a Linux VPS hosting package, I am trying to run a windows program via wine. Do I HAVE TO use VNC to access the program, or can I get X working properly and run the software strictly through wine?? (It requires a GUI)...

The reason I hate the VNC setup is because this is Audio Broadcasting software and the DJ's will have to use it via VNC which is extremely slow and horrible.......

adamk75 02-09-2012 04:22 AM

If this machine is not local, you will either have to use VNC or have the users ssh into the box with X11 forwarding enabled, and launch this program so that it's displayed on their local machine.

Adam

jdardis07 02-09-2012 06:12 AM

Quote:

Originally Posted by adamk75 (Post 4597896)
If this machine is not local, you will either have to use VNC or have the users ssh into the box with X11 forwarding enabled, and launch this program so that it's displayed on their local machine.

Adam

If I forwarded X would I get the same results as VNC? (Slow response time, bad graphix)

Thanks for the info

adamk75 02-09-2012 06:26 AM

Well the graphics would probably look better than in vnc, but it would be even slower than vnc.

grave_violin 02-09-2012 06:30 AM

I had similar problem with FreeBSD.

Solution in FreeBSD:

# Xorg -configure

this creates a file xorg.conf.new in /root.

# cp xorg.conf.new /etc/X11/xorg.conf

# startx

That solves the problem in FreeBSD. I do not know if it does in Linux too.


All times are GMT -5. The time now is 12:49 AM.