LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 10-19-2010, 05:11 AM   #1
mselvaprakash
LQ Newbie
 
Registered: Oct 2010
Posts: 7

Rep: Reputation: 0
Question Unable to Start X in Centos


# startx
xauth: creating new authority file /root/.serverauth.18174

X Window System Version 7.1.1
Release Date: 12 May 2006
X Protocol Version 11, Revision 0, Release 7.1.1
Build Operating System: Linux 2.6.18-53.el5 i686 Red Hat, Inc.
Current Operating System: Linux server1. 2.6.18-194.8.1.el5.028stab070.4PAE
#1 SMP Tue Aug 17 20:20:00 MSD 2010 i686
Build Date: 13 May 2010
Build ID: xorg-x11-server 1.1.1-48.76.el5_5.1
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Oct 18 21:13:59 2010
(EE) Unable to locate/open config file

Fatal server error:
xf86OpenConsole: Cannot open /dev/tty0 (No such file or directory)

XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.
Couldnt get a file descriptor referring to the console


i have used these commands also
mknod /dev/tty0 c 4 0
chmod 660 /dev/tty0

plz suggest me, how to do it??
 
Old 10-19-2010, 07:39 AM   #2
mselvaprakash
LQ Newbie
 
Registered: Oct 2010
Posts: 7

Original Poster
Rep: Reputation: 0
# /sbin/lspci | grep -i vga

pcilib: Cannot open /proc/bus/pci
lspci: Cannot find any working access method.

-----------

/etc/X11/xorg.conf

file is missing..

------------

# setup
No video cards were found on this machine, exiting

-----------

in proc filesystem /proc/pci/bus is missing.

-----------

Fatal server error:
xf86OpenConsole: Cannot open /dev/tty0 (No such file or directory)

(WW) xf86CloseConsole: KDSETMODE failed: Bad file descriptor
(WW) xf86CloseConsole: VT_GETMODE failed: Bad file descriptor

-------------
 
Old 10-20-2010, 02:07 AM   #3
vishesh
Member
 
Registered: Feb 2008
Distribution: Fedora,RHEL,Ubuntu
Posts: 660

Rep: Reputation: 66
You can manually create xorg.conf if u have following details
Monitor specifications
Video Adapter chipset
Video Adapter memory

Gooling can help your further.

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to Start X in Centos - VPS - SSH mselvaprakash Linux - General 1 10-19-2010 07:40 AM
Centos apache unable to start correctly shihao Linux - Server 18 12-10-2009 06:38 AM
Unable to boot in CentOS 5.4 nikunjbadjatya Linux - Software 4 11-12-2009 10:18 PM
Unable to start apache on CentOS Linux with error Starting httpd: Syntax error on lin pkumar2533 Linux - Newbie 9 08-26-2009 07:48 AM
CentOS v5.2 - Unable to start udev Arty Ziff Linux - Server 3 12-03-2008 07:16 AM


All times are GMT -5. The time now is 08:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration