LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 03-24-2007, 06:45 PM   #1
ejan
Member
 
Registered: Mar 2007
Location: Rochester Hills, MI, USA
Distribution: Mandriva 2007, CentOS 5, Debian 4.0
Posts: 38

Rep: Reputation: 15
Unable to Login to Swat


I've just installed Samba and Swat. When I connect to Swat (http://localhost:901), it prompts me for user name and password. The problem is it won't accept the correct credentials that I enter. It simply doesn't allow me to login even though I am providing the correct credentials.

The following error message is logged when I provide my credentials to Swat:

Quote:
[root@ejan ehsanullahjan]# tail -n 0 -f /var/log/messages
Mar 25 04:44:58 ejan swat[22318]: [2007/03/25 04:44:58, 0] printing/print_cups.c:cups_cache_reload(85)
Mar 25 04:44:58 ejan swat[22318]: Unable to connect to CUPS server localhost - Connection refused
Mar 25 04:45:04 ejan swat[22319]: [2007/03/25 04:45:04, 0] printing/print_cups.c:cups_cache_reload(85)
Mar 25 04:45:04 ejan swat[22319]: Unable to connect to CUPS server localhost - Connection refused
Mar 25 04:45:04 ejan swat[22319]: [2007/03/25 04:45:04, 0] auth/pampass.c:smb_pam_auth(535)
Mar 25 04:45:04 ejan swat[22319]: smb_pam_auth: PAM: UNKNOWN ERROR while authenticating user root
Mar 25 04:45:04 ejan swat[22319]: [2007/03/25 04:45:04, 0] auth/pampass.c:smb_pam_passcheck(810)
Mar 25 04:45:04 ejan swat[22319]: smb_pam_passcheck: PAM: smb_pam_auth failed - Rejecting User root !
Any ideas what might be wrong and how to fix it?
 
Old 03-26-2007, 04:47 AM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Post the contents of /etc/xinetd.d/swat
 
Old 03-26-2007, 03:01 PM   #3
ejan
Member
 
Registered: Mar 2007
Location: Rochester Hills, MI, USA
Distribution: Mandriva 2007, CentOS 5, Debian 4.0
Posts: 38

Original Poster
Rep: Reputation: 15
I also posted the same issue on Mandriva forums. It turned out that the SWAT package bundled with Mandriva 2007 Free is broken. The solution is as simple as replacing contents of your /etc/pam.d/samba file with the following

Code:
auth       include      system-auth
account    required     pam_nologin.so
account    include      system-auth
session    include      system-auth
For complete details please see the relavent post on Mandriva forums.

Thank you.
 
  


Reply

Tags
samba, swat


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to launch SWAT to configure SAMBA Bobby P Slackware 1 02-27-2007 03:52 PM
Problems with Samba-Swat: Unable to see other Windoze machines on my network. sutherncomfort Linux - Networking 9 02-02-2005 09:30 PM
I cannot login to SWAT Micah Linux - Software 3 02-19-2004 01:12 PM
unable to run SWAT gmansfield Linux - Newbie 10 09-09-2003 10:02 AM
Unable to access SWAT triplem Linux - Software 1 04-11-2003 03:32 PM


All times are GMT -5. The time now is 12:07 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration