LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 07-17-2012, 07:43 AM   #1
devan1p
LQ Newbie
 
Registered: May 2006
Posts: 12

Rep: Reputation: 0
Unable to login to samba-swat as non-root user


Hello,

I have recently configured a samba server and swat. I am unable to login to swat as non-root user. Below is the error logs I could see -

Jul 17 15:21:45 localhost xinetd[3927]: START: swat pid=9297 from=::ffff:192.168.0.110
Jul 17 15:21:46 localhost swat[9297]: [2012/07/17 15:21:46.796479, 0] auth/pampass.c:823(smb_pam_passcheck)
Jul 17 15:21:46 localhost swat[9297]: smb_pam_passcheck: PAM: smb_pam_auth failed - Rejecting User dev !
Jul 17 15:21:46 localhost xinetd[3927]: EXIT: swat status=0 pid=9297 duration=1(sec)


It is to be noted that I am able to access the shares without any issue and root login to swat is possible. Could anyone help me on solving this issue. I am using tdbsam as my password backend. Below is the global configuration on my smb.conf -

[global]
log file = /var/log/samba/log.%m
cups options = raw
load printers = yes
server string = Samba Server Version %v
workgroup = WORKGROUP
encrypt passwords = yes
security = user
passdb backend = tdbsam
max log size = 50

and below is the /etc/pam.d/samba file -

#%PAM-1.0
auth required pam_nologin.so
auth include password-auth
account include password-auth
session include password-auth
password include password-auth


Below is the log from /var/log/samba/log.swat -

[2012/07/17 15:37:44.019329, 0] auth/pampass.c:823(smb_pam_passcheck)
smb_pam_passcheck: PAM: smb_pam_auth failed - Rejecting User dev !


OS: Centos 6.2
Samba version :
samba.x86_64 3.5.10-125.el6
samba-client.x86_64 3.5.10-125.el6
samba-common.x86_64 3.5.10-125.el6
samba-swat.x86_64 3.5.10-125.el6

I am basically looking for a GUI to be given to users to change their smb password.

Thanks!
Dev

Last edited by devan1p; 07-17-2012 at 07:48 AM. Reason: updating information provided
 
Old 07-17-2012, 10:21 AM   #2
Abbaddon
Member
 
Registered: Aug 2004
Location: Guam
Distribution: Ubuntu, Gentoo
Posts: 45

Rep: Reputation: 15
Try webmin
 
Old 07-18-2012, 12:38 AM   #3
devan1p
LQ Newbie
 
Registered: May 2006
Posts: 12

Original Poster
Rep: Reputation: 0
Hello,

Thanks for the suggestion. I do have webmin installed; but unable to login as non-root user. Below is the log available with /var/log/secure -

Jul 18 08:32:15 localhost webmin[3726]: Non-existent login as dev from 192.168.0.110

The system user is existing but the shell is set to /bin/false. I do not want any users to login to this server. -

dev:x:1003:1003::/home/dev:/bin/false # from /etc/passwd

SELinux is disabled.

Any other suggestions?

Thanks!
Dev
 
Old 07-18-2012, 04:38 AM   #4
devan1p
LQ Newbie
 
Registered: May 2006
Posts: 12

Original Poster
Rep: Reputation: 0
Hello,

I have installed usermin and customized it to let the users change only password and user details. This is exactly what I wanted to achieve . Not sure what is the issue with swat. I might try that again on a lab system when I get time.

Thanks!
Dev
 
Old 07-18-2012, 05:50 AM   #5
centos123
Member
 
Registered: Apr 2011
Posts: 394

Rep: Reputation: 15
can you tell me procedure of configuration of swat server.......or link from where you configure..
 
Old 07-18-2012, 09:47 AM   #6
devan1p
LQ Newbie
 
Registered: May 2006
Posts: 12

Original Poster
Rep: Reputation: 0
Hi,

You can use yum to install samba-swat. The configuration is pretty simple.

Edit /etc/xinetd.d/swat (below given is mine. Modify 'only_from' to match your subnet and 'disable = no')

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
# default: off
# description: SWAT is the Samba Web Admin Tool. Use swat \
# to configure your Samba server. To use SWAT, \
# connect to port 901 with your favorite web browser.
service swat
{
port = 901
socket_type = stream
wait = no
only_from = 127.0.0.1 192.168.0.0/24
user = root
server = /usr/sbin/swat
log_on_failure += USERID
disable = no

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

save the file and start the service -

# /etc/init.d/swat start

make swat persistent across reboots -

# chkconfig swat on

and that's it. You can access swat by http://ipaddress:901

Also make sure to open the required port if you run a firewall.

Thanks!
Dev
 
  


Reply

Tags
pamauth, sambaswat


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Root login but no user login on samba Cybercool Linux - Newbie 3 07-13-2011 06:36 AM
unable to login as user; can login as root. rksanders Debian 24 02-09-2011 09:01 AM
Unable to login as root or user. mikeborger Linux - Newbie 11 01-31-2011 11:58 AM
Samba SWAT doesnt accept Root Password or User name Matt Perrgo Linux - Newbie 2 07-25-2008 03:33 AM
root login failure on samba-swat strimp099 Linux - Networking 4 05-27-2004 06:24 AM


All times are GMT -5. The time now is 08:49 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration