LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   Unable to login to NIS client machine(Ubuntu) using NIS login user name (http://www.linuxquestions.org/questions/linux-server-73/unable-to-login-to-nis-client-machine-ubuntu-using-nis-login-user-name-653394/)

crazymoonboy 07-03-2008 01:18 PM

Unable to login to NIS client machine(Ubuntu) using NIS login user name
 
Hi Friends,

I configured NIS server in Fedora 9 and is working fine.

I configured NIS client in Ubuntu and it is able to bind the NIS server.

In my NIS client machine:
1) "ypcat passwd" is showing all users passwords in NIS server.
2) "id nisuser" is showing the uid, gid and group values.

But, I am unable to login to my client machine using NIS login user name.

Can anybody suggest me a solution?

Thanks in advance.

Regards,
Chandramouli

Mr. C. 07-06-2008 10:39 PM

What does your /etc/nsswitch.conf file look like?

engelienart 02-09-2009 06:03 AM

Hi, I could start a topic of my own, but it seems to me, this thread asks the same question I want to ask:

I have NIS client working on a Ubuntu Workstation
I have NIS server working on a Ubuntu Server

1) "ypcat passwd" is showing all users passwords in NIS server.

2) "id %NISUSER%" says: "id: %NISUSER%: unknown user"

But, I am unable to login to my client machine using NIS login user name.

I find it difficult to explain myself: I want after a reboot, the Workstation most ask for a username and password. I want to be able to provide my username and password of a user of the server and after that, I will be able to see my home directory (and some shares/ or what ever they are called in Linux). If I am a member of the group ICT, I want to be able to see the ICT share and have a desktopicon that is linked to the share.

I am used to Windows NT 4.0 (lets all point at me and laugh) with Windows NT server, workstation and a NT domain. Currently I have a Ubuntu Server which runs a samba server, so my Windows XP workstations can logon a NT domain of the samba server.

If somebody would tell me what I am doing wrong, please do.

I forgot the /etc/nsswitch.conf:


Code:

# /etc/nsswitch.conf
#
# Example configuration of GNU Name Service Switch functionality.
# If you have the `glibc-doc' and `info' packages installed, try:
# `info libc "Name Service Switch"' for information about this file.

passwd:        compat
group:          compat
shadow:        compat

hosts:          files dns mdns
networks:      files

protocols:      db files
services:      db files
ethers:        db files
rpc:            db files

netgroup:      nis


engelienart 02-10-2009 06:32 AM

I am bumping this thread, because I still don't have an answer. I still have no clue what I have done wrong.

gouthamtrip 08-26-2009 08:20 AM

ubuntu Unknown id: nis client problem
 
Hi,

Try to add nis beside the compat parameter...below is the example nsswitch config file on ubuntu client system:

passwd: compat nis
group: compat nis
shadow: compat nis

#hosts: files mdns4_minimal [NOTFOUND=return] nis dns mdns4
networks: files

protocols: db files
services: db files
ethers: db files
rpc: db files

netgroup: nis

#--------------------------------------------

now test it with command:
root@red:~#yptest (you should see nis users list )
root@red:~# id test <test is the username on nisserver>

Regards,

Goutham T


Quote:

Originally Posted by engelienart (Post 3437042)
Hi, I could start a topic of my own, but it seems to me, this thread asks the same question I want to ask:

I have NIS client working on a Ubuntu Workstation
I have NIS server working on a Ubuntu Server

1) "ypcat passwd" is showing all users passwords in NIS server.

2) "id %NISUSER%" says: "id: %NISUSER%: unknown user"

But, I am unable to login to my client machine using NIS login user name.

I find it difficult to explain myself: I want after a reboot, the Workstation most ask for a username and password. I want to be able to provide my username and password of a user of the server and after that, I will be able to see my home directory (and some shares/ or what ever they are called in Linux). If I am a member of the group ICT, I want to be able to see the ICT share and have a desktopicon that is linked to the share.

I am used to Windows NT 4.0 (lets all point at me and laugh) with Windows NT server, workstation and a NT domain. Currently I have a Ubuntu Server which runs a samba server, so my Windows XP workstations can logon a NT domain of the samba server.

If somebody would tell me what I am doing wrong, please do.

I forgot the /etc/nsswitch.conf:


Code:

# /etc/nsswitch.conf
#
# Example configuration of GNU Name Service Switch functionality.
# If you have the `glibc-doc' and `info' packages installed, try:
# `info libc "Name Service Switch"' for information about this file.

passwd:        compat
group:          compat
shadow:        compat

hosts:          files dns mdns
networks:      files

protocols:      db files
services:      db files
ethers:        db files
rpc:            db files

netgroup:      nis



OldManWinter 11-26-2009 08:13 PM

I realise this is a little late, but after adding users to the NIS server or changing their passwords you need to go into /var/yp on the nis server and run make to rebuild the NIS database.

chrism01 11-26-2009 10:15 PM

There's a nice clear NIS howto here: http://www.linuxhomenetworking.com/w...onfiguring_NIS

engelienart 11-27-2009 02:29 AM

Ok, thanx. I 'll read some more. :D


All times are GMT -5. The time now is 06:47 PM.