LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 07-25-2011, 07:22 AM   #1
inno_k
LQ Newbie
 
Registered: Jul 2011
Posts: 3

Rep: Reputation: Disabled
Unhappy Ubuntu mail server- ssl certificate how do i get it to be verified on Outlook


I used a self assigned certificate

openssl req -new -outform PEM -out smtpd.cert -newkey rsa:2048 -nodes -keyout smtpd.key -keyform PEM -days 365 -x509

i followed configurations from th below website
http://library.linode.com/email/post...t-the-hostname

On my outlook client p.c`s whenever connecting for the first it pops up a message telling mi tht my certificate on my server cannot be verified then it continues after click yes.

How do i do away with tht message other thn buying trusted certificate
Or refer me to a good site with Ubuntu mail server configuration which makes uses of mysql

these are the lines in my /etc/dovecot/dovet.conf file
ssl_cert_file = /etc/ssl/certs/dovecot.pem
ssl_key_file = /etc/ssl/private/dovecot.pem

Last edited by inno_k; 07-25-2011 at 11:33 AM.
 
Old 07-25-2011, 05:04 PM   #2
kmassare
LQ Newbie
 
Registered: Apr 2011
Location: California, US
Distribution: Fedora
Posts: 28

Rep: Reputation: 8
Copy /etc/ssl/certs/dovecot.pem onto your Windows PC. On your PC, open Internet Explorer and import the dovecot.pem certificate file (Tools->Internet Options->Content Tab->Certificates). I put mine into the Trusted Root Certification Authorities but I'm importing the self signed CA Certificate which I used to sign my dovecot certificate. In your case, I would try to import into Trusted Publishers if importing into Trusted Root Certification Authorities doesn't work.
 
Old 08-02-2011, 01:11 PM   #3
inno_k
LQ Newbie
 
Registered: Jul 2011
Posts: 3

Original Poster
Rep: Reputation: Disabled
i solved th problem

i added th following line in /etc/dovecot/dovecot.conf
just b4 ssl certficates configurations line
disable_plaintext_auth = no
 
Old 08-02-2011, 04:01 PM   #4
Noway2
Senior Member
 
Registered: Jul 2007
Distribution: Ubuntu 10.10, Slackware 64-current
Posts: 2,124

Rep: Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776
If you own the domain and it is a top level domain, e.g. mydomain.com and not mydomain.myprovider.com, you might be interested in StartSSL. They offer free certificates that are recognized by browsers and email programs, unlike self signed ones.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't Locate SSL Certificate on Server carlosinfl Linux - Server 1 12-22-2010 01:14 AM
Using ssl certificate files to pick up mail with fetchmail RandomTroll Linux - Software 0 08-04-2010 01:59 AM
ssl certificate renewal for vsftpd on ubuntu replica88 Linux - Server 2 04-14-2010 06:28 AM
SSL Certificate and PKI question, secure HTTPS connection, mail encription Rostfrei Linux - Security 2 07-28-2008 03:20 AM
LXer: Linux Postfix mail server SSL certificate installations and configuration LXer Syndicated Linux News 0 07-13-2007 11:01 AM


All times are GMT -5. The time now is 06:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration