LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 11-24-2010, 09:13 PM   #1
dgermann
Member
 
Registered: Aug 2004
Distribution: Ubuntu 8.04.1 desk; Red Hat 9.0 server
Posts: 298

Rep: Reputation: 30
Question Ubuntu 10.04 server cli resolution too small


Hi--

After installing Ubuntu 10.04 lts server, when I go to log in, the type on the screen is so small I almost need a magnifying glass!

I have tried several changes in /etc/default/grub:

uncommented line GRUB_GFXMODE=640x480
GRUB_GFXPAYLOAD_LINUX=800x600x24
GRUB_GFXPAYLOAD_LINUX=720x480x8

After each one I ran update-grub and rebooted. None of them made any difference. I suspect I am barking up the wrong tree.

How do I make this large enough to read without going blind?

Thanks!
 
Old 11-25-2010, 06:39 AM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,592
Blog Entries: 2

Rep: Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047
I think your problem is connected to KMS (Kernel Mode Setting). What graphics chip does your server use? If it is Intel try to add
Code:
915.modeset=0
to your kernel line in grub.

Last edited by TobiSGD; 11-25-2010 at 06:40 AM.
 
Old 11-25-2010, 10:58 AM   #3
dgermann
Member
 
Registered: Aug 2004
Distribution: Ubuntu 8.04.1 desk; Red Hat 9.0 server
Posts: 298

Original Poster
Rep: Reputation: 30
Question

TobiSGD--

Yes, it is an Intel mobo--d915gav.

Not sure where to add that line in grub. In etc/default/grub.cfg? There is no kernel line in that file. This version of grub does not have a menu.lst file. I do see that there is a file /boot/grub/915resolution.mod but it is a binary file.

Thanks for helping me, TobiSGD!
 
Old 11-27-2010, 08:09 AM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,592
Blog Entries: 2

Rep: Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047
Add it to the GRUB_CMDLINE_LINUX_DEFAULT line in your /etc/default/grub file, then do
Code:
update-grub
as root.
 
Old 11-27-2010, 11:30 AM   #5
dgermann
Member
 
Registered: Aug 2004
Distribution: Ubuntu 8.04.1 desk; Red Hat 9.0 server
Posts: 298

Original Poster
Rep: Reputation: 30
Question

TobiSGD--

Thanks for finding that for me, TobiSGD!

No joy, so far, but some hints perhaps. Here's what I did:

1. I added these lines to /etc/default/grub and ran grub-mkconfig -o /boot/grub/grub.cfg. Still the type is tiny.

Code:
GRUB_GFXMODE=800x600x24
#GRUB_GFXPAYLOAD_LINUX=keep
2. I commented out the line with 800x600x24 and uncommented the line already in there calling for 640x480 and ran sudo update-grub. Still the type is tiny.

3. I appended "915.modeset=0" without quotes to the end of the "GRUB_CMDLINE_LINUX_DEFAULT="quiet"" line. Upon running sudo update-grub got an error message.

4. Re-edited to put a comma in front of 915.modeset=0; still got error message.

5. Put in a second GRUB_CMDLINE_LINUX_DEFAULT= line and put in the 915.modeset=0 line here, and finally update-grub ran without complaint. When I rebooted, got a lot of error lines scrolling too fast to read--but in a larger type. (Yay!) But then it switched back to the tiny type. (Boo!)

6. Tried commenting out the old GRUB_CMDLINE_LINUX_DEFAULT="quiet" line, but still got the scrolling larger type switching to tiny.

7. Tried rebooting and holding down shift key so I could get the grub menu so I could run the "vbeinfo" to see if I just need to specify a different resolution, but got no grub menu.

Any thoughts on what I can try next?

Thanks for helping me, TobiSGD!
 
Old 11-27-2010, 12:22 PM   #6
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,592
Blog Entries: 2

Rep: Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047Reputation: 4047
Disabling modesetting should do the job. What error-message do you get when adding 915.modeset=0?
To give you an example, here is how my line looks, I have ATI-graphics, so a different modeset-option.
Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet nomodeset"
 
Old 11-27-2010, 12:40 PM   #7
dgermann
Member
 
Registered: Aug 2004
Distribution: Ubuntu 8.04.1 desk; Red Hat 9.0 server
Posts: 298

Original Poster
Rep: Reputation: 30
Question

TobiSGD--

The error message was:
Code:
/etc/default/grub: 9: 915.modeset=0: not found
Still tiny type.

Here is my /etc/default/grub file:

Code:
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet 915.modeset=0"
#GRUB_CMDLINE_LINUX_DEFAULT=915.modeset=0
GRUB_CMDLINE_LINUX=""

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480
#GRUB_GFXPAYLOAD_LINUX=720x480x8
#GRUB_GFXMODE=800x600x24
#GRUB_GFXPAYLOAD_LINUX=keep




# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_LINUX_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
I have tried that one line also as the following, but still get tiny type:

Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet nomodeset 915.modeset=0"
I feel like you have gotten me so close!

Thanks, TobiSGD!
 
Old 11-27-2010, 12:45 PM   #8
dgermann
Member
 
Registered: Aug 2004
Distribution: Ubuntu 8.04.1 desk; Red Hat 9.0 server
Posts: 298

Original Poster
Rep: Reputation: 30
Question

TobiSGD--

Bingo!

I changed the order of that line to read:
Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet 915.modeset=0 nomodeset"
and it seems to have worked!

Thank you, thank you, thank you!

Now: will this keep this resolution when I have an upgrade to say grub2? Do I need to uncomment that line "#GRUB_GFXPAYLOAD_LINUX=keep"?

Any wisdom on why it worked?

Thanks!
 
  


Reply

Tags
cli, resolution


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Another Small Victory for Ubuntu Server Edition LXer Syndicated Linux News 0 01-29-2010 01:00 PM
Small Business Server - Ubuntu Server or ClarkConnect? colours_chris Linux - Server 5 07-23-2009 06:54 AM
Screen Resolution too small when upgrading Ubuntu to 8.10 gNguyen Linux - Newbie 8 04-15-2009 02:39 PM
LXer: Ubuntu Server vs. Windows Small Business Server: Looming Showdown? LXer Syndicated Linux News 0 09-02-2008 10:50 PM
LXer: SAMBA (Domaincontroller) Server For Small Workgroups With Ubuntu 7.10 LXer Syndicated Linux News 0 11-23-2007 03:41 PM


All times are GMT -5. The time now is 05:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration