LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 07-17-2012, 02:37 PM   #1
Iyyappan
Member
 
Registered: Dec 2008
Location: Chennai, India
Distribution: CentOS 5, SLES 11
Posts: 231

Rep: Reputation: 4
Time Zone issue


In Redhat 5.7, I have 2 users one root and a user.

In root when I type date, I get

Tue Jul 17 20:33:59 CEST 2012


In Another user, when I type date I receive the following

Tue Jul 17 18:33:15 UTC 2012


I need to update CEST time zone for the non root user too. How come time zone is different for 2 different users in same machine. I want the time zone to be changed without rebooting the box. Clock in sysconfig is set to Europe only

/etc/sysconfig/clock
ZONE="Europe/Budapest"
UTC=true
ARC=false

Last edited by Iyyappan; 07-17-2012 at 03:16 PM.
 
Old 07-17-2012, 03:46 PM   #2
yancek
Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 5,122

Rep: Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818Reputation: 818
You get: Tue Jul 17 18:33:15 UTC 2012
because you have in your clock file: UTC=true when it should be: UTC=false

I have no idea why you get different times for user and root?
 
Old 07-17-2012, 03:56 PM   #3
Iyyappan
Member
 
Registered: Dec 2008
Location: Chennai, India
Distribution: CentOS 5, SLES 11
Posts: 231

Original Poster
Rep: Reputation: 4
ok I created a link between /usr/share/timezone/Europe/Budapest /etc/localtime it worked.
 
Old 07-25-2012, 08:58 PM   #4
ashujain13
LQ Newbie
 
Registered: Jul 2012
Posts: 15
Blog Entries: 1

Rep: Reputation: Disabled
Unhappy

Not able to change "UTC=true to UTC=false"

it says read only mode.

Can any one help me please please please
 
Old 08-02-2012, 05:17 AM   #5
Iyyappan
Member
 
Registered: Dec 2008
Location: Chennai, India
Distribution: CentOS 5, SLES 11
Posts: 231

Original Poster
Rep: Reputation: 4
You should have root privileges to do this.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting time and time zone altogether properly in Slack-current, KDE4 spaceballs Slackware 3 04-20-2011 06:15 AM
Run script in EST time zone but server is in GMT zone jeesun Linux - Networking 1 04-04-2010 02:37 PM
adding time zone files to the time GUI interface noir911 Red Hat 1 03-08-2010 09:18 AM
Time skew of 580 min when I set my time zone in Gentoo scooter2 Linux - Newbie 1 03-05-2009 11:27 AM
CentOS Time Zone Issue & SpamAssassin? alfista Linux - Server 14 01-17-2008 08:10 PM


All times are GMT -5. The time now is 09:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration