LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 01-17-2012, 02:31 AM   #1
spawned
LQ Newbie
 
Registered: Dec 2009
Posts: 3

Rep: Reputation: 0
TFTP service refusing connections


I've installed atftpd, and configured it as follows:

boban@netmonitor:~$ cat /etc/default/atftpd
USE_INETD=false
OPTIONS="--tftpd-timeout 300 --retry-timeout 5 --mcast-port 1758 --mcast-addr 239.239.239.0-255 --mcast-ttl 1 --maxthread 100 --verbose=9 /tftp/"

boban@netmonitor:~$ ls -ld /tftp/
drwxrwxrwx 2 nobody root 4096 2012-01-16 13:06 /tftp/


boban@netmonitor:~$ ls -l /tftp/test.txt
-rw-rw-rw- 1 nobody root 12 2012-01-16 13:06 /tftp/test.txt

boban@netmonitor:~$ cat /etc/hosts.allow
in.tftpd: LOCAL, 192.168.150.66
atftpd: LOCAL, 192.168.150.66

boban@netmonitor:~$ tftp localhost
tftp> get test.txt
Received 12 bytes in 0.0 seconds

But, from other host, I'm getting:

boban@boban:~$ tftp 192.168.150.85
tftp> get test.txt
Transfer timed out.

Logs on tftp server shows:

Jan 16 15:20:40 netmonitor atftpd[13503]: Creating new socket: 192.168.150.85:37057
Jan 16 15:20:40 netmonitor atftpd[13503]: Serving test.txt to 192.168.150.66:35725
Jan 16 15:20:40 netmonitor atftpd[13503]: will do netascii convertion
Jan 16 15:20:40 netmonitor atftpd[13503]: recvmsg: Connection refused
Jan 16 15:20:40 netmonitor atftpd[13503]: tftpd_file.c: 926: recvfrom: Connection refused
Jan 16 15:20:40 netmonitor atftpd[13503]: Aborting transfer
Jan 16 15:20:40 netmonitor atftpd[13503]: Server thread exiting

There is no iptables filtering on both sides. Is there a way to solve this?
 
Old 01-17-2012, 03:32 AM   #2
ceyx
Member
 
Registered: May 2009
Location: Fort Langley BC
Distribution: Kubuntu,Free BSD,OSX,Windows
Posts: 193

Rep: Reputation: 39
Try iptables --list or specifically allow the ports you want using UFW, and watch the ufw logs

Try installing iptraf and watch the network traffic.

I'm guessing that local host ( ie same machine loopback ) is okay, the ports across machines are blocked which they would be unless they are specifically allowed ( by you !).
 
Old 01-17-2012, 03:49 AM   #3
MartinStrec
Member
 
Registered: Jan 2012
Location: Czech
Distribution: Fedora, RHEL, Ubuntu, Mint
Posts: 110

Rep: Reputation: 13
Check if your config use 'force passive mode'. see http://slacksite.com/other/ftp.html
It means the server has to open two ports, the first port number is 21, the second is anywhere, you can set it in server settings. There is used a range (for example form 30000 to 40000 ). See your configs and allow that range for your FTP in your firewall.
 
Old 01-18-2012, 08:28 AM   #4
Reuti
Senior Member
 
Registered: Dec 2004
Location: Marburg, Germany
Distribution: openSUSE 13.1
Posts: 1,320

Rep: Reputation: 252Reputation: 252Reputation: 252
The original question was about tftp, it looks like there is no passive mode at all. Do you want to use it to boot another machine by PXE or why you chose tftp?
 
  


Reply

Tags
tftp


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Privoxy refusing connections Badfish Linux - Networking 7 05-29-2007 11:29 PM
Refusing connections? linker1981 Linux - Networking 4 07-19-2006 10:16 AM
keep refusing connections tpark Linux - Networking 1 03-04-2004 03:24 AM
Refusing Connections goldfish Linux - Newbie 16 10-09-2003 07:13 PM
Telnet yet again. (refusing connections) hornokplease Linux - Networking 2 07-21-2003 04:30 AM


All times are GMT -5. The time now is 01:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration