LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 04-18-2011, 09:52 AM   #1
sohmc
Member
 
Registered: Aug 2002
Location: Alexandria
Distribution: ubuntu 12.04.2
Posts: 217

Rep: Reputation: 30
telnet to smtp server is closing immediately


Good morning all

I've configured postfix on my linux server. For the most part, I got everything working (IMAP, apache, etc) but for some reason, I can't get postfix to work remotely.

Postfix works locally to send mail. E.g. when I telnet locally to port 25. However, when I try to telnet from outside, the connection closes almost immediately.

I've looked at various configuration options and tuning enhancements but found nothing helpful.

Here is my config:
Code:
main.cf:

#See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu) [hostname redacted]
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# TLS parameters
# smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
# smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_tls_cert_file=/etc/certs/server.CA.cert
smtpd_tls_key_file=/etc/certs/server.private.openssl.key
#smtpd_use_tls=yes
smtpd_tls_security_level=may
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = [hostname redacted]
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = [hostname redacted]
relayhost =
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128 66.71.254.242/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
home_mailbox = Maildir/
inet_protocols = all
smtpd_sasl_type = dovecot
smtpd_sasl_path = private/auth-client
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_sasl_auth_enable = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
 
Old 04-18-2011, 10:12 AM   #2
rhamel
LQ Newbie
 
Registered: Sep 2009
Posts: 12

Rep: Reputation: 2
Sounds like a firewall blocking port 25

Try nmap from another machine on your network to see if port 25 is visible. If it is, then you still have a postfix issue.

nmap <ip-of-postfix-mail-server>

HTH
 
1 members found this post helpful.
Old 04-18-2011, 10:25 AM   #3
tva
Member
 
Registered: Jul 2010
Location: Finland
Distribution: Open SUSE 13.1
Posts: 73

Rep: Reputation: 6
Are you sure your isp allows smtp server on default port?

Also 66.71.254.242/8 on mynetworks seems quite huge...
 
Old 04-18-2011, 10:44 AM   #4
sohmc
Member
 
Registered: Aug 2002
Location: Alexandria
Distribution: ubuntu 12.04.2
Posts: 217

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by rhamel View Post
Try nmap from another machine on your network to see if port 25 is visible. If it is, then you still have a postfix issue.
Since I can actually telnet into the machine, port 25 is open, as is 26 and 465. I double-checked this with both nmap and netstat.

Quote:
Originally Posted by tva View Post
Are you sure your isp allows smtp server on default port?

Also 66.71.254.242/8 on mynetworks seems quite huge...
My ISP does not allow port 25 connections, which is why I'm trying to connect via 465 (TLS). Same thing happens for port 26.
 
Old 04-18-2011, 02:29 PM   #5
sohmc
Member
 
Registered: Aug 2002
Location: Alexandria
Distribution: ubuntu 12.04.2
Posts: 217

Original Poster
Rep: Reputation: 30
It looks like the culprit was this config option:

Code:
smtpd_tls_key_file=/etc/certs/server.private.openssl.key
This key that I used was the ENCRYPTED version of the key. So I just used the unencrypted version of the key. That worked.

Now, I need to get SASL to work, which I think is completely different.

Thanks everyone!
 
  


Reply

Tags
postfix, smtpd


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Connection to SSH closing immediately scratched Linux - General 8 03-26-2007 12:49 AM
Fedora 6 - problem with terminal window closing immediately. bostonantifan Fedora 5 03-25-2007 08:21 PM
PHP mail not connecting to SMTP server but can connect with telnet mrJimmbo Linux - Server 1 12-12-2006 06:51 PM
authentication to SMTP server to avoid telnet sailu_mvn Linux - Software 2 12-20-2005 04:52 AM
Accessing an SMTP server via TELNET ganninu Linux - Security 14 12-10-2003 03:37 AM


All times are GMT -5. The time now is 02:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration