LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 05-01-2010, 05:39 PM   #1
tvc457
LQ Newbie
 
Registered: Apr 2010
Posts: 9

Rep: Reputation: 0
system time cannot be change


On installation of my OEL (Oracle Enterprise Linux), I've made a mistake, and set the date and time wrong. It's pointing to a date far in the future.

OK, so I change the date (and time), all looks OK. But when I boot, all is back to the same date (in 2015).

I'm running this OS in VMware, I don't know if this issue relates to VM or not.
 
Old 05-01-2010, 08:19 PM   #2
jstephens84
Senior Member
 
Registered: Sep 2004
Distribution: (Home)Opensolaris, Ubuntu, CentOS, (Work - AIX, HP-UX, Red Hat)
Posts: 2,056

Rep: Reputation: 94
How are you changing the date and time? are you using a command or did you install desktop manager? Not really familar with OSL.
 
Old 05-02-2010, 08:30 AM   #3
tvc457
LQ Newbie
 
Registered: Apr 2010
Posts: 9

Original Poster
Rep: Reputation: 0
GNOME GUI time settings, logged in as root
I also tried with "date", also as root

For both, I waited 1 minute, checked via the "date" command, and time was reset

All remains OK, until next boot
 
Old 05-02-2010, 07:26 PM   #4
jstephens84
Senior Member
 
Registered: Sep 2004
Distribution: (Home)Opensolaris, Ubuntu, CentOS, (Work - AIX, HP-UX, Red Hat)
Posts: 2,056

Rep: Reputation: 94
Not that this has anything to do with it but what time does your bios have?
 
Old 05-03-2010, 05:57 AM   #5
tvc457
LQ Newbie
 
Registered: Apr 2010
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jstephens84 View Post
Not that this has anything to do with it but what time does your bios have?
BIOS is OK, and so is my Windows XP running on the same hardware ... just this Linux is wrong.

There IS a message at Linux bootup, stating that previous startup is in the future. Technically spoken, this is correct. But, that would mean it is impossible to set the date back to an ealier moment in time ?!

I may need to be in special bootup mode to change time ?!
 
Old 05-03-2010, 01:00 PM   #6
tvc457
LQ Newbie
 
Registered: Apr 2010
Posts: 9

Original Poster
Rep: Reputation: 0
Went into Single User mode, did the same command ("date") and then it works OK.
 
Old 05-05-2010, 01:58 PM   #7
tvc457
LQ Newbie
 
Registered: Apr 2010
Posts: 9

Original Poster
Rep: Reputation: 0
Issue is back, system time is back to a time in the future
 
Old 05-09-2010, 01:27 PM   #8
ninohead
LQ Newbie
 
Registered: Apr 2010
Posts: 11

Rep: Reputation: 0
Probably You need to change your hardware clock...or your linux box is listing to NTP server
Hardware clock = BIOS clock

when you boot your computer..go to the bios mode (keep pressing del and all the Function keys)..you will land in bios screen(blue screen)
You might see some option in the bios which will let you to change the time.....try doing that..save the configuration ..then reboot....

might work...if its a problem with hardware clock

even check whether your box is listeing to any NTP server

Last edited by ninohead; 05-09-2010 at 01:28 PM.
 
Old 05-09-2010, 01:34 PM   #9
EricTRA
Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291
Hi,

You can change the hardware clock settings or copy from system to hw or vice versa with the hwclock command. Have you tried one of those yet? No need to reboot to see what your hwclock is set to.

From the manpage:
Code:
       hwclock -r or hwclock --show
       hwclock -w or hwclock --systohc
       hwclock -s or hwclock --hctosys
       hwclock -a or hwclock --adjust
       hwclock -v or hwclock --version
       hwclock --set --date=newdate
Kind regards,

Eric
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
change the time of the system abd_bela Debian 2 11-17-2008 09:20 AM
System time change loccom Linux - General 1 03-16-2005 10:58 AM
Cannot change system time mikemrh9 Suse/Novell 7 01-02-2005 04:06 AM
Change system time JonCooperUK Slackware 4 04-02-2004 10:41 PM
how to change the system time? h/w Linux - Newbie 12 12-29-2003 06:53 PM


All times are GMT -5. The time now is 11:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration