LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   SWAT not talking to SMB anymore in ubuntu 12.04 (http://www.linuxquestions.org/questions/linux-server-73/swat-not-talking-to-smb-anymore-in-ubuntu-12-04-a-4175428862/)

mrpurple 09-24-2012 08:01 PM

SWAT not talking to SMB anymore in ubuntu 12.04
 
1 Attachment(s)
Hi,
I have ubuntu 12.04 on a few systems and I like to use SWAT to manage my SAMBA. However, since upgrading one machine to ubuntu 12.04 and recently on another machine with a fresh install of 12.04 SWAT doesnt work anymore. Specifically, SWAT is running and accessible but when I try to create a share I get a blank screen with nothing but SAMBA and a bar? I cannot view existing shares or globals either.

Its not the "root login" issue newbies often get. I can see all the options along the top after login.

Its not SAMBA because I can manually change my SMB.conf file and create new shares which are available and working.

Its not permissions on my smb.conf file because I tried setting that to 777.

Has anyone else lost functionality of swat like I have? (twice now on seperate machines) Anyone know what might have caused it and how to fix?

I'll try and attach a pic of the non-functional page (It appears after I select the basic or advanced button in "shares".

mrpurple 11-25-2012 04:57 PM

Bumping with the fact that I'm getting this problem on a fresh install of ubuntu 12.10.

I still can't figure out why SWAT cant edit the smb.conf files and why the editing pages within swat only show the samba image appearing as per the previous post.

mrpurple 12-09-2012 07:21 PM

Bumping with solution...

Given that the standard install methods posted (almost) everywhere for installing swat produce this "broken" form, I was truely surprised no one else had come across it. Then I found this bug report on the SAMBA site:
https://bugzilla.samba.org/show_bug.cgi?id=8999
The upshot of which is that there is a bug in one of the SWAT dependancies but you can work around the bug with
Code:

sudo apt-get remove libpam-smbpass
NB: Your samba passwords will no longer be synced with your login passwords.


All times are GMT -5. The time now is 01:02 PM.