LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 08-05-2010, 09:26 AM   #1
PlatformIndependentBoy
LQ Newbie
 
Registered: Nov 2009
Location: Wales
Distribution: Fedora 11
Posts: 6

Rep: Reputation: 0
sudo ... command not found


Hello, I'm new to the unix side of things and I am working on a VMware ESXi server, I have just installed a vManagement Assistant VM.

I am attempting to set up a Dell UPS, the UPS management software needs to be installed on the vMA and i am trying to run the command 'sudo ./setup_console.bin' but get the error message '-bash: setup_console.bin command not found'.

What do I need to do here? Why is the command not found? I am in the directory where the setup_console.bin file is located when I try to run this command.

Cheers
 
Old 08-05-2010, 09:40 AM   #2
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,647

Rep: Reputation: 524Reputation: 524Reputation: 524Reputation: 524Reputation: 524Reputation: 524
Did you make setup_console.bin executable?
 
Old 08-05-2010, 10:06 AM   #3
PlatformIndependentBoy
LQ Newbie
 
Registered: Nov 2009
Location: Wales
Distribution: Fedora 11
Posts: 6

Original Poster
Rep: Reputation: 0
No, I did not. I was following some instructions which did not state that as a requirement. Does the file need to be setup as an executable? I assumed it would run as it was.

Below are the instructions:

Dell UPS Management Software Installation
To install the software:
1 Start the vMA 4.0 guest operating system.
2 Download the software from the Dell Web site (support.dell.com) or from the CD (F618R A04 or
higher) provided with the UPS.
3 Upload the software from Windows to vMA 4.0 using WinSCP tools.
4 Enter the following command to install the software:
sudo ./setup_console.bin

I thought that typing 'sudo ./setup_console.bin' would be sufficient to run it. I am evidently missing something. Man this is frustrating.

But cheers for the help!
 
Old 08-05-2010, 10:41 AM   #4
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 14,650

Rep: Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575
Quote:
Originally Posted by PlatformIndependentBoy View Post
No, I did not. I was following some instructions which did not state that as a requirement. Does the file need to be setup as an executable? I assumed it would run as it was.

Below are the instructions:

Dell UPS Management Software Installation
To install the software:
1 Start the vMA 4.0 guest operating system.
2 Download the software from the Dell Web site (support.dell.com) or from the CD (F618R A04 or
higher) provided with the UPS.
3 Upload the software from Windows to vMA 4.0 using WinSCP tools.
4 Enter the following command to install the software:
sudo ./setup_console.bin

I thought that typing 'sudo ./setup_console.bin' would be sufficient to run it. I am evidently missing something. Man this is frustrating.

But cheers for the help!
Run "chmod 755" (or 777, if you want to be a bit unsafe), on the setup_console.bin file, then try to run it. That will set the file to be executable, and allow it to run.

There are many explanations on file permissions out there, but essentially it's rwx (read, write, execute). The "read" bit is a value of 4, write is 2, and execute is 1. So, setting it to 755 would be rwxr-xr-x, meaning the OWNER (the first three settings), can do anything with it, but the GROUP and OTHERS would only be able to read and execute.
 
1 members found this post helpful.
Old 08-05-2010, 10:53 AM   #5
tommylovell
Member
 
Registered: Nov 2005
Distribution: Fedora, Redhat
Posts: 372

Rep: Reputation: 101Reputation: 101
Quote:
Originally Posted by TB0ne View Post
Run "chmod 755" (or 777, if you want to be a bit unsafe), on the setup_console.bin file, then try to run it. That will set the file to be executable, and allow it to run.
You can also
Code:
chmod +x setup_console.bin
That leaves the other bits alone and just turns on the eXecute bits. Not that it matters here, but sometimes you want to leave the other permission bits alone.
 
1 members found this post helpful.
Old 08-05-2010, 11:20 AM   #6
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 14,650

Rep: Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575
Quote:
Originally Posted by tommylovell View Post
You can also
Code:
chmod +x setup_console.bin
That leaves the other bits alone and just turns on the eXecute bits. Not that it matters here, but sometimes you want to leave the other permission bits alone.
Very true...that's another good part about Linux...always more than one way to do (and think about) things. I've always done it with the numeric method, so that's what I always go to.
 
1 members found this post helpful.
Old 08-06-2010, 08:36 AM   #7
PlatformIndependentBoy
LQ Newbie
 
Registered: Nov 2009
Location: Wales
Distribution: Fedora 11
Posts: 6

Original Poster
Rep: Reputation: 0
Thumbs up Cheers all!

Thanks for the help there guys. Even though i'm a newbie in Linux I new about file permissions but never thought about them. Doh!

Your help is much appreciated.

This forum is helping to make Unix based systems grow on me.
 
Old 08-06-2010, 12:44 PM   #8
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 14,650

Rep: Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575Reputation: 2575
Quote:
Originally Posted by PlatformIndependentBoy View Post
Thanks for the help there guys. Even though i'm a newbie in Linux I new about file permissions but never thought about them. Doh!

Your help is much appreciated.

This forum is helping to make Unix based systems grow on me.
That they do. You get VERY used to having an abundance of tools to draw upon, and ways to do things, that you just don't have with Windows.

After a while, you think "Cripes...how does anyone get ANYTHING done on a Windows box?"?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
sudo slackpkg = command not found gabrielmagno Slackware 10 06-22-2013 05:41 AM
why sudo root command not found? vitalstrike82 Suse/Novell 5 11-07-2007 08:29 PM
sudo: shutdown: command not found ekdya Fedora 2 09-29-2006 04:42 PM
bash: rpm: command not found && sudo: alien: command not found Java_Code Ubuntu 7 07-27-2006 11:57 PM
sudo: readme : command not found vishal.thorat Linux - Security 3 07-17-2003 05:56 PM


All times are GMT -5. The time now is 09:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration