LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   Starting sshd: /etc/init.d/sshd: line 113: /usr/sbin/sshd: Permission denied (http://www.linuxquestions.org/questions/linux-server-73/starting-sshd-etc-init-d-sshd-line-113-usr-sbin-sshd-permission-denied-631091/)

sumanc 03-27-2008 03:45 PM

Starting sshd: /etc/init.d/sshd: line 113: /usr/sbin/sshd: Permission denied
 
Hi,

I am running Fedore 8 (x86_64) on Intel Core 2 Duo machine. I have openssh-server.x86_64 version 4.7p1-2.fc8 installed.

When I attempt to start the SSH server as root by using the command '/etc/init.d/sshd start', I get the following message:
===================================================================================
Starting sshd: /etc/init.d/sshd: line 113: /usr/sbin/sshd: Permission denied
[FAILED]
===================================================================================
The line 113 in /etc/init.d/sshd contains: '$SSHD $OPTIONS && success || failure'

I am not being able to find out the problem. Any suggestion?


Thanks and regards,
Suman Chakrabarty.

acid_kewpie 03-27-2008 06:09 PM

assuming that you ARE root, then the only general angle i'd have is selinux. anythign from it in dmesg?

sumanc 03-27-2008 06:32 PM

Quote:

Originally Posted by acid_kewpie (Post 3102442)
assuming that you ARE root, then the only general angle i'd have is selinux. anythign from it in dmesg?


Yes, the problem was with selinux! "setenforce 0" solves the problem. :) I have not checked the dmesg yet.

acid_kewpie 03-28-2008 05:12 AM

that is *NOT* a solution, that's a dangerous workaround...

sumanc 03-28-2008 05:34 AM

Quote:

Originally Posted by acid_kewpie (Post 3102875)
that is *NOT* a solution, that's a dangerous workaround...


Certainly. But the machine is in an internal network and for my personal use. That is why I took the workaround.

While it is working now, can I ask you what would be the right way to really 'solve' the problem? Thanks.

acid_kewpie 03-28-2008 05:59 AM

well dmesg should show you the selinux violation. more often than not it's a case of using tools like chcon to correct selinux context errors rather than changing the underlying policy for selinux, although the latter is still a route to explore if need be.


All times are GMT -5. The time now is 10:05 PM.