LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
LinkBack Search this Thread
Old 02-20-2014, 07:20 PM   #1
gps1976
LQ Newbie
 
Registered: Feb 2014
Posts: 2

Rep: Reputation: Disabled
start_udev


I built two RHEL 6.5 servers that will have Oracle DBs running on them. I created a udev-disk file in /etc/udev/rules.d/ that includes the scsi ids, user/group ownership, devices names, etc. After I was done I ran partprobe and start_udev. All is good, devices names show under /dev with the correct permissions.

Problem, after reboots, disk devices show root:root as the owners. I then run command start_udev and then correct permissions appear, in this case oracleracle.

How do I fix it, so oracleracle stay after reboot?

THanks.
 
Old 02-21-2014, 12:32 PM   #2
John VV
Guru
 
Registered: Aug 2005
Posts: 12,108

Rep: Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591Reputation: 1591
add a entry for them in /etc/fstab

and mount them as rw
 
Old 02-21-2014, 12:54 PM   #3
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 1,702

Rep: Reputation: 426Reputation: 426Reputation: 426Reputation: 426Reputation: 426
Quote:
Originally Posted by John VV View Post
add a entry for them in /etc/fstab

and mount them as rw
He may be using the disks as raw table spaces - in which case, the Oracle database has total control over the disk and allocations. This can be a bit more efficient (less overhead specifically) than using a filesystem to hold files for tablespaces.

What he needs is for udev to set the ownership of the device names to that of the oracle database (last I knew this was the "oracle" login).

I think what the OP wants is in:

http://www.oracle-base.com/articles/...ux-5-and-6.php
 
Old 02-22-2014, 05:59 AM   #4
robertjinx
Member
 
Registered: Oct 2007
Location: Prague, CZ
Distribution: RedHat / CentOS / Ubuntu / SUSE / Debian
Posts: 546

Rep: Reputation: 58
Please attach the rule file, it might be easier to help.
 
Old 02-25-2014, 08:25 AM   #5
gps1976
LQ Newbie
 
Registered: Feb 2014
Posts: 2

Original Poster
Rep: Reputation: Disabled
Figured it out

Yes jpollard, you are correct. Oracle has control of the devices, so no entries in /etc/fstab, no pvcreate/vgcreate/lvcreate. Basically you only partition the disks with fdisk and configure UDEV.

The linux servers I configured use Quest/VAS to authenticate to the domain. After reboot the UDEV service started before the VAS service, so the oracle owners could not be authenticated, therefore assigning root:root.

The fix: use the uid and gid of the owner:group in place of the names within the udev-asm file created at /etc/udev/rules.d/. Below is what inside of the file looks like, for one disk.

KERNEL=="sd?1", BUS=="scsi", PROGRAM=="/sbin/scsi_id -g -u -d /dev/$parent", RESULT=="36000c295c17f976e30ac061baeb62a08", NAME="cst_data_01", OWNER="199", GROUP="209", MODE="0660"
 
Old 02-25-2014, 09:54 AM   #6
jpollard
Senior Member
 
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 1,702

Rep: Reputation: 426Reputation: 426Reputation: 426Reputation: 426Reputation: 426
If these are non-raid disks, you should be able to use LVM to set up the raid and partitions - then hand them over to Oracle.

I do think it is still better to have hardware raid external to the operating system.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] 50-udev.rules causes start_udev to hang on boot peridian Red Hat 6 08-15-2010 03:37 PM


All times are GMT -5. The time now is 11:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration