LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   SSH Not working (http://www.linuxquestions.org/questions/linux-server-73/ssh-not-working-4175450492/)

pra838 02-16-2013 10:09 PM

SSH Not working
 
This backtrack server (bt 5R3) I used morethan 6 months.SSH worked properly.I Expanded my hard disk capacity as follows (My host is RHEL 5.X and used KVM for virtualization).
#####################
#1.Stop VM
#2.mv mykvm.img mykvm.img.bkp
#3.qemu-img create -f raw addon.raw 10G
4#.cat mykvm.img.bak addon.raw >> mykvm.img
####################################

VNC and all other services work(metasploit also working).But ssh is not working.

when give following ...
root@bt:~# /etc/init.d/ssh start
root@bt:~#

No outputs.....

root@bt:~# ssh -v root@localhost
OpenSSH_5.3p1 Debian-3ubuntu6, OpenSSL 0.9.8k 25 Mar 2009
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Connecting to localhost [127.0.0.1] port 22.
debug1: connect to address 127.0.0.1 port 22: Connection refused
ssh: connect to host localhost port 22: Connection refused
root@bt:~#

######## My sshd_config file look likes this ...... ###############

root@bt:~# cat /etc/ssh/sshd_config
# Package generated configuration file
# See the sshd_config(5) manpage for details

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_dsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
AuthorizedKeysFile %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
PasswordAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication. Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes
UseDNS no
#
#
#ServerAliveInterval 60
root@bt:~#


###### Done following things #####

sshd-generate
/etc/init.d/ssh stop --- start (< --- ssh script also in init.d)


Not working.....

Please help me to rectify the issue.I saw many posts regarding this issue but not with correct solutions.Is this BT issue?

Thanks and Bestb Regards/
Prabhath

pingu 02-17-2013 03:25 AM

Is the ssh server running?
You could check with "ps -e |grep ssh" or "service ssh status"
If it's not, check the logs for more detailed info.
If it is, check firewall rules.

Skaperen 02-17-2013 02:36 PM

Any error messages with the things you did?


All times are GMT -5. The time now is 07:04 AM.