LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
LinkBack Search this Thread
Old 04-02-2008, 08:43 AM   #1
ssilayaraja
Member
 
Registered: Aug 2003
Location: chennai
Posts: 115

Rep: Reputation: 15
squidguard is not working with squid proxy


i have installed squid proxy 2.6 on my centos 5 it is working fine lateron i installaed squidguard 1.3 but squidguard is not redirectiong when the user browse unwanted websites
my question is how can i ensure wheather squidguard is working or not
 
Old 04-21-2008, 09:16 AM   #2
unixashoke
LQ Newbie
 
Registered: Mar 2008
Posts: 4

Rep: Reputation: 0
squidGuard is not working

Hi all

I am using squid 2.6 in RHEL5 I have installed squidGuard 1.3 and implanted transparent proxy. My problem is that my squidGuard is working properly when it works independently but when I have written
redirect_program /usr/local/bin/squirdGuard -c /usr/local/squidGuard/squardGuard, then the squid is not blocking the desired sites using squidGuard. Please help me to solve the problem
 
Old 04-22-2008, 07:11 AM   #3
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,615

Rep: Reputation: Disabled
I tried using squidguard using webmin. But i have have not been able to use delay pools. Though i can create delay pools i have not been able to attach them to the access control lists.
Can this be done using squidguard? I am running RHEL4
 
Old 04-22-2008, 09:31 AM   #4
ksri07091983
Member
 
Registered: Nov 2007
Location: Chennai,TamilNadu,India
Distribution: RedHat,SuSE
Posts: 65

Rep: Reputation: 15
Hi,

for this kind of issues, please paste the squid.conf and squidguard.conf so that people out there could have an idea.

Thanks
Sridhar
 
Old 05-20-2009, 11:41 AM   #5
szsahin
LQ Newbie
 
Registered: May 2009
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by unixashoke View Post
Hi all

I am using squid 2.6 in RHEL5 I have installed squidGuard 1.3 and implanted transparent proxy. My problem is that my squidGuard is working properly when it works independently but when I have written
redirect_program /usr/local/bin/squirdGuard -c /usr/local/squidGuard/squardGuard, then the squid is not blocking the desired sites using squidGuard. Please help me to solve the problem
First off all, "redirect_program" directive is used on squid 2.5 , not on squid 2.6. If you wish to make it work, replace "redirect_program" directive by "url_rewrite_program" directive. Then defining "url_rewrite_children" directive is recommended. And if there is any "redirect_children" line present, replace it by "url_rewrite_children" directive.

And for webmin users(as of 1.470), if you are using squid 2.6, unfortunately squid + squidguard webmin modules are suffering from the issue above. But it seems for squid 2.5 that squid + squidguard webmin modules are working normally.
 
Old 12-06-2010, 06:52 PM   #6
wlasarili
LQ Newbie
 
Registered: Sep 2003
Distribution: red Hat 9
Posts: 3

Rep: Reputation: 0
Webmin and Squid(squidguard)

Hi, newbie here! Got error after saving any info Squidguard at DAtabase directory "Error - Perl execution failed - Undefined subroutine &squidguard::terror called at /usr/libexec/webmin/squidguard/create_plainconf.cgi line 31.

im using CentOS 5.4v and installed webmin(webmin-1.520-1.noarch.rpm)

2nd. installed also with db4-4.3.29-8.112asp.i386.rpm but it says package db4-4.3.29-10.el5.i386 is already installed.

3rd try to install squidGuard-1.4-8.el5.i386.rpm successfully installed but iv noticed that some folders to remember which is "
/etc/squid/squidGuard.conf created as /etc/squid/squidGuard.conf.rpmnew"

hope that someone could help me and assist me... tnx
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
transparent squid proxy not working Niceman2005 Linux - Networking 5 01-17-2008 05:10 PM
msn messenger is not working with proxy squid Manjula.S Linux - Hardware 2 03-28-2007 07:06 AM
outlook not working with squid proxy server bhajan.verma Linux - Networking 7 09-22-2006 04:25 AM
working amsn through squid proxy server mchitrakar Linux - Software 2 06-04-2005 06:41 AM
squid conf: squid failed when I type insert redirect_program /usr/bin/squidguard Niceman2005 Linux - Software 1 11-24-2004 02:29 PM


All times are GMT -5. The time now is 05:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration