LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   Squid source code installation problem (http://www.linuxquestions.org/questions/linux-server-73/squid-source-code-installation-problem-771631/)

gulnawaz 11-26-2009 12:00 AM

Squid source code installation problem
 
I am Using the Squid2.7-STABLE7. the ./configure has the following options work successful

./configure --enable-storeio=”disk,aufs,ufs” --enable-removal-policies=”lru,heap” --enable-snmp --enable-delay-pools --enable-arp-acl --enable-cache-digests --enable-linux-netfilter --disable-ident-lookups --enable-underscores --enable-auth=”basic” --enable-basic-auth-helpers=NCSA --with-maxfd=8192 --enable-default-err-language=English && echo “configuration Successful”

BUT make shows the following error:

Error:
make[3]: Leaving directory `/root/Desktop/squid-2.7.STABLE7/src/fs'
Making all in repl
make[3]: Entering directory `/root/Desktop/squid-2.7.STABLE7/src/repl'
make[3]: *** No rule to make target `lib”lru.a', needed by `all-am'. Stop.
make[3]: Leaving directory `/root/Desktop/squid-2.7.STABLE7/src/repl'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/root/Desktop/squid-2.7.STABLE7/src'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/root/Desktop/squid-2.7.STABLE7/src'
make: *** [all-recursive] Error 1

Early response of any one will be highly appreciated.

Regards

Gul

knudfl 11-26-2009 05:34 AM

1 Attachment(s)
First : /root/ is not supposed to be use for compiling.
/root/ is not to be used for anything. Never.
Doing non administrative tasks as root is unsafe for you,
and a secrurity risk for all others too, if you are
connected to a network / internet.

Default for compiling can be /home/'user'/tmp/
.....
.....
Squid2.7-STABLE7 chokes in one of your options.
Take one away at a time and try again.
Patching for 2.7-STABLE7 is here :
http://packages.debian.org/squeeze/squid
> Links for squid > [squid_2.7.STABLE7-1.diff.gz]
Roll out the patch anywhere to get a folder debian/
The file 'rules' shows the used config options.

If CentOS 5.x : # yum install squid
gets you ver. 2.6 . CentOS 4.x : ver. 2.5 .

A new version with possibly more usable options
wget http://download.fedora.redhat.com/pu...2.fc13.src.rpm
> squid-3.1.0.15-2.fc13.src.rpm : All patching included.
Have a look into 'squid.spec'
.. to see the many included options.
And very easy to rebuild to 'rpm' on CentOS 5.x .
Just works !

rpmbuild -bb squid.spec
.. provides squid-3.1.0.15-2.<arch>.rpm
in /home/'user'/rpms/RPMS/<arch>/ :
> >
Setting up the rpm building account in /home/'user'/
http://www.linuxquestions.org/questi...5.1-766486/#13
..... .. :) ..

gulnawaz 12-01-2009 11:09 PM

Squid source Code Installation
 
I am using centos 2.6 and squid-2.7.STABLE7 i have uzip the squid-2.7.STABLE7 to /src
and have added the --prefix=/usr/local/squid and still i have received the following error plz quid

./cf_gen cf.data ./cf.data.depend
/bin/sh ./repl_modules.sh ”lru heap” > repl_modules.c
/bin/sh ./store_modules.sh ”disk aufs ufs” >store_modules.c
make all-recursive
make[2]: Entering directory `/src/squid-2.7.STABLE7/src'
Making all in fs
make[3]: Entering directory `/src/squid-2.7.STABLE7/src/fs'
make[3]: *** No rule to make target `lib”disk.a', needed by `all-am'. Stop.
make[3]: Leaving directory `/src/squid-2.7.STABLE7/src/fs'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/src/squid-2.7.STABLE7/src'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/src/squid-2.7.STABLE7/src'
make: *** [all-recursive] Error 1

knudfl 12-03-2009 10:30 AM

The option --enable-storeio=”disk,aufs,ufs”
will not work with all the squid 2.7...squid-3.0.STABLE20,
using ./configure --enable-storeio=”disk,aufs,ufs” .

The special files / commands etc. to do it is included in
http://download.fedora.redhat.com/pu...2.fc13.src.rpm
.. shown in post # 2 .. and in
http://download.fedora.redhat.com/pu...1.fc10.src.rpm
By doing the rpm rebuild the option will be included.
Else not.
Please read post # 2 again.
.....


All times are GMT -5. The time now is 03:18 PM.