LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 12-09-2007, 11:26 PM   #1
espiya7
Member
 
Registered: Jul 2007
Posts: 33

Rep: Reputation: 15
squid installation error


Gud day to everyone! I would like to ask you guys for help. I was installing squid2.6STABLE17 on my fc6 box. I wanted my proxy server to be transparent when i redirect packets from my packet filter firewall and at the same time allow ping requests, so I inputted the following on configure:

./configure --enable-pf-transparent --enable-icmp --prefix=/etc/squid

And so I make the file and then did make install. A floury of messages appeared and then suddenly, it stopped and an error appeared. It was something like "No headers for packet filter found, this option will not be enabled". However, squid performed just fine but its still not transparent.

How can I change my squid.conf to make it transparent and allow ping to run through it. Thanx guys!
 
Old 12-10-2007, 02:55 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,925

Rep: Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327
Quote:
an error appeared. It was something like "No headers for packet filter found, this option will not be enabled"
You need to install the kernel sources that include the missing kernel headers.
To configure squid 2.6 as a transparent proxy you need just the following line in squid.conf
Code:
http_port xx.xx.xx.xx:3128 transparent
For more details
read this (the part for 2.6 version).
 
Old 12-10-2007, 05:53 AM   #3
espiya7
Member
 
Registered: Jul 2007
Posts: 33

Original Poster
Rep: Reputation: 15
thank you for replying to my post.

I did this on my packet filter firewall:

rdr on $internal proto {tcp,udp} from any to port {80,81} -> $proxy_server port 3128


but still, it doesn't work.


So, do i have to reinstall squid again and specify the header file for me to be able to make it transparent?
 
Old 12-10-2007, 07:34 AM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,925

Rep: Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327
You must first install the kernel sources for your exact kernel version. It's in the installation CD of your distro.
Then to build squid again, you run:
Code:
make clean (to clean your previous attempt)
./configure --enable-pf-transparent --enable-icmp --prefix=/etc/squid
make
make install (as root)
 
Old 12-12-2007, 12:53 AM   #5
espiya7
Member
 
Registered: Jul 2007
Posts: 33

Original Poster
Rep: Reputation: 15
thanx man! I really appreciate your help!
 
Old 12-14-2007, 06:38 AM   #6
espiya7
Member
 
Registered: Jul 2007
Posts: 33

Original Poster
Rep: Reputation: 15
help!

my server just got doped the other day, it wasn't blocking the sites i indicated on the squid.conf. so i finally gave up and reinstalled the whole fc6 + squid2.6. but another problem went up. i tried using yum install squid but i wasnt able to start squid it always fails. then i tried another approach w/c was the make install but i can't start squid properly even though i did an /usr/local/squid/sbin/squid -NCd1 on it and reported : "Ready to accept connections" (it should be fine right?) yet my clients can't connect to it.

i really need your professional help, thanks!
 
Old 12-14-2007, 06:42 AM   #7
espiya7
Member
 
Registered: Jul 2007
Posts: 33

Original Poster
Rep: Reputation: 15
as a side note, i already gave ownership on its directories. i have really no idea as to why this is happenning.
 
Old 12-14-2007, 07:23 AM   #8
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,925

Rep: Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327
Quote:
i did an /usr/local/squid/sbin/squid -NCd1 on it and reported : "Ready to accept connections" (it should be fine right?) yet my clients can't connect to it.
. Make sure that squid is running and it's listening on the port your clients use to connect:
Code:
netstat -tapl|grep squid
 
Old 12-14-2007, 08:12 PM   #9
espiya7
Member
 
Registered: Jul 2007
Posts: 33

Original Poster
Rep: Reputation: 15
this was what i saw:

tcp 0 0 *:webcache *:* LISTEN 10002/(squid)


is this it???
 
Old 12-15-2007, 08:37 AM   #10
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,925

Rep: Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327
Yes, that means that squid is up and running. I am not sure what port webcache is, but you can find it running:
Code:
netstat -tanpl|grep squid
and see if this is the port your clients are trying to connect.

Last edited by bathory; 12-17-2007 at 02:39 AM.
 
Old 12-16-2007, 05:52 AM   #11
espiya7
Member
 
Registered: Jul 2007
Posts: 33

Original Poster
Rep: Reputation: 15
no, its not because i'm using the default port which is 3128.
 
Old 12-17-2007, 02:41 AM   #12
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,925

Rep: Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327Reputation: 1327
You should edit squid.conf and change the port to the one that your clients use to connect.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
squid installation and configuration celebnavin Linux - Server 2 10-17-2007 10:14 AM
squid installation and configuration celebnavin Linux - Newbie 1 10-02-2007 07:22 AM
Squid Installation help virgo Linux - Newbie 2 07-27-2004 02:24 AM
Squid Installation ham_madpk Linux - Networking 0 05-05-2001 07:58 AM
Squid Installation tina_gora Linux - Networking 0 05-03-2001 07:33 AM


All times are GMT -5. The time now is 04:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration