LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
LinkBack Search this Thread
Old 02-07-2011, 07:53 AM   #1
dracuss
Member
 
Registered: May 2006
Location: Chisinau, Moldova
Distribution: Gentoo, Debian sid
Posts: 151

Rep: Reputation: 29
Squid excessive memory consuming on Fedora 12


There is squid 3.1.8 on a Fedora 12 server with 2 GB of RAM. It is used for sharing the Internet for approximatively 80 PC's. The problem is that it is really a memory hog, when enabling delay pools.
I am using the following configuration for the memory pools:
Code:
delay_pools 1
delay_class 1 2
delay_access 1 allow drumuri
delay_access 1 deny all
#delay_parameters 1 10485760/10485760 #mmare 512 kbs
#delay_parameters 1 131072/131072        #1024 kbs
delay_parameters 1 524288/524288  32768/32768        #Total 4 mb, per utilizator 256 kbs
There are moments when the squid process uses approximatively all the RAM and goes into swapping. After that I restart it, it goes well for a while and again eats up all the memory.
On the Internet it says that Squid uses a lot of memory, but should it use 2 GB of memory, even if all 80 people are online at the same time?
Also, please tell me how could I minimise the memory usage. I googled for it, but found nothing regarding delay pools.

Last edited by dracuss; 02-07-2011 at 08:26 AM.
 
Old 02-08-2011, 02:35 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 26,519
Blog Entries: 51

Rep: Reputation: 2598Reputation: 2598Reputation: 2598Reputation: 2598Reputation: 2598Reputation: 2598Reputation: 2598Reputation: 2598Reputation: 2598Reputation: 2598Reputation: 2598
Moved: This thread is deemed more suitable in the Server forum and has been moved accordingly to help your thread/question get the exposure it deserves.
 
Old 02-09-2011, 01:48 AM   #3
dracuss
Member
 
Registered: May 2006
Location: Chisinau, Moldova
Distribution: Gentoo, Debian sid
Posts: 151

Original Poster
Rep: Reputation: 29
I guess that the problem is solved, now squid uses much less memory at the expense of some additional CPU activity:
I compiled squid with the --enable-dlmalloc switch, by using the SRPM from http://download.fedora.redhat.com/pu...1.fc15.src.rpm.
 
Old 06-23-2012, 06:24 AM   #4
vinit.contact
LQ Newbie
 
Registered: Apr 2009
Location: India/Uttarakhand/Roorkee
Posts: 1

Rep: Reputation: 0
Thumbs up This is working

Thanks a lot dear for this solutions.
I use this in RHEL 6.
 
  


Reply

Tags
memory, squid, swap


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Excessive Memory Usage ! kubed_lovee Linux - Server 4 10-01-2010 08:15 AM
Server consuming cache memory vikas027 Linux - Server 10 03-06-2009 01:28 AM
Consuming Memory problem aloneattack Linux - Server 2 04-08-2008 11:07 PM
excessive memory use with dropline alephnull Slackware 3 02-02-2005 01:10 PM
X uses an excessive amount of memory! ~80Mb kamstrup Linux - Software 3 08-18-2003 06:42 AM


All times are GMT -5. The time now is 08:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration