LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 08-06-2007, 03:42 AM   #1
jean-luch
LQ Newbie
 
Registered: Aug 2007
Posts: 1

Rep: Reputation: 0
Squid and NTLM authentication


I am new on this forum .
I try to install a proxy server using squid 2.6.STABLE5 for i386-debian-linux .I have installed samba, kerberos , windbind .

I have configured the squid.conf like this :
auth_param ntlm program

/usr/bin/ntlm_auth--helper-protocol=squid-2.5-basic --require-membership-of=AURUS-SYSTEMES.LOCAL\\accessweb
auth_param basic children 5
auth_param basic credentialsttl 2 hours
acl ntlm proxy_auth REQUIRED
http_access allow ntlm

I have tested the ntlm_auth and it works fine


When I run a browser using with an account not in the accessweb group , the system ask for a username password .

I cannot display any pages . The log files gives :

Aug 6 10:07:47 localhost squid[20715]: clientReadRequest: FD 22 (192.168.30.204:3383) Invalid Request
Aug 6 10:08:21 localhost squid[20715]: storeDirWriteCleanLogs: Starting...
Aug 6 10:08:21 localhost squid[20715]: WARNING: Closing open FD 23
Aug 6 10:08:21 localhost squid[20715]: commSetEvents: epoll_ctl(EPOLL_CTL_DEL): failed on fd=23: (1) Operation not permitted
Aug 6 10:08:21 localhost squid[20715]: 65536 entries written so far.
Aug 6 10:08:21 localhost squid[20715]: Finished. Wrote 109868 entries.
Aug 6 10:08:21 localhost squid[20715]: Took 0.0 seconds (3522087.6 entries/sec).
Aug 6 10:08:21 localhost squid[20715]: authenticateNTLMHandleReply: *** Unsupported helper response ***, 'ERR'
Aug 6 10:08:21 localhost squid[20676]: Squid Parent: child process 20715 exited due to signal 6
Aug 6 10:08:24 localhost squid[20676]: Squid Parent: child process 20741 started
Aug 6 10:08:24 localhost squid[20741]: Starting Squid Cache version 2.6.STABLE5 for i386-debian-linux-gnu...
Aug 6 10:08:24 localhost squid[20741]: Process ID 20741

I get the same thing when I log with an account in the appropriate accesweb group .

Any Idea or clue ?

Thanks in advance
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SQUID NTLM Authentication keeps asking for a username and password rowellb Linux - Networking 15 09-22-2009 11:11 AM
Squid NTLM authentication stevehh Linux - Networking 0 02-06-2007 10:06 AM
NTLM authentication. TheRealDeal Linux - Networking 4 10-12-2006 07:36 PM
Squid and NTLM Authentication codedv Linux - Networking 5 07-16-2006 03:46 AM
Proxy with NTLM Authentication in Console nemesys571 Slackware 3 04-01-2006 11:26 AM


All times are GMT -5. The time now is 10:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration