LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices



Reply
 
Search this Thread
Old 12-16-2011, 07:38 PM   #1
peterlowrie
Member
 
Registered: May 2009
Location: New Zealand
Distribution: mdv-x86/aurora-sparc64/solaris10-x86/solaris10-sparc
Posts: 42

Rep: Reputation: 15
Question Softraid (0) recovery situation


Gidday,

My system is a dual xeon 32bit thing with six SCSI disks. Only two of them are connected to a softraid 0 /dev/md0

My distro is Mandriva 2009.0

/dev/sdc1 is of type Linux RAID (0xfd). Start sector 63, 136gb U320.
/dev/sdf1 is ditto above. Both typed but unformatted. Then I connected them to a new RAID device /dev/md0 with xfs filesystem. Here is one rub: i am not entirely sure about the filesystem, it could be ext3 or 4. And it's mount posi was /home. It ran this way for ages and then...

The computer died because /dev/sda1 died. So I put another disk into the array at position /dev/sda and rebuilt the system from scratch.

When I reconnected /dev/sdc1 and /dev/sdf1 to a new RAID 0 disk /dev/mdo (just like before) drakconf wanted me to format the new md0 (XFS) but I didn't. Needless to say I was then unable to mount the drive at the old posi at /home.

The situation is similar to a thread by fornax entitled "softraid with mdadm" and after following this thread and others of a similar vein I have been unable to decipher the contents therein to my satisfaction. Satisfaction being the recovery of my data.

Now I have to prostrate myself before the members of www.linuxquestions.org in a hopeful attempt to find help. Feel free to dive in...

Best wishes
Peter Lowrie
 
Old 12-16-2011, 07:40 PM   #2
peterlowrie
Member
 
Registered: May 2009
Location: New Zealand
Distribution: mdv-x86/aurora-sparc64/solaris10-x86/solaris10-sparc
Posts: 42

Original Poster
Rep: Reputation: 15
the other associated issue

OK, so I get the raid disk made /dev/md0 but until I format it, it won't mount. So I have to figure out how to mount this unformatted disk??

:-| Peter
 
  


Reply

Tags
softraid


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xfs_growfs on softraid card ? p4cm4n88 Linux - Server 3 01-21-2011 11:07 AM
how to recover softraid information? rippfx Linux - Server 1 01-29-2010 10:11 PM
looking for softraid 0 how to zogthegreat Linux - Hardware 1 08-09-2009 12:44 PM
softraid-1: Disk name changes when plug in PhillipHuang Linux - General 2 02-13-2007 10:30 PM
poor softRAID 0 performance with kernel 2.6.x hcb Linux - General 1 02-03-2004 03:09 AM


All times are GMT -5. The time now is 09:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration