Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Server
User Name
Linux - Server This forum is for the discussion of Linux Software used in a server related context.


Search this Thread
Old 10-14-2009, 09:07 PM   #1
LQ Newbie
Registered: Sep 2009
Posts: 6

Rep: Reputation: 0
smtp error on sendmail but not on squirrelmail after opening port 587

I have a mail client that communicates with my dedicated server through ISP Verizon recently blocked port 25 so my mail client can't communicate. I opened port 587 in Now when I log on the password for the email account is not recognized. Also, I get a bash no such directory when i query the /etc/password file. Does anyone have any idea where my password files might be located? Clearly the password is not a real issue as i can log in on squirrel mail.

Also, is there something amiss in this snippet?

dnl #
dnl #
dnl # Rudimentary information on creating certificates for sendmail TLS:
dnl # make -C /usr/share/ssl/certs usage
dnl #
dnl define(`confCACERT_PATH',`/usr/share/ssl/certs')
dnl define(`confCACERT',`/usr/share/ssl/certs/ca-bundle.crt')
dnl define(`confSERVER_CERT',`/usr/share/ssl/certs/sendmail.pem')
dnl define(`confSERVER_KEY',`/usr/share/ssl/certs/sendmail.pem')
dnl #
dnl # This allows sendmail to use a keyfile that is shared with OpenLDAP's
dnl # slapd, which requires the file to be readble by group ldap
dnl #
dnl define(`confDONT_BLAME_SENDMAIL',`groupreadablekeyfile')dnl
dnl #
define(`LUSER_RELAY', `local:undeliverable')dnl
dnl define(`confTO_QUEUEWARN', `4h')dnl
dnl define(`confTO_QUEUERETURN', `5d')dnl
dnl define(`confQUEUE_LA', `12')dnl
dnl define(`confREFUSE_LA', `18')dnl
define(`confTO_IDENT', `0')dnl
dnl FEATURE(delay_checks)dnl
FEATURE(`mailertable',`hash -o /etc/mail/mailertable.db')dnl
FEATURE(`virtusertable',`hash -o /etc/mail/virtusertable.db')dnl
FEATURE(`genericstable',`hash -o /etc/mail/genericstable.db')dnl
dnl #
dnl # The -t option will retry delivery if e.g. the user runs over his quota.
dnl #
FEATURE(local_procmail,`',`procmail -t -Y -a $h -d $u')dnl
FEATURE(`access_db',`hash -T<TMPF> -o /etc/mail/access.db')dnl
dnl #
dnl # The following causes sendmail to only listen on the IPv4 loopback address
dnl # and not on any other network devices. Remove the loopback
dnl # address restriction to accept email from the internet or intranet.
dnl #
dnl DAEMON_OPTIONS(`Port=smtp,Addr=, Name=MTA')dnl
DAEMON_OPTIONS(`Port=smtp, Name=MTA')dnl
dnl #
dnl # The following causes sendmail to additionally listen to port 587 for
dnl # mail from MUAs that authenticate. Roaming users who can't reach their
dnl # preferred sendmail daemon due to port 25 being blocked or redirected find
dnl # this useful.
dnl #
DAEMON_OPTIONS(`Port=submission, Name=MSA, M=Ea')dnl
dnl #
dnl # The following causes sendmail to additionally listen to port 465, but
dnl # starting immediately in TLS mode upon connecting. Port 25 or 587 followed
dnl # by STARTTLS is preferred, but roaming clients using Outlook Express can't
dnl # do STARTTLS on ports other than 25. Mozilla Mail can ONLY use STARTTLS
dnl # and doesn't support the deprecated smtps; Evolution <1.1.1 uses smtps
dnl # when SSL is enabled-- STARTTLS support is available in version 1.1.1.
dnl #
dnl # For this to work your OpenSSL certificates must be configured.
dnl #
dnl # DAEMON_OPTIONS(`Port=smtps, Name=TLSMTA, M=s')dnl
dnl #
dnl # The following causes sendmail to additionally listen on the IPv6 loopback
dnl # device. Remove the loopback address restriction listen to the network.
dnl #
dnl # NOTE: binding both IPv4 and IPv6 daemon to the same port requires
dnl # a kernel patch
dnl #
dnl DAEMON_OPTIONS(`port=smtp,Addr=::1, Name=MTA-v6, Family=inet6')dnl
dnl #
dnl # We strongly recommend not accepting unresolvable domains if you want to
dnl # protect yourself from spam. However, the laptop and users on computers
dnl # that do not have 24x7 DNS do need this.
dnl #
dnl FEATURE(`accept_unresolvable_domains')dnl
dnl #
dnl FEATURE(`relay_based_on_MX')dnl
dnl #
dnl # Also accept email sent to "localhost.localdomain" as local email.
dnl #
dnl #
dnl # The following example makes mail from this host and any additional
dnl # specified domains appear to be sent from
dnl #
dnl MASQUERADE_AS(`')dnl
dnl #
dnl # masquerade not just the headers, but the envelope as well
dnl #
dnl FEATURE(masquerade_envelope)dnl
dnl #
dnl # masquerade not just, but @* as well
dnl #
dnl FEATURE(masquerade_entire_domain)dnl
dnl #
dnl MASQUERADE_DOMAIN(localhost)dnl
dnl MASQUERADE_DOMAIN(localhost.localdomain)dnl
define(`SMTP_MAILER_FLAGS', `k')dnl
Kdomainmap text -k0 -v2 /etc/virtualhosting/mappings/sendmail.domainmap
Kquotacheck program /usr/lib/opcenter/sendmail/quotacheck
Kadv_quotacheck program /usr/lib/opcenter/sendmail/adv_quotacheck
Kmount_table text -a<DEVICE_FOUND> -k1 -v0 /etc/mtab
Kstore_it_in macro
Ksleep program /bin/sleep

Thanks for your help.

Old 10-16-2009, 06:18 AM   #2
Forrest Coredump
Registered: Oct 2009
Location: Southwestern United States
Distribution: Redhat Enterprise Linux 4-5 (Current RHCE), Fedora Core 11 (FC11), Arch Linux, BT3 (Current GCIH)
Posts: 42

Rep: Reputation: 16
Change/add the following and rebuild your sendmail.conf file paying attention to the order(remember you need to listen on both 25 and 537);


dnl DAEMON_OPTIONS(`Port=submission, Name=MSA, M=Ea’)dnl


DAEMON_OPTIONS(`Port=587, Name=MSA, M=Ea’)dnl
DAEMON_OPTIONS(`Port=25, Name=MTA')dnl

m4 /etc/mail/ > /etc/mail/

You should be good to go then....
Old 10-16-2009, 11:16 PM   #3
LQ Newbie
Registered: Sep 2009
Posts: 6

Original Poster
Rep: Reputation: 0
Thanks, Forest.
I haven't had the chance to do this yet but it just looks right.

Old 10-18-2009, 07:43 PM   #4
LQ Newbie
Registered: Sep 2009
Posts: 6

Original Poster
Rep: Reputation: 0
I made the changes but I am still getting a password error, Invalid username or password.
I even went into the server via the Ensim control panel and deleted the user then recreated it with to confirn the password but I still get the password error. I can't receive or send through the mailbox.

I can't find the /preferences/passwords file where, I think, the passwords are supposed to be stored.
Old 10-18-2009, 07:49 PM   #5
LQ Newbie
Registered: Sep 2009
Posts: 6

Original Poster
Rep: Reputation: 0
I made the changes in but I'm still getting a "invalid user id or password".
I went into the server via Ensim control panel to verify the password and user name. I even deleted the user and then recreated it to be certain of the password and username, but I still get the same error.

I think the password is supposed to be stored in a /preferences/passwords file but I can't find that file. Any clues?


open, password, port, sendmail, smtpauth

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sendmail SMTP relay error but only from some ISPs ThickGit Linux - Server 5 06-06-2009 03:01 AM
CHANGE SMTP port to 587 in Evolution Email Mgr Fedora 10 KFL Fedora 3 01-22-2009 11:45 AM
qmail smpt port 25...587 coupleofquestions Linux - Server 1 12-03-2006 02:30 PM
Switch SMTP port from 25 to 587 hardwired Linux - Networking 7 05-31-2004 09:48 AM
Sendmail / Squirrelmail - external ISP blocked port 25 piers Linux - Newbie 5 04-27-2003 09:42 AM

All times are GMT -5. The time now is 01:04 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration