LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Server (http://www.linuxquestions.org/questions/linux-server-73/)
-   -   SLES 11.2 Samba Server with Win7 Clients (http://www.linuxquestions.org/questions/linux-server-73/sles-11-2-samba-server-with-win7-clients-791786/)

pnguyen 02-26-2010 01:14 PM

SLES 11.2 Samba Server with Win7 Clients
 
Hello Everyone,

I just installed SLES 11.2 X86_64 and have SMB Server started after adding 2 lines to smb.conf:
1. NTMLv2 = Yes
2. name resolve order = wins bcast host lmhosts

There are also 02 new DWORD lines I add to Win7 clients
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanManWorkstation\Parameters

1. DomainCompatibilityMode = 1
2. DNSNameResolutionRequired = 0

Of course a few number of modifications I made from Yast to enable SMB Server and Client, and bcast as well. Now I am able to join my Linux Domain without error at first reboot from win7, but it seems spending a long time about 30 secs for auth. even I test on a very fast network system, all with core quad 3GHZ CPU and 4GB DDR2
I would like to mention here that before I made the above changes I did a lot of different modifications onto my win7 clients (I found many suggestions online), and all seems mess up and never work; Then I had to reinstall win7 from scratch and just add 02 lines as above, but it works.

Please let me know what more I need to modify from both systems to make it work fast and correctly. Thanks in advance!

Pnguyen

TB0ne 02-26-2010 01:40 PM

Quote:

Originally Posted by pnguyen (Post 3878046)
Hello Everyone,

I just installed SLES 11.2 X86_64 and have SMB Server started after adding 2 lines to smb.conf:
1. NTMLv2 = Yes
2. name resolve order = wins bcast host lmhosts

There are also 02 new DWORD lines I add to Win7 clients
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanManWorkstation\Parameters

1. DomainCompatibilityMode = 1
2. DNSNameResolutionRequired = 0

Of course a few number of modifications I made from Yast to enable SMB Server and Client, and bcast as well. Now I am able to join my Linux Domain without error at first reboot from win7, but it seems spending a long time about 30 secs for auth. even I test on a very fast network system, all with core quad 3GHZ CPU and 4GB DDR2
I would like to mention here that before I made the above changes I did a lot of different modifications onto my win7 clients (I found many suggestions online), and all seems mess up and never work; Then I had to reinstall win7 from scratch and just add 02 lines as above, but it works.

Please let me know what more I need to modify from both systems to make it work fast and correctly. Thanks in advance!

Pnguyen

Sorry, this is a Windows problem. From what I've read, there is a known issue with Windows 7 and pretty much ANYTHING else, except other Windows boxes.

There's nothing you can change on Linux to make this work.

pnguyen 03-12-2010 12:01 PM

Quote:

Originally Posted by TB0ne (Post 3878076)
Sorry, this is a Windows problem. From what I've read, there is a known issue with Windows 7 and pretty much ANYTHING else, except other Windows boxes.

There's nothing you can change on Linux to make this work.

Thank you anyway! Then I just wait for a patch from Microsoft???

TB0ne 03-12-2010 12:16 PM

Quote:

Originally Posted by pnguyen (Post 3895985)
Thank you anyway! Then I just wait for a patch from Microsoft???

Well, since it's not a Linux problem, what do you think????


All times are GMT -5. The time now is 08:06 AM.