LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 01-03-2013, 10:26 PM   #1
said76
Member
 
Registered: Aug 2011
Posts: 97

Rep: Reputation: Disabled
Set up UPS on Ubuntu Server


Hi,

I just got a UPS Eaton Powerware 5110 1000A that I'd like to plug into my Ubuntu Server 12.04 LTS. I have done this with machine running on Windows XP SP3. However, as I'm quite familiar but not too savvy with Linux machine, I'm not sure if I should set it up using the CD that comes with the UPS or from the following link that teaches how to install 5110 on Ubuntu

https://help.ubuntu.com/community/Po...5110UPSin12.04

Any help would be greatly appreciated.

Thank you
 
Old 01-03-2013, 10:59 PM   #2
Ser Olmy
Senior Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 1,985

Rep: Reputation: Disabled
Eaton has their own, propriatary management software which come bundled with their UPS units and can be downloaded from their web site as well.

The link points to an article describing how monitor a 5110 using Network UPS Tools, a free, open-source power management tool.

You may use either program to manage your UPS.
 
Old 01-17-2013, 02:24 AM   #3
said76
Member
 
Registered: Aug 2011
Posts: 97

Original Poster
Rep: Reputation: Disabled
Thank you for your reply.

Sorry for the late reply.

I decided to follow the steps from the link mentioned in my opening thread which is https://help.ubuntu.com/community/Po...5110UPSin12.04

1. install nut by "apt-get install nut"
<...>
However, I was stuck at the point where I need to edit the following file:
gksudo gedit /etc/udev/rules.d/99_nut-serialups.rules

Well, there is no such file as 99_nut-serialups.rules under /etc/udev/rules.d.

I'm not sure if this procedure is designed for a normal Ubuntu desktop 12.04, not for Server 12.04.

Any help would be greatly appreciated.

Thank you
 
Old 01-17-2013, 03:00 AM   #4
Ser Olmy
Senior Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 1,985

Rep: Reputation: Disabled
Quote:
Originally Posted by said76 View Post
However, I was stuck at the point where I need to edit the following file:
gksudo gedit /etc/udev/rules.d/99_nut-serialups.rules

Well, there is no such file as 99_nut-serialups.rules under /etc/udev/rules.d.
Did you try creating one?
 
Old 01-17-2013, 07:50 PM   #5
said76
Member
 
Registered: Aug 2011
Posts: 97

Original Poster
Rep: Reputation: Disabled
Thank you for your reply.

No, I didn't. I can try to create one and see what happens.

Thank you very much
 
Old 01-22-2013, 03:46 PM   #6
said76
Member
 
Registered: Aug 2011
Posts: 97

Original Poster
Rep: Reputation: Disabled
Thank you for your reply.

I have been testing it for a couple of days consecutively because the first and the second days did not work as I wanted it to.

What happened was it did not shut down immediately when the power went out although I had set "SHUTDOWNCMD" to "/sbin/shutdown -h now". I actually waited for a couple of minutes and it still did not shut down. I did not get any message that's indicating it's going to shutdown in x minutes or something at all.

This is how I installed it based on the link I mentioned in my opening post.

Installing: apt-get install nut
Editing /etc/nut/ups.conf :
[Powerware5110]
driver = bcmxcp_usb
port = auto

I use port=auto Since I use USB cable to connect my Powerware 5110 to my Ubuntu server 12.04 LTS

I created a file /etc/udev/rules.d/99_nut-serialups.rules and add the following:
KERNEL=="ttyS0", GROUP="nut"

Then, Start:
$ sudo udevadm control --reload-rules
$ sudo udevadm trigger
$ sudo upsdrvctl start

Network UPS Tools - UPS driver controller 2.4.6
Network UPS Tools - BCMXCP UPS driver 0.25 (2.4.6)
USB communication subdriver 0.19

Editing /etc/nut/upsd.conf by adding and save:
ACL all 0.0.0.0/0
ACL localhost 127.0.0.1/32
ACCEPT localhost
REJECT all

Editing /etc/nut/upsd.users by adding and save:
[mysystemuser]
password = __YOUR_PASSWORD_HERE__
allowfrom = localhost
upsmon master

Editing /etc/nut/upsmon.conf
This, I'm not sure if I did it right. I actually commented those existing variables in every lines and add the followings to the last line:
MONITOR Powerware5110@localhost 1 mysystemuser __YOUR_PASSWORD_HERE__ master
POWERDOWNFLAG /etc/killpower
SHUTDOWNCMD "/sbin/shutdown -h now"

and save.

then, change permissions
sudo chown root:nut /etc/nut/*
sudo chmod 640 /etc/nut/*

Editing /etc/default/nut
START_UPSD=yes
START_UPSMON=yes

Editing /etc/nut/nut.conf
MODE=standalone

Start nut: sudo /etc/init.d/nut start

Then, did sudo upsc Powerware5110 and received the following:
ambient.temperature.high: 137
ambient.temperature.low: 34
battery.charge.low: 22
battery.voltage: 26.9
device.mfr: Eaton
device.model: POWERWARE UPS 1000i
device.serial:
device.type: ups
driver.name: bcmxcp_usb
driver.parameter.pollinterval: 2
driver.parameter.port: auto
driver.version: 2.6.3
driver.version.internal: 0.25
input.frequency: 50.1
input.frequency.high: 55
input.frequency.low: 45
input.frequency.nominal: 50
input.transfer.boost.high: 216
input.transfer.high: 280
input.transfer.low: 186
input.transfer.trim.low: 260
input.voltage: 246
input.voltage.nominal: 240
output.current: 0.6
output.current.nominal: 2.5
output.frequency: 50.1
output.phases: 1
output.voltage: 246
output.voltage.nominal: 240
ups.beeper.status: enabled
ups.firmware: Cont:00.50 Inve:01.50
ups.load: 24.0
ups.mfr: Eaton
ups.model: POWERWARE UPS 1000i
ups.power.nominal: 1000
ups.serial:
ups.status: OL

So it seems like everything is working fine.

When I deliberately switched my main power off, I could hear my powerware 5110 start beeping and saw the "ups.status: ALARM OB".

So everything looks fine. But it didn't turn off the server right away.

WOndering if you could advice me where I did it wrong that might cause it not to work properly.

Thank you
 
Old 01-22-2013, 06:35 PM   #7
Ser Olmy
Senior Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 1,985

Rep: Reputation: Disabled
Normally, nut will not initiate shutdown until the UPS reports a low battery condition. If that's not wat you want, take a look at man upssched.
 
Old 01-23-2013, 05:00 PM   #8
said76
Member
 
Registered: Aug 2011
Posts: 97

Original Poster
Rep: Reputation: Disabled
Thank you for your reply.

Yes, you're absolutely right about using the upssched. After reading the upssched manual as suggested, it now does what I want it to do that is wait for 60 secs before shutting down.

It's all good now

Thank you for your help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: How To Set Up A Feng Office Suite Web Server On Ubuntu Server 10.10 LXer Syndicated Linux News 0 04-04-2011 12:00 PM
LXer: How To Set Up A Webgui Based Print Server On Ubuntu Server Using SWAT, CUPS, And SAMBA LXer Syndicated Linux News 0 08-20-2010 01:40 PM
How to set up subdomains on Ubuntu Server LazerPhreak Linux - Server 4 01-22-2010 05:38 AM
Trying to set-up a web server on ubuntu 5.10 jazee Linux - Software 4 03-14-2006 11:19 PM
random hard lock ups on nforce2 chip set mobo? 5mi11er Linux - Hardware 3 08-26-2004 11:11 PM


All times are GMT -5. The time now is 11:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration