LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
LinkBack Search this Thread
Old 06-15-2007, 10:46 AM   #1
Eduardain
LQ Newbie
 
Registered: Aug 2006
Posts: 6

Rep: Reputation: 0
Server shutdowns by itself


Hello
I'm trying to find out why my server is powering off by itself. I would like to know where the problem is. It seems to be a cron job because it goes down every day same hour. This is the log I have from the hour it happens
Jun 14 16:03:59 salome syslogd 1.4.1: restart.
How can I avoid this?
Thanks
 
Old 06-15-2007, 11:13 AM   #2
p_s_shah
Member
 
Registered: Mar 2005
Location: India
Distribution: RHEL 3/4, Solaris 8/9/10, Fedora 4/8, Redhat Linux 9
Posts: 212
Blog Entries: 1

Rep: Reputation: 33
Check your crontab using crontab -l .
Check your /etc/cron.daily directory also, if there is any script which restart the server.
And provide detailed logs from /var/log/messages for troubleshooting.
 
Old 06-16-2007, 11:22 AM   #3
Eduardain
LQ Newbie
 
Registered: Aug 2006
Posts: 6

Original Poster
Rep: Reputation: 0
Hi, thanks for your help
I ran crontab -l from root in I got no crontab for root
also I have another user but there's no cron script to restart the server. do you know how to see enviroment logs? also I saw in my snmp server that the server is not going down at same time. snmp server logs has 30min to 1 hour of difference.

in /var/log/messages, the logs before shutdown and after power on

Jun 14 16:07:13 salome kernel: Bluetooth: HCI socket layer initialized
Jun 14 16:07:13 salome kernel: Bluetooth: L2CAP ver 2.8
Jun 14 16:07:14 salome kernel: Bluetooth: L2CAP socket layer initialized
Jun 14 16:07:14 salome kernel: Bluetooth: RFCOMM socket layer initialized
Jun 14 16:07:14 salome kernel: Bluetooth: RFCOMM TTY layer initialized
Jun 14 16:07:14 salome kernel: Bluetooth: RFCOMM ver 1.8
Jun 14 16:07:14 salome kernel: Bluetooth: HIDP (Human Interface Emulation) ver 1.1
Jun 15 16:04:06 salome syslogd 1.4.1: restart.
Jun 15 16:04:07 salome kernel: klogd 1.4.1, log source = /proc/kmsg started.
Jun 15 16:04:07 salome kernel: Linux version 2.6.18-8.el5 (mockbuild@builder4.centos.org) (gcc version 4.1.1 20070105 (Red Hat 4.1.1-52)) #1 SMP Thu Mar 15 19:57:35 EDT 2007
Jun 15 16:04:07 salome kernel: BIOS-provided physical RAM map:
Jun 15 16:04:07 salome kernel: BIOS-e820: 0000000000000000 - 000000000009f000 (usable)
 
Old 06-17-2007, 11:21 PM   #4
p_s_shah
Member
 
Registered: Mar 2005
Location: India
Distribution: RHEL 3/4, Solaris 8/9/10, Fedora 4/8, Redhat Linux 9
Posts: 212
Blog Entries: 1

Rep: Reputation: 33
Have you checked scripts in /etc/cron.daily ?
Also cross check again crontab files of all users in /var/spool/cron/.

Run a script at 16:00 which grabs output of ps -efc or ps aux into a file every minute. Check the file after server restart to find out if there is any process/script which is causing server restart.

Time difference between your server and SNMP logs may be due to different time settings on both servers. Run date command on both servers at the same time and check difference between them. If this is the cause, setup NTP for synchronized timings.

Update us your findings.
 
Old 06-19-2007, 11:43 AM   #5
Eduardain
LQ Newbie
 
Registered: Aug 2006
Posts: 6

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by p_s_shah
Have you checked scripts in /etc/cron.daily ?
Also cross check again crontab files of all users in /var/spool/cron/.

Run a script at 16:00 which grabs output of ps -efc or ps aux into a file every minute. Check the file after server restart to find out if there is any process/script which is causing server restart.

Time difference between your server and SNMP logs may be due to different time settings on both servers. Run date command on both servers at the same time and check difference between them. If this is the cause, setup NTP for synchronized timings.

Update us your findings.
thanks for your help, I started to read, and I find there is an option on BIOS where it is a power management setting. I disable an option called ACPI, and the problem is gone. The problem was that ACPI recognice when a device as monitor, keyboard, etc is not connected then it forces the system to make a power safe and shutdown
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux shutdowns sernan Linux - Newbie 4 09-05-2005 09:32 AM
Scheduling shutdowns avenolpey Debian 1 06-01-2005 10:05 PM
system shutdowns KDElinux Linux - Software 2 12-30-2004 04:38 PM
Soft shutdowns Maverick1182 Linux - Newbie 4 08-17-2004 07:13 AM
Bad Shutdowns SierraClassic35 Linux - General 7 09-17-2001 11:45 PM


All times are GMT -5. The time now is 02:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration