LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Server
User Name
Password
Linux - Server This forum is for the discussion of Linux Software used in a server related context.

Notices

Reply
 
Search this Thread
Old 11-19-2008, 02:54 AM   #1
archiac
LQ Newbie
 
Registered: Nov 2008
Location: Woodstock, GA [USA]
Distribution: Slackware
Posts: 10

Rep: Reputation: 0
Sendmail with IPv6 support


There are many helps and howto's however, I'm still stuck with this issue.
But I have nothing that can clearly aide in the solution to my issue at this point now.

Quote:
Nov 19 02:42:15 phemur sm-mta[2180]: NOQUEUE: --- 451 4.0.0 opendaemonsocket: daemon MTA-v6: cannot bind: Address already in use (hold)
Nov 19 02:42:15 phemur sm-mta[2180]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA-v6: cannot bind: Address already in use
Nov 19 02:42:15 phemur sm-mta[2180]: daemon MTA-v6: problem creating SMTP socket
Nov 19 02:42:15 phemur sm-mta[2180]: NOQUEUE: --- 421 4.0.0 opendaemonsocket: daemon MTA-v6: server SMTP socket wedged: exiting (hold)
Nov 19 02:42:15 phemur sm-mta[2180]: NOQUEUE: SYSERR(root): opendaemonsocket: daemon MTA-v6: server SMTP socket wedged: exiting
And tonight I'm here.
Quote:
ipv6: exports duplicate symbol inet6_unregister_protosw (owned by kernel)
Here's the process I have taken thus far.

Download sendmail any version still available. Current working with 8.12.11.
Here is my site.config.m4
Code:
dnl ### Changes to disable the default NIS support
APPENDDEF(`confENVDEF', `-UNIS')

dnl ### Changes for PH_MAP support.
dnl# APPENDDEF(`confMAPDEF',`-DPH_MAP')
dnl# APPENDDEF(`confLIBS', `-lphclient')
dnl# APPENDDEF(`confINCDIRS', `-I/opt/nph/include')
dnl# APPENDDEF(`confLIBDIRS', `-L/opt/nph/lib')

dnl ### Changes for STARTTLS support
APPENDDEF(`confENVDEF',`-DSTARTTLS')

APPENDDEF(`confENVDEF',`-DSASL=2')
APPENDDEF(`confENVDEF',`-DMILTER')

APPENDDEF(`confLIBS', `-lssl -lcrypto -lsasl2')
APPENDDEF(`confLIBDIRS', `-L/usr/local/ssl/lib -R/usr/local/ssl/lib')
APPENDDEF(`confINCDIRS', `-I/usr/local/ssl/include')

APPENDDEF(`confENVDEF', `-DNETINET6 -DNEEDSGETIPNODE')
APPENDDEF(`conf_sendmail_ENVDEF',`-DNETINET6 -DNEEDSGETIPNODE')
As you can see I have included the compile options to include IPv6 support into the sendmail build.

As shown below I have been working / playing with this for quite some time now.
mailhub.mc file
Code:
dnl # enable both ipv6 and ipv4 in sendmail:                                                                                     
dnl #   
dnl # DAEMON_OPTIONS(`Name=MTA-IPv4, Family=inet')dnl                                                                                                                          
dnl # DAEMON_OPTIONS(`Name=MTA-IPv4, Family=inet, Addr=70.88.178.103')dnl                                                                            
dnl # DAEMON_OPTIONS(`Name=MTA-IPv6, Family=inet6, Addr=[IPv6:2001:470:5:35::102]')dnl                                                                          
dnl # DAEMON_OPTIONS(`Name=MTA-IPv6, Family=inet6, Addr=2001:470:5:35::102')dnl                                                                          
dnl # DAEMON_OPTIONS(`Name=MTA-IPv6, Family=inet6')dnl                                                                           
define(`confBIND_OPTS',`WorkAroundBrokenAAAA')dnl
I do not have any IPv6 modules loaded as everything is built into my kernel.
Quote:
root@phemur:/etc/mail$ lsmod
Module Size Used by
lp 13348 0
parport_pc 27556 1
parport 34632 2 lp,parport_pc
fuse 45588 1
i2c_piix4 11020 0
3c59x 42920 0
intel_agp 25236 1
i2c_core 22528 1 i2c_piix4
uhci_hcd 25996 0
mii 8448 1 3c59x
shpchp 32788 0
agpgart 30664 1 intel_agp
evdev 12672 0
root@phemur:/etc/mail$
Needless to say, I'm at a lose, I have been using sendmail for quite some time now, and have grown quite fond of it, and do not really want to move to another software. So please don't make that suggestion. I'm seeking some assistance to trouble shoot the error listed above.

I know that it is NOT listening twice, it seems to me that the IPv6 address is trying to bind to the IPv4 address, and this is why I am receiving this error.

Here's a netstat -an
Quote:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 0.0.0.0:37 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:110 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:143 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:113 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN
tcp 0 224 70.88.178.102:22 70.88.178.97:56164 ESTABLISHED
tcp6 0 0 :::22 :::* LISTEN
udp 0 0 0.0.0.0:512 0.0.0.0:*
udp 0 0 0.0.0.0:37 0.0.0.0:*
Thanks in advance.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ipv6 support lq wanghao LQ Suggestions & Feedback 2 11-14-2007 10:41 PM
How to add ipv6 support to kernel 2.4.21 raver Linux - Networking 4 08-14-2007 07:05 PM
gdm ipv6 or ipv4 support? shanenin Linux - Software 2 03-03-2005 09:23 PM
IPv6 support and configuration for RH 8.0 davloz Red Hat 0 01-21-2004 04:49 AM


All times are GMT -5. The time now is 12:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration