Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Server
User Name
Linux - Server This forum is for the discussion of Linux Software used in a server related context.


  Search this Thread
Old 04-21-2009, 02:42 PM   #1
Registered: Mar 2005
Posts: 141

Rep: Reputation: 15
Sendmail not using FQDN in HELO even though hostname setting is correct.

I'll start with the prefix warning that I've very unfamiliar with sendmail, I personally run and prefer postfix, but my new job uses sendmail for all their mailservers.

We have 3 sendmail servers, (1 primary and 2 that handle outgoing email) and one of them is not sending a FQDN during the HELO process. I've already searched and double checked against every solution I've seen posted so I'm hoping someone can suggest something I may have missed.

Here is what I'm seeing in remote logs when I test email.

Apr 21 11:27:13 nix postfix/smtpd[22176]: <[]: HELO gandalf
and I'm also seeing bounce back emails containing info like:

<<< 553 Bogus helo gandalf. <>
When I telnet to the server in question port 25 I see the FQDN in the banner

220 ESMTP Sendmail 8.13.8/8.12.11; Tue, 21 Apr 2009 11:20:59 -0700
and both uname -a and the hostname command show the FQDN

# Do not remove the following line, or various programs
# that require network functionality will fail. gandalf localhost.localdomain localhost
#::1    localhost6.localdomain6 localhost6 gandalf

These settings are identical to two other sendmail servers and this is the only one not sending a FQDN in a helo statement. I'd greatly appreciate if anyone could tell me why this server is misbehaving as the primary sysadmin who is very familiar with sendmail is out this week.
Old 04-21-2009, 04:39 PM   #2
LQ Guru
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,205

Rep: Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394
Check the Dj variable in the working and not working
If sendmail cannot identify the domain name (lack of /etc/resolv.conf) you can use:
Old 04-21-2009, 10:39 PM   #3
Registered: Mar 2005
Posts: 141

Original Poster
Rep: Reputation: 15
Thanks for the suggestion but in further testing I narrowed the problem down a php script and not the mail server itself (normal email had the correct ehlo, script generated email didn't). I'm not sure why sendmail allowed it, but a variable of $mail_server = 'gandalf'; was causing the problem. Changing it to $mail_server = ''; resolved it.


helo, rhel, sendmail

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
hostname, fqdn, /etc/hosts setup [GOD]Anck Slackware 9 07-20-2010 05:51 PM
best pratice for hostname? FQDN vs short? zerobane Linux - Networking 1 02-03-2009 02:45 PM
Forcing sendmail to use HELO the_gripmaster Linux - Server 4 10-08-2008 04:07 AM
helo fqdn restriction dlublink Linux - Software 1 10-13-2006 10:26 PM
Sendmail settings. Will sendmail always answer "helo". (and tracing blocked port 25) Bjorkli Linux - Networking 5 05-24-2004 04:13 AM

All times are GMT -5. The time now is 09:33 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration